summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2024-05-01 11:52:56 +0200
committerAlphaJack2024-05-01 11:52:56 +0200
commite65b3dff5f6a0f205cbb5476b0274601627fb3c8 (patch)
tree370aacfe380da4b4e5ffa9b3b84452d521f14586
parent6ed9b9951d7363f41ac90cb981f2bd1a44a3d470 (diff)
downloadaur-e65b3dff5f6a0f205cbb5476b0274601627fb3c8.tar.gz
Updated aider-chat to 0.30.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d526130f8c4..efdac346190e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = aider-chat
pkgdesc = AI pair programming in your terminal
- pkgver = 0.30.0
+ pkgver = 0.30.1
pkgrel = 1
url = https://aider.chat/
arch = any
@@ -33,7 +33,7 @@ pkgbase = aider-chat
optdepends = python-soundfile: portaudio support
provides = aider
options = !strip
- source = https://files.pythonhosted.org/packages/source/a/aider-chat/aider-chat-0.30.0.tar.gz
- b2sums = 3525c666296fc3ed318362e5b484d55ff08811a5434607507462d070d9dfb17d7add71f048586a12dad3a95f2d6ee447e40118f4e7893acc6f59f588db2ea413
+ source = https://files.pythonhosted.org/packages/source/a/aider_chat/aider_chat-0.30.1.tar.gz
+ b2sums = 7e71f690c4a9d44c56cd321d003c6642dae0dffbde3fcf1bdbb392b97e126284adf720e7115383acc2a1ac20344d465750059147e8486e9241a7ee697f3b05f1
pkgname = aider-chat
diff --git a/PKGBUILD b/PKGBUILD
index a05e1af84a0c..2c0c9b30aefe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: AlphaJack <alphajack at tuta dot io>
pkgname="aider-chat"
-_pkgname="$pkgname"
-pkgver=0.30.0
+_pkgname="aider_chat"
+pkgver=0.30.1
pkgrel=1
pkgdesc="AI pair programming in your terminal"
url="https://aider.chat/"
@@ -34,16 +34,16 @@ makedepends=("python-packaging" "python-build" "python-installer" "python-wheel"
optdepends=("python-sounddevice: portaudio support"
"python-soundfile: portaudio support")
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-b2sums=('3525c666296fc3ed318362e5b484d55ff08811a5434607507462d070d9dfb17d7add71f048586a12dad3a95f2d6ee447e40118f4e7893acc6f59f588db2ea413')
+b2sums=('7e71f690c4a9d44c56cd321d003c6642dae0dffbde3fcf1bdbb392b97e126284adf720e7115383acc2a1ac20344d465750059147e8486e9241a7ee697f3b05f1')
options=("!strip")
build(){
- cd "$pkgname-$pkgver"
+ cd "$_pkgname-$pkgver"
python -m build --wheel --no-isolation
}
package(){
- cd "$pkgname-$pkgver"
+ cd "$_pkgname-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
# remove three files that should not be there
find "$pkgdir/usr/lib/" -depth -type d \( -name "benchmark" -o -name "tests" \) -exec rm -rf {} \;