summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikl2024-04-01 23:07:31 +0300
committerMikl2024-04-01 23:07:31 +0300
commit1b898817d4f989affc515dd9fb2984be9003db1d (patch)
treebdc52dda2df0443dfdc0410702859ca45e5aad4e
downloadaur-1b898817d4f989affc515dd9fb2984be9003db1d.tar.gz
v2.8-1
-rw-r--r--.SRCINFO27
-rwxr-xr-xPKGBUILD28
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ac53bde8ae4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = aif-master
+ pkgver = 2.8
+ pkgrel = 1
+ url = https://github.com/maximalisimus/aif-master.git
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = imagemagick
+ depends = arch-install-scripts
+ depends = dialog
+ depends = ncurses
+ depends = lib32-ncurses
+ depends = pacman-contrib
+ depends = parted
+ depends = util-linux
+ depends = gptfdisk
+ depends = python
+ depends = wget
+ depends = curl
+ depends = sed
+ depends = gawk
+ depends = grep
+ replaces = aif-master
+ source = aif-master::git+https://github.com/maximalisimus/aif-master.git
+ sha256sums = SKIP
+
+pkgname = aif-master
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..e0b9f83db805
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=aif-master
+_pkgrun="aif"
+pkgver=2.8
+pkgrel=1
+arch=('any')
+url="https://github.com/maximalisimus/${pkgname}.git"
+license=('GPL')
+depends=(arch-install-scripts dialog ncurses lib32-ncurses pacman-contrib parted util-linux gptfdisk python wget curl sed gawk grep)
+makedepends=(git imagemagick)
+replaces=($pkgname)
+
+source=("$pkgname::git+https://github.com/maximalisimus/${pkgname}.git"
+ )
+
+sha256sums=('SKIP'
+ )
+
+prepare() {
+ cd ${srcdir}/$pkgname
+ mkdir -p ./post/
+ make DESTDIR=./post/ all
+ make DESTDIR=./post/ install
+}
+
+package() {
+ mkdir -p $pkgdir/usr/
+ cp -a ${srcdir}/$pkgname/post/usr/* $pkgdir/usr/
+}