summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiaotian Wu2021-12-04 14:54:26 +0800
committerXiaotian Wu2021-12-04 14:54:26 +0800
commit89c281a18c0745454fd7d9831f53a2ab291fb268 (patch)
tree50c73e2cef15d960ec1fd81e71a0a7557478e12f
downloadaur-89c281a18c0745454fd7d9831f53a2ab291fb268.tar.gz
init
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD45
-rw-r--r--aigepu.desktop9
-rw-r--r--index.js24
-rw-r--r--logo.pngbin0 -> 5211 bytes
-rw-r--r--package.json15
6 files changed, 123 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71dd70cebf2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = aigepu
+ pkgdesc = 指北者有声简谱编辑软件
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://aigepu.com
+ arch = x86_64
+ license = GPL
+ makedepends = asar
+ makedepends = electron11
+ depends = c-ares
+ depends = ffmpeg
+ depends = gtk3
+ depends = http-parser
+ depends = libevent
+ depends = libnghttp2
+ depends = libxslt
+ depends = minizip
+ depends = nss
+ depends = re2
+ depends = snappy
+ source = aigepu.desktop
+ source = index.js
+ source = logo.png
+ source = package.json
+ sha256sums = 4a80f5c56a36f9b57d75f1ad928d3bc1fb9996c6972f0239ca59e0678caee9dc
+ sha256sums = 0fcf90ce21d83abf12d013f1fcbcacbe79c6c3a737d677a686210a43ac902d77
+ sha256sums = b1601305118665652818b2567e098414586a373aac8f1329bb03585674ccab44
+ sha256sums = 9f8df1516e01d76b3377dd7a24593e206bd29a52d3559345e534cefc46fad71b
+
+pkgname = aigepu
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0b9f4e683f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Xiaotian Wu <yetist@gmail.com>
+
+pkgname=aigepu
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="指北者有声简谱编辑软件"
+url="https://aigepu.com"
+arch=('x86_64')
+license=('GPL')
+depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libnghttp2'
+ 'libxslt' 'minizip' 'nss' 're2' 'snappy')
+makedepends=('asar' 'electron11')
+source=('aigepu.desktop'
+ 'index.js'
+ 'logo.png'
+ 'package.json'
+)
+sha256sums=('4a80f5c56a36f9b57d75f1ad928d3bc1fb9996c6972f0239ca59e0678caee9dc'
+ '0fcf90ce21d83abf12d013f1fcbcacbe79c6c3a737d677a686210a43ac902d77'
+ 'b1601305118665652818b2567e098414586a373aac8f1329bb03585674ccab44'
+ '9f8df1516e01d76b3377dd7a24593e206bd29a52d3559345e534cefc46fad71b')
+
+build() {
+ mkdir app
+ cp index.js logo.png package.json app
+ cp -rf /usr/lib/electron11/* .
+ rm resources/default_app.asar
+ asar pack app resources/app.asar
+ ln -fsr electron aigepu
+}
+
+package() {
+ install -d ${pkgdir}/usr/lib/aigepu
+ cp -rf locales/ resources/ swiftshader/ ${pkgdir}/usr/lib/aigepu
+ cp lib* ${pkgdir}/usr/lib/aigepu
+ cp *.pak *.bin *.json ${pkgdir}/usr/lib/aigepu
+ cp chrome-sandbox electron version ${pkgdir}/usr/lib/aigepu
+ ln -sf electron ${pkgdir}/usr/lib/aigepu/aigepu
+
+ install -d ${pkgdir}/usr/bin
+ ln -sf /usr/lib/aigepu/aigepu ${pkgdir}/usr/bin/aigepu
+
+ install -Dm644 logo.png ${pkgdir}/usr/share/pixmaps/aigepu.png
+ install -Dm644 aigepu.desktop ${pkgdir}/usr/share/applications/aigepu.desktop
+}
diff --git a/aigepu.desktop b/aigepu.desktop
new file mode 100644
index 000000000000..05c2828fb43e
--- /dev/null
+++ b/aigepu.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=aigepu
+Name[zh_CN]=爱歌谱
+Comment=Jianpu editor software
+Comment[zh_CN]=简谱制谱软件
+Exec=aigepu
+Icon=aigepu
+Type=Application
+Categories=Audio;Sequencer;Midi;AudioVideoEditing;Music;AudioVideo;
diff --git a/index.js b/index.js
new file mode 100644
index 000000000000..603152e615c0
--- /dev/null
+++ b/index.js
@@ -0,0 +1,24 @@
+const { app, BrowserWindow, Menu } = require('electron')
+const path = require('path')
+
+function createWindow () {
+ const win = new BrowserWindow({
+ titleBarStyle: 'hidden',
+ width: 1024,
+ height: 768,
+ useContentSize: true,
+ icon: path.join(__dirname, './logo.png')
+ })
+ win.loadURL('https://aigepu.com/zhipu');
+}
+
+app.on('window-all-closed', function () {
+ if (process.platform !== 'darwin') app.quit()
+})
+app.whenReady().then(() => {
+ createWindow()
+ Menu.setApplicationMenu(null);
+ app.on('activate', function () {
+ if (BrowserWindow.getAllWindows().length === 0) createWindow()
+ })
+})
diff --git a/logo.png b/logo.png
new file mode 100644
index 000000000000..11d341018e37
--- /dev/null
+++ b/logo.png
Binary files differ
diff --git a/package.json b/package.json
new file mode 100644
index 000000000000..852bca580e22
--- /dev/null
+++ b/package.json
@@ -0,0 +1,15 @@
+{
+ "name": "aigepu",
+ "version": "1.0.0",
+ "description": "aigepu",
+ "main": "index.js",
+ "scripts": {
+ "start": "electron ."
+ },
+ "repository": {
+ "type": "git",
+ "url": "https://github.com"
+ },
+ "author": "wuxiaotian",
+ "license": "ISC"
+}