summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-12 18:06:16 +0800
committerzxp198210052024-01-12 18:06:16 +0800
commit304946d752575628c10dc04928092a22efd093b5 (patch)
tree0978b33ce05b696bdc13c9a9e7c02650ca24dc7c
parent29491d85ee782eecad4317414ff1ef655000bc9d (diff)
downloadaur-304946d752575628c10dc04928092a22efd093b5.tar.gz
update to 1.1.10
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--aihub.sh8
3 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf94491d55f2..970c9260c932 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = aihub
pkgdesc = A collection of large model capabilities, AI capabilities Electron client, with a minimalist interface, will support more AI capabilities in the future.一款集合众多大模型能力、AI能力的Electron客户端,具有极简的界面,将在未来支持更多AI能力.
- pkgver = 1.1.9
+ pkgver = 1.1.10
pkgrel = 1
url = https://github.com/classfang/AIHub
arch = any
@@ -12,9 +12,9 @@ pkgbase = aihub
depends = electron28
provides = aihub
conflicts = aihub
- source = aihub::git+https://github.com/classfang/AIHub.git#tag=v1.1.9
+ source = aihub.git::git+https://github.com/classfang/AIHub.git#tag=v1.1.10
source = aihub.sh
sha256sums = SKIP
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
pkgname = aihub
diff --git a/PKGBUILD b/PKGBUILD
index 3ac3e30a30ec..914d8c3bcbfc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=aihub
_pkgname=AIHub
-pkgver=1.1.9
+pkgver=1.1.10
_electronversion=28
pkgrel=1
pkgdesc="A collection of large model capabilities, AI capabilities Electron client, with a minimalist interface, will support more AI capabilities in the future.一款集合众多大模型能力、AI能力的Electron客户端,具有极简的界面,将在未来支持更多AI能力."
@@ -20,18 +20,18 @@ makedepends=(
'git'
)
source=(
- "${pkgname}::git+${url}.git#tag=v${pkgver}"
+ "${pkgname}.git::git+${url}.git#tag=v${pkgver}"
"${pkgname}.sh"
)
sha256sums=('SKIP'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname}|g" \
-e "s|@appasar@|app.asar|g" \
-i "${srcdir}/${pkgname}.sh"
gendesk -q -f -n --categories "Utility" --name "${_pkgname}" --exec "${pkgname} %U"
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}.git"
sed '/- snap/d;/- deb/d' -i electron-builder.yml
export npm_config_build_from_source=true
export ELECTRON_SKIP_BINARY_DOWNLOAD=1
@@ -42,9 +42,9 @@ build() {
}
package() {
install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "${srcdir}/${pkgname}/dist/linux-unpacked/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname}"
- install -Dm644 "${srcdir}/${pkgname}/dist/linux-unpacked/resources/app.asar.unpacked/resources/"* -t "${pkgdir}/usr/lib/${pkgname}/app.asar.unpacked/resources"
+ install -Dm644 "${srcdir}/${pkgname}.git/dist/linux-unpacked/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}.git/dist/linux-unpacked/resources/app.asar.unpacked/resources/"* -t "${pkgdir}/usr/lib/${pkgname}/app.asar.unpacked/resources"
install -Dm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
- install -Dm644 "${srcdir}/${pkgname}/resources/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "${srcdir}/${pkgname}.git/resources/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
install -Dm644 "${srcdir}/${pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file
diff --git a/aihub.sh b/aihub.sh
index c77c53567639..aacd8f895847 100644
--- a/aihub.sh
+++ b/aihub.sh
@@ -6,12 +6,10 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
- exit
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
- exit
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file