summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-27 18:03:33 +0800
committerzxp198210052024-03-27 18:03:33 +0800
commite3b4a36c8c3154f2f2e95b08bdfca37c130594c2 (patch)
tree62cc586c4fdc2d4c837cfae4046cf246925af1c6
parent351475b98bd9fce12b327bc4ece90365d424ed78 (diff)
downloadaur-e3b4a36c8c3154f2f2e95b08bdfca37c130594c2.tar.gz
update to 1.4.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f965f997cac..998cab20f928 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = aihub
pkgdesc = A collection of large model capabilities, AI capabilities Electron client, with a minimalist interface, will support more AI capabilities in the future.一款集合众多大模型能力、AI能力的Electron客户端,具有极简的界面,将在未来支持更多AI能力.
- pkgver = 1.4.0
+ pkgver = 1.4.1
pkgrel = 1
url = https://github.com/classfang/AIHub
arch = any
@@ -12,9 +12,9 @@ pkgbase = aihub
depends = electron29
provides = aihub
conflicts = aihub
- source = aihub.git::git+https://github.com/classfang/AIHub.git#tag=v1.4.0
+ source = aihub.git::git+https://github.com/classfang/AIHub.git#tag=v1.4.1
source = aihub.sh
- sha256sums = SKIP
+ sha256sums = e0ec322fca31d895fe784042c827bf92f32a81b296f7856b4cf358c8d30cde45
sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = aihub
diff --git a/PKGBUILD b/PKGBUILD
index 940c85043a33..e228921a5d55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=aihub
_pkgname=AIHub
-pkgver=1.4.0
+pkgver=1.4.1
_electronversion=29
pkgrel=1
pkgdesc="A collection of large model capabilities, AI capabilities Electron client, with a minimalist interface, will support more AI capabilities in the future.一款集合众多大模型能力、AI能力的Electron客户端,具有极简的界面,将在未来支持更多AI能力."
@@ -23,13 +23,13 @@ source=(
"${pkgname}.git::git+${url}.git#tag=v${pkgver}"
"${pkgname}.sh"
)
-sha256sums=('SKIP'
+sha256sums=('e0ec322fca31d895fe784042c827bf92f32a81b296f7856b4cf358c8d30cde45'
'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname}|g" \
-e "s|@runname@|app.asar|g" \
- -e "s|@options@||g" \
+ -e "s|@options@|env ELECTRON_OZONE_PLATFORM_HINT=auto|g" \
-i "${srcdir}/${pkgname}.sh"
gendesk -q -f -n --categories="Utility" --name="${_pkgname}" --exec="${pkgname} %U"
cd "${srcdir}/${pkgname}.git"
@@ -43,13 +43,14 @@ build() {
mkdir -p "${srcdir}/.electron-gyp"
touch "${srcdir}/.electron-gyp/.yarnrc"
if [ `curl -s ipinfo.io/country | grep CN | wc -l ` -ge 1 ];then
+ echo -e "\n" >> .npmrc
echo 'registry="https://registry.npmmirror.com/"' >> .npmrc
echo 'electron_mirror="https://registry.npmmirror.com/-/binary/electron/"' >> .npmrc
echo 'electron_builder_binaries_mirror="https://registry.npmmirror.com/-/binary/electron-builder-binaries/"' >> .npmrc
else
echo "Your network is OK."
fi
- sed "s|--linux|--dir|g" -i package.json
+ sed "/- AppImage/d;/- snap/d;s|- deb|- dir|g" -i electron-builder.yml
yarn install --cache-folder "${srcdir}/.yarn_cache"
yarn run build:linux
}