summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbadcast2022-12-05 00:19:48 +0600
committerbadcast2022-12-05 00:19:48 +0600
commit3b9ce8e54cc19759589d01461c41a1ebf8b7822b (patch)
tree80e05185a10c1763ec9758446dee572b12174d32
parent61080f4750648184cd58295875aa4a6418f07d88 (diff)
downloadaur-3b9ce8e54cc19759589d01461c41a1ebf8b7822b.tar.gz
Windows Path converter added (winepath)
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dccac60d3964..fe79b7e2a6ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,12 @@ build(){
echo "Append aimp (shell):/usr/bin/aimp"
#save patch
echo "#!/usr/bin/sh
-/usr/bin/wine '/opt/aimp/AIMP/AIMP.exe' \"\$@\"" > aimp
+#Convert Linux paths to Windows paths.
+#Example:
+#GNU LINUX | WINDOWS OS
+# \$HOME = %USERPROFILE%\\ (etc).
+_paths=$(winepath --windows \"\$@\")
+/usr/bin/wine start /unix '/opt/aimp/AIMP/AIMP.exe' \${_paths}" > aimp
}
package(){