summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorc-reeder2019-12-14 23:52:09 -0300
committerc-reeder2019-12-14 23:56:17 -0300
commit4280e737601aa5f50c7fb394247743c75d1b75da (patch)
tree79d840d59f7f2cc6aedc5ff588d64bec19602196
parent5608f0c433b84268d4ce672291361d2df282e311 (diff)
downloadaur-4280e737601aa5f50c7fb394247743c75d1b75da.tar.gz
Fixed config file readability problem and minor PKGBUILD corrections
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
-rw-r--r--aio-remote8
-rw-r--r--aio-remote.desktop2
-rw-r--r--aio-remote.pngbin4395 -> 18589 bytes
5 files changed, 27 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d5d2fcf2d9f..9ef4b9251af3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = aio-remote
pkgdesc = All In One remote to control any application using an android app.
pkgver = 3.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://aioremote.net
arch = any
license = unknown
- depends = java-environment
- depends = bash
+ makedepends = wget
+ depends = java-runtime=8
optdepends = bluez: for bluetooth support
source = aio-remote.desktop
source = aio-remote.png
- md5sums = de3ff5e5931c17a46a0719d773a58afe
- md5sums = 2b70bbd76e20a9181470a7f415f2c9cf
+ source = aio-remote
+ md5sums = fcebc46b9245b7a40cff4b58e66635f7
+ md5sums = 84d303db6c7a90e2d2e46371e4fcef8f
+ md5sums = 3e67e3b48e5e9a77a49dc8d1576e3392
pkgname = aio-remote
diff --git a/PKGBUILD b/PKGBUILD
index e428922e7a53..2c86362216f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
# Maintainer: Connor Reeder <connor.reeder@ymail.com>
pkgname=aio-remote
-pkgrel=1
+pkgrel=2
pkgver=3.5.0
pkgdesc="All In One remote to control any application using an android app."
arch=("any")
url="https://aioremote.net"
license=('unknown')
-depends=("java-environment" "bash")
+depends=("java-runtime=8")
+makedepends=("wget")
optdepends=('bluez: for bluetooth support')
-source=("$pkgname.desktop" "$pkgname.png")
+source=("$pkgname.desktop" "$pkgname.png" "$pkgname")
noextract=()
-md5sums=('de3ff5e5931c17a46a0719d773a58afe'
- '2b70bbd76e20a9181470a7f415f2c9cf')
+md5sums=('fcebc46b9245b7a40cff4b58e66635f7'
+ '84d303db6c7a90e2d2e46371e4fcef8f'
+ '3e67e3b48e5e9a77a49dc8d1576e3392')
prepare() {
echo "Determining latest version..."
@@ -26,9 +28,7 @@ prepare() {
find . -name "config.ini" -exec mv {} . \;
echo $latest_url | sed 's/_linux.zip$//' | sed 's/^.*AioRemoteDesktop//' > version.txt
echo ${jar_file} > jar_file.txt
- echo '#!/bin/bash' >> aio-remote
- echo "cd /usr/share/${pkgname}" >> aio-remote
- echo "java -jar ${jar_file}" >> aio-remote
+ echo "exec /usr/bin/java -jar /usr/share/java/${pkgname}/${jar_file}" >> ${srcdir}/aio-remote
}
pkgver() {
cat version.txt
@@ -36,9 +36,9 @@ pkgver() {
package() {
local jar_file=$(cat jar_file.txt)
- install -Dm644 ${jar_file} "$pkgdir/usr/share/$pkgname/${jar_file}"
- install -Dm644 "config.ini" "$pkgdir/usr/share/$pkgname/config.ini"
- install -Dm644 "${pkgname}.png" "$pkgdir/usr/share/${pkgname}/${pkgname}.png"
+ install -Dm644 ${jar_file} "$pkgdir/usr/share/java/$pkgname/${jar_file}"
+ install -Dm644 "config.ini" "$pkgdir/usr/share/doc/$pkgname/config.ini.example"
+ install -Dm644 "${pkgname}.png" "$pkgdir/usr/share/pixmaps/${pkgname}.png"
install -Dm755 ${pkgname} "$pkgdir/usr/bin/${pkgname}"
install -Dm644 ${pkgname}.desktop "$pkgdir/usr/share/applications/${pkgname}.desktop"
}
diff --git a/aio-remote b/aio-remote
new file mode 100644
index 000000000000..dc2b528a464c
--- /dev/null
+++ b/aio-remote
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+if [[ ! -r ~/.config/aio-remote/config.ini ]]; then
+ install -Dm644 /usr/share/doc/aio-remote/config.ini.example ~/.config/aio-remote/config.ini
+fi
+
+cd ~/.config/aio-remote
+
diff --git a/aio-remote.desktop b/aio-remote.desktop
index e147eddeaf44..759d7adb08c6 100644
--- a/aio-remote.desktop
+++ b/aio-remote.desktop
@@ -4,4 +4,4 @@ Type=Application
Name=AIO Remote
Comment=All In One Remote
Exec=aio-remote
-Icon=/usr/share/aio-remote/aio-remote.png
+Icon=aio-remote
diff --git a/aio-remote.png b/aio-remote.png
index f450a6758814..7fef731ac036 100644
--- a/aio-remote.png
+++ b/aio-remote.png
Binary files differ