summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorc-reeder2019-12-12 16:25:47 -0300
committerc-reeder2019-12-12 16:25:47 -0300
commit5608f0c433b84268d4ce672291361d2df282e311 (patch)
tree285259a4f53ac8e7ef1d45ec8072b6b54662ab4b
downloadaur-5608f0c433b84268d4ce672291361d2df282e311.tar.gz
Initial Commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD44
-rw-r--r--aio-remote.desktop7
-rw-r--r--aio-remote.pngbin0 -> 4395 bytes
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d5d2fcf2d9f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = aio-remote
+ pkgdesc = All In One remote to control any application using an android app.
+ pkgver = 3.5.0
+ pkgrel = 1
+ url = https://aioremote.net
+ arch = any
+ license = unknown
+ depends = java-environment
+ depends = bash
+ optdepends = bluez: for bluetooth support
+ source = aio-remote.desktop
+ source = aio-remote.png
+ md5sums = de3ff5e5931c17a46a0719d773a58afe
+ md5sums = 2b70bbd76e20a9181470a7f415f2c9cf
+
+pkgname = aio-remote
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e428922e7a53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Connor Reeder <connor.reeder@ymail.com>
+
+pkgname=aio-remote
+pkgrel=1
+pkgver=3.5.0
+pkgdesc="All In One remote to control any application using an android app."
+arch=("any")
+url="https://aioremote.net"
+license=('unknown')
+depends=("java-environment" "bash")
+optdepends=('bluez: for bluetooth support')
+source=("$pkgname.desktop" "$pkgname.png")
+noextract=()
+md5sums=('de3ff5e5931c17a46a0719d773a58afe'
+ '2b70bbd76e20a9181470a7f415f2c9cf')
+
+prepare() {
+ echo "Determining latest version..."
+ latest_url=$(curl -i bit.ly/aio_remote_desktop_linux | tr -d '\r' | grep '^Location:' | sed 's/^Location:\s//')
+ local bundle_file=$(echo $latest_url | sed 's/^.*\///')
+ wget -P ${srcdir} ${latest_url}
+ unzip "${srcdir}/${bundle_file}"
+ rm -rf "${srcdir}/__MACOSX"
+ local jar_file=${bundle_file/_linux.zip/.jar}
+ find . -name "${jar_file}" -exec mv {} . \;
+ find . -name "config.ini" -exec mv {} . \;
+ echo $latest_url | sed 's/_linux.zip$//' | sed 's/^.*AioRemoteDesktop//' > version.txt
+ echo ${jar_file} > jar_file.txt
+ echo '#!/bin/bash' >> aio-remote
+ echo "cd /usr/share/${pkgname}" >> aio-remote
+ echo "java -jar ${jar_file}" >> aio-remote
+}
+pkgver() {
+ cat version.txt
+}
+
+package() {
+ local jar_file=$(cat jar_file.txt)
+ install -Dm644 ${jar_file} "$pkgdir/usr/share/$pkgname/${jar_file}"
+ install -Dm644 "config.ini" "$pkgdir/usr/share/$pkgname/config.ini"
+ install -Dm644 "${pkgname}.png" "$pkgdir/usr/share/${pkgname}/${pkgname}.png"
+ install -Dm755 ${pkgname} "$pkgdir/usr/bin/${pkgname}"
+ install -Dm644 ${pkgname}.desktop "$pkgdir/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/aio-remote.desktop b/aio-remote.desktop
new file mode 100644
index 000000000000..e147eddeaf44
--- /dev/null
+++ b/aio-remote.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+
+Type=Application
+Name=AIO Remote
+Comment=All In One Remote
+Exec=aio-remote
+Icon=/usr/share/aio-remote/aio-remote.png
diff --git a/aio-remote.png b/aio-remote.png
new file mode 100644
index 000000000000..f450a6758814
--- /dev/null
+++ b/aio-remote.png
Binary files differ