summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia Pellegrino2022-09-27 10:07:50 +0200
committerClaudia Pellegrino2022-09-27 10:18:35 +0200
commita83b117a665d0008300d341b721485553bb06e15 (patch)
treeaf3f6e22c4efb6454e9553016a9ec966194da94a
downloadaur-a83b117a665d0008300d341b721485553bb06e15.tar.gz
aio-remote-neo v1.85.0
-rw-r--r--.SRCINFO24
-rw-r--r--.editorconfig20
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD61
-rw-r--r--aio-remote-neo.bash4
5 files changed, 116 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee65f56b5445
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = aio-remote-neo
+ pkgdesc = Smart home app that hosts your custom remote control designs from AIO CREATOR NEO
+ pkgver = 1.85.0
+ pkgrel = 1
+ url = https://shop.mediola.com/aio-creator-neo
+ arch = x86_64
+ license = custom
+ depends = alsa-lib
+ depends = at-spi2-core
+ depends = libcups
+ depends = libxcomposite
+ depends = libxkbcommon
+ depends = libxrandr
+ depends = mesa
+ depends = nss
+ depends = pango
+ conflicts = aio-remote-neo-git
+ options = !strip
+ source = aio-remote-neo-1.85.0.tar.gz::https://s3-eu-west-1.amazonaws.com/mediola-download/aioremote_neo/release/desktop/1.85.0/AIO+REMOTE+NEO-linux.tar.gz
+ source = aio-remote-neo.bash
+ sha512sums = bb4e60ff90d6236b1c23fb42e7e043ba6ce6a5e1206ab6ae430dcc9172161f3480a00545230a5073c3683a1c59d99351ac71016249e303049b81f7203eba3a30
+ sha512sums = 802c2e819ff1964cf37f9b0198261943c922f0e34dff4f077c481fdd7670a6e8f5061c7fcfd08e0de30ba60519ce2de33c2640c270c5adfcc7635a175bc0df32
+
+pkgname = aio-remote-neo
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..29215c86a3df
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,20 @@
+# https://editorconfig.org
+
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+indent_style = space
+insert_final_newline = true
+trim_trailing_whitespace = true
+
+[*.{diff,patch}]
+end_of_line = lf
+trim_trailing_whitespace = false
+
+[PKGBUILD]
+indent_size = 2
+
+[*.json]
+indent_size = 2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..37dd117487ab
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+/.vscode/
+/src
+/pkg
+*.log
+*.pkg.*
+*.tar.*
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..858c5cec6330
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Claudia Pellegrino <aur ät cpellegrino.de>
+
+pkgname=aio-remote-neo
+pkgver=1.85.0
+pkgrel=1
+pkgdesc='Smart home app that hosts your custom remote control designs from AIO CREATOR NEO'
+arch=('x86_64')
+url='https://shop.mediola.com/aio-creator-neo'
+license=('custom')
+depends=(
+ 'alsa-lib'
+ 'at-spi2-core'
+ 'libcups'
+ 'libxcomposite'
+ 'libxkbcommon'
+ 'libxrandr'
+ 'mesa'
+ 'nss'
+ 'pango'
+)
+conflicts=('aio-remote-neo-git')
+options=('!strip')
+
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://s3-eu-west-1.amazonaws.com/mediola-download/aioremote_neo/release/desktop/${pkgver}/AIO+REMOTE+NEO-linux.tar.gz"
+ 'aio-remote-neo.bash'
+)
+
+sha512sums=(
+ 'bb4e60ff90d6236b1c23fb42e7e043ba6ce6a5e1206ab6ae430dcc9172161f3480a00545230a5073c3683a1c59d99351ac71016249e303049b81f7203eba3a30'
+ '802c2e819ff1964cf37f9b0198261943c922f0e34dff4f077c481fdd7670a6e8f5061c7fcfd08e0de30ba60519ce2de33c2640c270c5adfcc7635a175bc0df32'
+)
+
+build() {
+ rm -f "${srcdir}/AIO REMOTE NEO/.DS_Store"
+}
+
+package() {
+ echo >&2 'Packaging the application'
+ mkdir -p "${pkgdir}/opt/${pkgname}"
+ cp -r --preserve=mode -T "${srcdir}/AIO REMOTE NEO" \
+ "${pkgdir}/opt/${pkgname}"
+
+ echo >&2 'Packaging the executable'
+ install -D -m 755 -T "${srcdir}/aio-remote-neo.bash" \
+ "${pkgdir}/usr/bin/aio-remote-neo"
+
+ echo >&2 'Packaging README.txt, credits.html'
+ install -D -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" \
+ "${srcdir}/README.txt" "${srcdir}/AIO REMOTE NEO/credits.html"
+
+ echo >&2 'Packaging desktop file'
+ install -D -m 644 -t "${pkgdir}/usr/share/applications/${pkgname}" \
+ "${srcdir}/AIO REMOTE NEO.desktop"
+
+ echo >&2 'Packaging license files'
+ install -D -m 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" \
+ "${srcdir}/AIO REMOTE NEO/License_"{de,en}'.txt' \
+ "${srcdir}/AIO REMOTE NEO/mediola/eula.html" \
+ "${srcdir}/AIO REMOTE NEO/mediola/licenses/files"/*
+}
diff --git a/aio-remote-neo.bash b/aio-remote-neo.bash
new file mode 100644
index 000000000000..7fb2b0d93044
--- /dev/null
+++ b/aio-remote-neo.bash
@@ -0,0 +1,4 @@
+#!/usr/bin/env bash
+set -e
+cd /opt/aio-remote-neo
+exec ./aio_remote_neo "$@"