summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-08-15 13:18:13 -0500
committerCarlos Aznarán Laos2022-08-15 13:18:13 -0500
commit67d0313fe9cd7b981b483e85fd931c48834c4a43 (patch)
tree75d8b7213b57d946bc09738342f601edeaf249f1
parent19d931f83644572036fab3e72157e88cb3f1e765 (diff)
downloadaur-67d0313fe9cd7b981b483e85fd931c48834c4a43.tar.gz
Bump version to 1.40.4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD60
2 files changed, 31 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b9b05b81ed5..5d32b0dd2010 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = air
pkgdesc = Live reload for Go apps
- pkgver = 1.28.0
+ pkgver = 1.40.4
pkgrel = 1
url = https://github.com/cosmtrek/air
arch = x86_64
license = GPL3
makedepends = git
- makedepends = go
depends = glibc
+ depends = go
options = !lto
- source = air::git+https://github.com/cosmtrek/air.git#commit=1e895ef469967de7c1b68a8bceb22b0a1296cdc7
+ source = air::git+https://github.com/cosmtrek/air.git#commit=5ac18a4db4621fecc79d2afb5a4384c2586635de
b2sums = SKIP
pkgname = air
diff --git a/PKGBUILD b/PKGBUILD
index 8d12fdeeaf0b..07f0bc0550f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,42 @@
-# Maintainer: George Rawlinson <george@rawlinson.net.nz>
-
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: George Rawlinson <george@rawlinson.net.nz>
pkgname=air
-pkgver=1.28.0
+pkgver=1.40.4
pkgrel=1
pkgdesc="Live reload for Go apps"
-arch=('x86_64')
-url="https://github.com/cosmtrek/air"
-license=('GPL3')
-depends=('glibc')
-makedepends=('git' 'go')
+arch=(x86_64)
+url="https://github.com/cosmtrek/${pkgname}"
+license=(GPL3)
+depends=(glibc go)
+makedepends=(git)
options=('!lto')
-_commit='1e895ef469967de7c1b68a8bceb22b0a1296cdc7'
-source=("$pkgname::git+$url.git#commit=$_commit")
+_commit='5ac18a4db4621fecc79d2afb5a4384c2586635de'
+source=("${pkgname}::git+${url}.git#commit=${_commit}")
b2sums=('SKIP')
pkgver() {
- cd "$pkgname"
-
+ cd ${pkgname}
git describe --tags | sed 's/^v//'
}
prepare() {
- cd "$pkgname"
+ # set Go flags
+ export GOPATH="$srcdir"/gopath
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_ENABLED=0
+ cd ${pkgname}
# create directory for build output
- mkdir build
-
+ mkdir -p build
# download dependencies
go mod download
}
build() {
- cd "$pkgname"
-
- # set Go flags
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
-
+ cd ${pkgname}
go build -v \
-trimpath \
-buildmode=pie \
@@ -50,18 +49,15 @@ build() {
.
}
-check() {
- cd "$pkgname"
-
- go test -v ./...
-}
+# check() {
+# cd ${pkgname}
+# go test -v ./...
+# }
package() {
- cd "$pkgname"
-
+ cd ${pkgname}
# binary
- install -vDm755 -t "$pkgdir/usr/bin" "build/$pkgname"
-
+ install -vDm755 -t "${pkgdir}/usr/bin" "build/${pkgname}"
# documentation
- install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md air_example.toml
+ install -vDm644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md air_example.toml
}