summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Miegl2018-04-06 21:31:56 +0200
committerJosef Miegl2018-04-06 21:31:56 +0200
commitd1d3bce36db3fd7e08ec57c0cffc469adf0a3894 (patch)
treeb7fa3af3c3337668960ff217543f6d9decdec50e
parent93758396ed32a6b4205da643c826be19fe7c9b91 (diff)
downloadaur-d1d3bce36db3fd7e08ec57c0cffc469adf0a3894.tar.gz
add proper dependencies and contributors (thanks vesath)
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD11
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d9b4a230c9b..a15f7bb32a13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,20 +8,18 @@ pkgbase = aircrack-ng-git
arch = armv7h
license = GPL2
makedepends = git
- makedepends = autoconf
- makedepends = automake
- makedepends = pkg-config
- makedepends = make
- makedepends = gcc-libs
+ makedepends = python
+ depends = gcc-libs
+ depends = libnl
depends = openssl
+ depends = sqlite
depends = iw
- depends = net-tools
- depends = shtool
depends = ethtool
- depends = libnl
- depends = libtool
+ depends = net-tools
+ optdepends = python: dump-join, airgraph-ng, versuck-ng, airdrop-ng
provides = aircrack-ng
conflicts = aircrack-ng
+ replaces = aircrack-ng-svn
source = git://github.com/aircrack-ng/aircrack-ng.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1c5c615e6a4d..9266c33a94f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,9 @@
# Maintainer: Josef Miegl <josef@miegl.cz>
+# Contributor: Gaetan Bisson <bisson@archlinux.org
+# Contributor: Brad Fanella <bradfanella@archlinux.us>
+# Contributor: Daenyth <Daenyth+Arch [at] gmail [dot] com>
+# Contributor: Corrado Primier <bardo@aur.archlinux.org>
+# Contributor: ice-man <icemanf@gmail.com>
pkgname=aircrack-ng-git
_pkgname=aircrack-ng
@@ -8,13 +13,15 @@ pkgdesc='WiFi security auditing tools suite'
url='https://aircrack-ng.org/'
arch=('i686' 'x86_64' 'armv7h')
license=('GPL2')
-makedepends=('git' 'autoconf' 'automake' 'pkg-config' 'make' 'gcc-libs')
-depends=('openssl' 'iw' 'net-tools' 'shtool' 'ethtool' 'libnl' 'libtool')
+makedepends=('git' 'python')
+depends=('gcc-libs' 'libnl' 'openssl' 'sqlite' 'iw' 'ethtool' 'net-tools')
+optdepends=('python: dump-join, airgraph-ng, versuck-ng, airdrop-ng')
source=("git://github.com/aircrack-ng/aircrack-ng.git")
sha256sums=('SKIP')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
+replaces=('aircrack-ng-svn')
pkgver() {
cd "${srcdir}/${_pkgname}"