summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikola Hadžić2022-06-21 21:21:08 +0200
committerNikola Hadžić2022-06-21 21:21:08 +0200
commita09efbcb14096cecc67665c51eafba4bf2f9159f (patch)
tree65c68d7e189eecb9d33a6c96ab56abb685dd443d
parent15ec1683a20f24041958daff2c34dc29052f8731 (diff)
downloadaur-a09efbcb14096cecc67665c51eafba4bf2f9159f.tar.gz
1.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD51
2 files changed, 33 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc2b48e5a1fb..767f2870d765 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = airpad
- pkgdesc = Basic text editor
- pkgver = 0.2
+ pkgdesc = Basic GUI text editor
+ pkgver = 1.0
pkgrel = 1
- url = https://gitlab.com/oktopod11/airpad
+ url = https://gitlab.com/NH000/airpad
arch = x86_64
license = GPL3
+ makedepends = make
+ makedepends = gcc
+ makedepends = pkgconf
+ makedepends = coreutils
depends = gtk3
- depends = xdg-utils
- source = https://gitlab.com/oktopod11/airpad/raw/master/archive/airpad-0.2.tar.gz
- sha512sums = 8ef206c10c46ce6835fa31eb0ae291f1b3856948c956a0a9ef86cf6b09509a13b298a043fc874021f9d9e3c6ad13529956f2458931ec1d0a4379ff8a311afcf3
+ depends = gettext
+ source = airpad-1.0::git+https://gitlab.com/NH000/airpad#tag=7602564b3f944fc331e4785c4fb45ca21a90c3f0
+ sha256sums = SKIP
pkgname = airpad
-
diff --git a/PKGBUILD b/PKGBUILD
index edfa005309ff..3cd4a53adf24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,33 @@
-# Maintainer: Nikola Hadžić <nikola@firemail.cc>
+# Maintainer: Nikola Hadžić <nikola.hadzic.000@protonmail.com>
pkgname="airpad"
-pkgver=0.2
+pkgver="1.0"
pkgrel=1
-epoch=
-pkgdesc="Basic text editor"
+pkgdesc="Basic GUI text editor"
arch=("x86_64")
-url="https://gitlab.com/oktopod11/airpad"
+url="https://gitlab.com/NH000/airpad"
license=("GPL3")
-groups=()
-depends=("gtk3" "xdg-utils")
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-source=("https://gitlab.com/oktopod11/airpad/raw/master/archive/airpad-${pkgver}.tar.gz")
-noextract=()
-sha512sums=('8ef206c10c46ce6835fa31eb0ae291f1b3856948c956a0a9ef86cf6b09509a13b298a043fc874021f9d9e3c6ad13529956f2458931ec1d0a4379ff8a311afcf3')
+depends=("gtk3" "gettext")
+makedepends=("make" "gcc" "pkgconf" "coreutils")
+source=("$pkgname-$pkgver::git+$url#tag=7602564b3f944fc331e4785c4fb45ca21a90c3f0")
+sha256sums=("SKIP")
build() {
- cd "$srcdir/$pkgname"
- make build RELEASE=release
- make link
+ cd "$pkgname-$pkgver"
+ make all OPTIMIZE=1
}
package() {
- cd "$srcdir/$pkgname"
- mkdir -p "$pkgdir/usr/share/icons/hicolor/32x32/apps/"
- mkdir -p "$pkgdir/usr/share/icons/hicolor/48x48/apps/"
- mkdir -p "$pkgdir/usr/share/icons/hicolor/128x128/apps/"
- mkdir -p "$pkgdir/usr/share/applications/"
- make install INSTALLDIR="$pkgdir/usr/bin/" ICONSDIR="$pkgdir/usr/share/icons/hicolor/" APPDIR="$pkgdir/usr/share/applications/"
-}
+ cd "$pkgname-$pkgver"
+
+ install -D -t "$pkgdir/usr/bin" "airpad"
+
+ mkdir -p "$pkgdir/usr/share/locale/sr/LC_MESSAGES"
+ msgfmt -o "$pkgdir/usr/share/locale/sr/LC_MESSAGES/airpad.mo" "po/sr.po"
+ mkdir -p "$pkgdir/usr/share/locale/sr_RS@latin/LC_MESSAGES"
+ msgfmt -o "$pkgdir/usr/share/locale/sr_RS@latin/LC_MESSAGES/airpad.mo" "po/sr_RS@latin.po"
+ install -m 644 -D "icon.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/airpad.svg"
+
+ mkdir -p "$pkgdir/usr/share/applications"
+ echo -e '[Desktop Entry]\nType=Application\nVersion=1.5\nName=Airpad\nGenericName=Text editor\nGenericName[sr]=Уређивач текста\nGenericName[sr_RS@latin]=Uređivač teksta\nComment=Edit text\nComment[sr]=Уредите текст\nComment[sr_RS@latin]=Uredite tekst\nIcon=airpad\nDBusActivatable=true\nTryExec=/usr/bin/airpad\nExec=/usr/bin/airpad %F\nTerminal=false\nMimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;\nCategories=Utility;TextEditor;\nStartupNotify=true' > "$pkgdir/usr/share/applications/com.gitlab.NH000.Airpad.desktop"
+}