summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarryhaja2016-01-01 19:25:04 -0800
committerlarryhaja2016-01-01 19:25:04 -0800
commit42fa91b737b0f72a7a7aa85a16aa7db46790809d (patch)
tree1e16c423a0e8f47c25bcc8f99cdd3b25dda5f522
parent4967f23cd1a9fbc73ace7fe1b89980088625f6d3 (diff)
downloadaur-airpwn.tar.gz
fix permission denied when build function called
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52dbbd67682b..0ed33ef81dff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
# Generated by makepkg 4.2.1
-# Thu Jun 11 21:20:36 UTC 2015
+# Sat Jan 2 03:05:12 UTC 2016
pkgbase = airpwn
pkgdesc = A generic packet injection tool for 802.11 networks.
pkgver = 1.4
- pkgrel = 6
+ pkgrel = 7
url = http://airpwn.sourceforge.net
arch = i686
arch = x86_64
license = GPL
makedepends = sed
+ makedepends = automake
+ makedepends = autoconf
depends = pcre
depends = libpcap
depends = openssl
diff --git a/PKGBUILD b/PKGBUILD
index 2c8ab16d9208..f88ba0277387 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=airpwn
pkgver=1.4
-pkgrel=6
+pkgrel=7
pkgdesc="A generic packet injection tool for 802.11 networks."
arch=('i686' 'x86_64')
url="http://airpwn.sourceforge.net"
license=('GPL')
depends=('pcre' 'libpcap' 'openssl' 'libnet' 'python2' 'libnl1')
-makedepends=('sed')
+makedepends=('sed' 'automake' 'autoconf')
optdepends=('net-tools: to put wireless interfaces into monitor mode'
'iw: for mac80211 monitor-mode support'
'madwifi-utils: for madwifi monitor-mode support')
@@ -39,9 +39,7 @@ build() {
--enable-static=no
make
- make install DESTDIR="$pkgdir"
- # Don't conflict with lorcon package man page
- mv "$pkgdir"/usr/share/man/man3/lorcon.3 "$pkgdir"/usr/share/man/man3/lorcon-old.3
+ make install DESTDIR="$PWD"
cd ..
# Fix airpwn files so we can use it with a Python version other than 2.4.
@@ -51,8 +49,8 @@ build() {
autoreconf -ivf
CFLAGS="${CFLAGS}" \
- CPPFLAGS="-I${pkgdir}/usr/include" \
- LDFLAGS="-L${pkgdir}/usr/lib" \
+ CPPFLAGS="-Ilorcon/usr/include" \
+ LDFLAGS="-Llorcon/usr/lib" \
LIBS="-lcrypto" \
./configure \
--prefix=/usr \
@@ -64,6 +62,11 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
+ # Install lorcon.
+ make -C lorcon install DESTDIR="$pkgdir"
+ # Don't conflict with lorcon package man page
+ mv "$pkgdir"/usr/share/man/man3/lorcon.3 "$pkgdir"/usr/share/man/man3/lorcon-old.3
+
make install DESTDIR="$pkgdir"
install -m 0755 mac80211_prep.sh "$pkgdir/usr/sbin"