summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2022-04-16 12:32:48 -0700
committerEric Anderson2022-04-16 12:32:48 -0700
commit0c65b3bab98913908e5808498efaa556b000cad5 (patch)
treef3cc2bfa3595c0c149eb5119cbf5eae489406502
parentfa560490fd0b24a595fd5501237ba680d3431faa (diff)
downloadaur-0c65b3bab98913908e5808498efaa556b000cad5.tar.gz
Fix 0.3.4 compilation
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--airsane-png-h.patch13
-rw-r--r--airsane-systemd-dir.patch15
4 files changed, 13 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2e3883737ac..6bccd4091728 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = airsane-git
pkgdesc = Publish SANE scanners to MacOS and Android via Apple AirScan
- pkgver = 0.3.2.r0.g53909a5
+ pkgver = 0.3.4.r2.g0736ea3
pkgrel = 1
url = https://github.com/SimulPiscator/AirSane
arch = i686
@@ -16,14 +16,10 @@ pkgbase = airsane-git
provides = airsane
conflicts = airsane
source = airsane::git+https://github.com/SimulPiscator/AirSane.git
- source = airsane-png-h.patch
source = airsane-systemd-dir.patch
md5sums = SKIP
- md5sums = c0adf20be58acc81963cdb83a3c6b75e
- md5sums = 3d7c6bc2b6c9993626a5d7e6580ee307
+ md5sums = 7c14c073eb6fae88baad06c195eb6907
sha256sums = SKIP
- sha256sums = ef034dcdefbaf6b41873d33256b44756c5752184af6c885944527453d8a87162
- sha256sums = 806b92de06b404fba23fb7f5c1bcdeecd7cf1d479481d2d61d5587c8a4354f69
+ sha256sums = 10f53fb504224e5a814023342933a6143cde6af0f9479ab8ae4b5a84b929a5ea
pkgname = airsane-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 61946220008d..ce34ed921474 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Eric Anderson <ejona86@gmail.com>
pkgname=airsane-git
-pkgver=0.3.2.r0.g53909a5
+pkgver=0.3.4.r2.g0736ea3
pkgrel=1
pkgdesc="Publish SANE scanners to MacOS and Android via Apple AirScan"
arch=('i686' 'x86_64')
@@ -12,14 +12,11 @@ provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
backup=()
source=("${pkgname%-git}::git+https://github.com/SimulPiscator/AirSane.git"
- "airsane-png-h.patch"
"airsane-systemd-dir.patch")
md5sums=('SKIP'
- 'c0adf20be58acc81963cdb83a3c6b75e'
- '3d7c6bc2b6c9993626a5d7e6580ee307')
+ '7c14c073eb6fae88baad06c195eb6907')
sha256sums=('SKIP'
- 'ef034dcdefbaf6b41873d33256b44756c5752184af6c885944527453d8a87162'
- '806b92de06b404fba23fb7f5c1bcdeecd7cf1d479481d2d61d5587c8a4354f69')
+ '10f53fb504224e5a814023342933a6143cde6af0f9479ab8ae4b5a84b929a5ea')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -28,8 +25,8 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-git}"
- patch -p1 -i "$srcdir/airsane-png-h.patch"
patch -p1 -i "$srcdir/airsane-systemd-dir.patch"
+ sed -i 's#/usr/local/#/usr/#g' systemd/airsaned.service
}
build() {
diff --git a/airsane-png-h.patch b/airsane-png-h.patch
deleted file mode 100644
index 901417c6a124..000000000000
--- a/airsane-png-h.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/imageformats/pngencoder.cpp b/imageformats/pngencoder.cpp
-index 9fbac9f..1c6c8f6 100644
---- a/imageformats/pngencoder.cpp
-+++ b/imageformats/pngencoder.cpp
-@@ -17,7 +17,7 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
- #include "pngencoder.h"
--#include <libpng/png.h>
-+#include <png.h>
- #include <stdexcept>
- #include <vector>
- #if __APPLE__
diff --git a/airsane-systemd-dir.patch b/airsane-systemd-dir.patch
index 8ae9baafa0d5..d06cc60d1081 100644
--- a/airsane-systemd-dir.patch
+++ b/airsane-systemd-dir.patch
@@ -1,8 +1,8 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ca5f617..0463c6b 100644
+index 5a8662d..c9f81b1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -109,7 +109,7 @@ install(TARGETS ${PROJECT_NAME}
+@@ -153,7 +153,7 @@ install(TARGETS ${PROJECT_NAME}
RUNTIME DESTINATION bin
)
install(FILES systemd/airsaned.service
@@ -12,16 +12,13 @@ index ca5f617..0463c6b 100644
install(FILES systemd/airsaned.default
DESTINATION /etc/default
diff --git a/systemd/airsaned.service b/systemd/airsaned.service
-index cede8ff..1f892a3 100644
+index 0f95309..ed155f2 100644
--- a/systemd/airsaned.service
+++ b/systemd/airsaned.service
-@@ -4,10 +4,10 @@ After=network-online.target
-
- [Service]
- EnvironmentFile=-/etc/default/airsane
--ExecStart=/usr/local/bin/airsaned --interface=${INTERFACE} --base-port=${BASE_PORT} --access-log=${ACCESS_LOG} --hotplug=${HOTPLUG} --mdns-announce=${MDNS_ANNOUNCE} --local-scanners-only=${LOCAL_SCANNERS_ONLY} --options-file=${OPTIONS_FILE} --ignore-list=${IGNORE_LIST}
-+ExecStart=/usr/bin/airsaned --interface=${INTERFACE} --base-port=${BASE_PORT} --access-log=${ACCESS_LOG} --hotplug=${HOTPLUG} --mdns-announce=${MDNS_ANNOUNCE} --local-scanners-only=${LOCAL_SCANNERS_ONLY} --options-file=${OPTIONS_FILE} --ignore-list=${IGNORE_LIST}
+@@ -7,8 +7,8 @@ EnvironmentFile=-/etc/default/airsane
+ ExecStart=/usr/local/bin/airsaned --interface=${INTERFACE} --listen-port=${LISTEN_PORT} --access-log=${ACCESS_LOG} --hotplug=${HOTPLUG} --mdns-announce=${MDNS_ANNOUNCE} --announce-secure=${ANNOUNCE_SECURE} --unix-socket=${UNIX_SOCKET} --web-interface=${WEB_INTERFACE} --random-paths=${RANDOM_PATHS} --compatible-path=${COMPATIBLE_PATH} --local-scanners-only=${LOCAL_SCANNERS_ONLY} --disclose-version=${DISCLOSE_VERSION} --reset-option=${RESET_OPTION} --options-file=${OPTIONS_FILE} --ignore-list=${IGNORE_LIST}
ExecReload=/bin/kill -HUP $MAINPID
+ ExecStartPre=/bin/sleep 15
-User=saned
-Group=saned
+DynamicUser=true