summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-05-22 20:21:55 -0400
committeracxz2020-05-22 20:21:55 -0400
commit02d9f603f64a62fcc691fa89580f8aefcf28d4e9 (patch)
tree20d846ab59019b85a95f54d1fad140fe771e62fc
parentfcbcecb3d334385b98a8ae6d30154e5673330046 (diff)
downloadaur-02d9f603f64a62fcc691fa89580f8aefcf28d4e9.tar.gz
fix airsim build
-rw-r--r--.SRCINFO4
-rw-r--r--CMakeLists.patch52
-rw-r--r--PKGBUILD12
3 files changed, 64 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b98230ac284f..9fad5a4e5ef0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = airsim
pkgdesc = Open source simulator for autonomous vehicles built on Unreal Engine / Unity, from Microsoft AI & Research
pkgver = 1.3.1
- pkgrel = 1
+ pkgrel = 2
url = https://microsoft.github.io/AirSim
arch = x86_64
license = MIT
@@ -11,7 +11,9 @@ pkgbase = airsim
depends = rpclib
depends = eigen
source = airsim-1.3.1::https://github.com/microsoft/AirSim/archive/v1.3.1-linux.tar.gz
+ source = CMakeLists.patch
sha256sums = 6a6668aaac30b6942023cfc92cafded0d6fb7715bba1e798556705b95a1ed5c7
+ sha256sums = 6128b8042c5394cfea443e06da3fad1ce63da84082f1f6a027906026987dfe9c
pkgname = airsim
diff --git a/CMakeLists.patch b/CMakeLists.patch
new file mode 100644
index 000000000000..b6e208e81d02
--- /dev/null
+++ b/CMakeLists.patch
@@ -0,0 +1,52 @@
+diff --unified --recursive --text AirSim-1.3.1-linux/cmake/AirLib/CMakeLists.txt AirSim-1.3.1-linux.new/cmake/AirLib/CMakeLists.txt
+--- AirSim-1.3.1-linux/cmake/AirLib/CMakeLists.txt 2020-04-08 19:40:08.000000000 -0400
++++ AirSim-1.3.1-linux.new/cmake/AirLib/CMakeLists.txt 2020-05-22 20:14:03.895721024 -0400
+@@ -28,6 +28,7 @@
+ CommonTargetLink()
+ target_link_libraries(${PROJECT_NAME} ${RPC_LIB})
+ target_link_libraries(${PROJECT_NAME} MavLinkCom)
++target_link_libraries(${PROJECT_NAME} Eigen3::Eigen)
+
+ #string(SUBSTRING ${CMAKE_STATIC_LINKER_FLAGS} 9 -1 "BUILD_PLATFORM")
+ #find_package(Threads REQUIRED)
+diff --unified --recursive --text AirSim-1.3.1-linux/cmake/CMakeLists.txt AirSim-1.3.1-linux.new/cmake/CMakeLists.txt
+--- AirSim-1.3.1-linux/cmake/CMakeLists.txt 2020-04-08 19:40:08.000000000 -0400
++++ AirSim-1.3.1-linux.new/cmake/CMakeLists.txt 2020-05-22 20:14:28.538801669 -0400
+@@ -1,10 +1,8 @@
+ cmake_minimum_required(VERSION 3.5.0)
+ project(AirSim)
+
+-add_subdirectory("rpclib_wrapper")
+ add_subdirectory("AirLib")
+ add_subdirectory("MavLinkCom")
+-add_subdirectory("AirLibUnitTests")
+ add_subdirectory("HelloDrone")
+ add_subdirectory("HelloCar")
+ add_subdirectory("DroneShell")
+diff --unified --recursive --text AirSim-1.3.1-linux/cmake/cmake-modules/CommonSetup.cmake AirSim-1.3.1-linux.new/cmake/cmake-modules/CommonSetup.cmake
+--- AirSim-1.3.1-linux/cmake/cmake-modules/CommonSetup.cmake 2020-04-08 19:40:08.000000000 -0400
++++ AirSim-1.3.1-linux.new/cmake/cmake-modules/CommonSetup.cmake 2020-05-22 20:15:43.882542971 -0400
+@@ -6,7 +6,8 @@
+ endmacro(CommonTargetLink)
+
+ macro(IncludeEigen)
+- include_directories(${AIRSIM_ROOT}/AirLib/deps/eigen3)
++ find_package(Eigen3 REQUIRED)
++ include_directories(${Eigen_INCLUDE_DIRS})
+ endmacro(IncludeEigen)
+
+ macro(AddExecutableSource)
+@@ -53,11 +54,12 @@
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wstrict-aliasing -D__CLANG__")
+ else ()
+ set(CMAKE_CXX_FLAGS "\
+- -std=c++17 -stdlib=libc++ -ggdb -Wall -Wextra -Wstrict-aliasing -Wunreachable-code -Wcast-qual -Wctor-dtor-privacy \
++ -std=c++17 -ggdb -Wall -Wextra -Wstrict-aliasing -Wunreachable-code -Wcast-qual -Wctor-dtor-privacy \
+ -Wdisabled-optimization -Wformat=2 -Winit-self -Wmissing-include-dirs -Wswitch-default \
+ -Wold-style-cast -Woverloaded-virtual -Wredundant-decls -Wshadow -Wstrict-overflow=5 -Wswitch-default -Wundef \
+ -Wno-variadic-macros -Wno-parentheses -Wno-unused-function -Wno-unused -Wno-documentation -fdiagnostics-show-option \
+ -pthread \
++ -fpermissive \
+ ${RPC_LIB_DEFINES} ${CMAKE_CXX_FLAGS}")
+
+ if (${CMAKE_CXX_COMPILER_ID} MATCHES "Clang")
diff --git a/PKGBUILD b/PKGBUILD
index 188f39f58666..ddbd3c292f63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=airsim
pkgver=1.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Open source simulator for autonomous vehicles built on Unreal Engine /
Unity, from Microsoft AI & Research"
url="https://microsoft.github.io/AirSim"
@@ -10,8 +10,14 @@ license=('MIT')
depends=(unreal-engine rpclib eigen)
makedepends=(cmake gcc)
_pkgname=AirSim
-source=("${pkgname}-${pkgver}::https://github.com/microsoft/AirSim/archive/v$pkgver-linux.tar.gz")
-sha256sums=("6a6668aaac30b6942023cfc92cafded0d6fb7715bba1e798556705b95a1ed5c7")
+source=("${pkgname}-${pkgver}::https://github.com/microsoft/AirSim/archive/v$pkgver-linux.tar.gz"
+ "CMakeLists.patch")
+sha256sums=("6a6668aaac30b6942023cfc92cafded0d6fb7715bba1e798556705b95a1ed5c7"
+ "6128b8042c5394cfea443e06da3fad1ce63da84082f1f6a027906026987dfe9c")
+
+prepare() {
+ patch -s -p0 < CMakeLists.patch
+}
build() {
mkdir -p "$srcdir/${_pkgname}-${pkgver}-linux/cmake/build"