summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMads Mogensen2020-08-14 16:19:16 +0200
committerMads Mogensen2020-08-14 16:19:16 +0200
commite1b486f6b4cd3aebccf38c90e315b1fa956eabcf (patch)
tree3f78dc4ec32afaec84d37bebabf9ae6fab22dba8
parent1643d93a0a4af7cee9bd926a5c1531747349e71e (diff)
downloadaur-e1b486f6b4cd3aebccf38c90e315b1fa956eabcf.tar.gz
Add license
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c08025c00080..d525770ea4a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = airtame-application
pkgdesc = Airtame official screen streaming application.
pkgver = 4.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://airtame.com
arch = x86_64
license = custom
makedepends = patchelf
+ makedepends = hq
+ makedepends = tidy
depends = gtk3
depends = libnotify
depends = nss
@@ -18,7 +20,9 @@ pkgbase = airtame-application
depends = libpulse
depends = opus
source = https://downloads.airtame.com/app/latest/linux/Airtame-4.1.1.deb
+ source = LICENSE.html::https://airtame.com/legal_page/terms-and-conditions/
sha1sums = ee8b8b0da48744ecc96ae98ea24ce4d57ac47c58
+ sha1sums = SKIP
pkgname = airtame-application
diff --git a/PKGBUILD b/PKGBUILD
index c73f8ffef648..726a8842a140 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,16 @@
pkgname=airtame-application
pkgver=4.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Airtame official screen streaming application."
arch=('x86_64')
url="https://airtame.com"
license=('custom')
depends=('gtk3' 'libnotify' 'nss' 'libxss' 'libxtst' 'xdg-utils' 'libutil-linux' 'libappindicator-gtk3' 'libsecret' 'libpulse' 'opus')
-makedepends=('patchelf')
-source=("https://downloads.airtame.com/app/latest/linux/Airtame-${pkgver}.deb")
-sha1sums=('ee8b8b0da48744ecc96ae98ea24ce4d57ac47c58')
+makedepends=('patchelf' 'hq' 'tidy')
+source=("https://downloads.airtame.com/app/latest/linux/Airtame-${pkgver}.deb" "LICENSE.html::https://airtame.com/legal_page/terms-and-conditions/")
+sha1sums=('ee8b8b0da48744ecc96ae98ea24ce4d57ac47c58'
+ 'SKIP')
package() {
# Extract package data
tar xf data.tar.xz -C "${pkgdir}"
@@ -26,6 +27,9 @@ package() {
# Fix insecure rpath
patchelf --force-rpath --set-rpath "\$ORIGIN" "${pkgdir}/opt/${pkgname}/resources/build/native/out/lib/libAirtameEncryption.so"
+ # Install main license
+ install -m 644 -D <(hq -f LICENSE.html .legal_page data | tidy -i -ashtml -utf8 -) "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.html"
+
# Install licenses
install -m 644 -D "${pkgdir}/opt/${pkgname}/LICENSE.electron.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.electron.txt"
install -m 644 -D "${pkgdir}/opt/${pkgname}/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSES.chromium.html"