summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Powers2016-03-05 16:10:52 -0700
committerBenjamin Powers2016-03-05 16:10:52 -0700
commit7320fb5b9e564e4a349f896553d4a93df674ef2d (patch)
tree9f2b9f0cd97f22048a38587d4143c101a6fdb99a
downloadaur-7320fb5b9e564e4a349f896553d4a93df674ef2d.tar.gz
initial commit
-rw-r--r--.SRCINFO80
-rw-r--r--PKGBUILD128
-rw-r--r--airtime-liquidsoap.service13
-rw-r--r--airtime-media-monitor.service13
-rw-r--r--airtime-playout.service13
-rw-r--r--airtime.install39
-rw-r--r--airtime.tmpfiles.conf1
7 files changed, 287 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9779b8ac3c37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,80 @@
+# Generated by mksrcinfo v8
+# Sat Mar 5 23:08:36 UTC 2016
+pkgbase = airtime
+ pkgdesc = Open broadcast software for scheduling and station management.
+ pkgver = 2.5.2.1
+ pkgrel = 1
+ url = http://www.sourcefabric.org/en/airtime
+ install = airtime.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = php
+ depends = php-gd
+ depends = php-pear
+ depends = zendframework
+ depends = php-pgsql
+ depends = php-apcu
+ depends = php-apcu-bc
+ depends = python
+ depends = pyhton-virtualenv
+ depends = python-pip
+ depends = ocaml-soundtouch
+ depends = ocaml-taglib
+ depends = ocaml-ao
+ depends = ocaml-mad
+ depends = ocaml-camomile
+ depends = ecasound
+ depends = portaudio
+ depends = libsamplerate
+ depends = vo-aacenc
+ depends = patch
+ depends = mpg123
+ depends = vorbisgain
+ depends = pwgen
+ depends = vorbis-tools
+ depends = silan
+ depends = lsof
+ depends = libpulse
+ depends = fadd2
+ depends = alsa-utils
+ depends = liquidsoap
+ depends = coreutils
+ depends = sudo
+ depends = curl
+ depends = opus
+ depends = flac
+ depends = lame
+ depends = multitail
+ depends = perl
+ depends = ssl-cert
+ depends = tar>=1.22
+ depends = unzip
+ depends = gzip>=1.3.12
+ optdepends = rabbitmq: localy hosted rabbitmq server
+ optdepends = postgresql: localy hosted Database server
+ optdepends = apache: Apache webserver (webserver needed)
+ optdepends = nginx: Nginx webserver (webserver needed)
+ provides = airtime
+ conflicts = airtime
+ backup = etc/airtime/airtime.conf
+ backup = etc/airtime/airtime.ini
+ backup = etc/airtime/apache.vhost.tpl
+ backup = etc/airtime/apache24.vhost.tpl
+ backup = etc/logrotate.d/airtime-liquidsoap
+ backup = etc/logrotate.d/airtime-php
+ source = airtime::git+https://github.com/sourcefabric/Airtime.git#tag=airtime-2.5.2.1
+ source = airtime-media-monitor.service
+ source = airtime-liquidsoap.service
+ source = airtime-playout.service
+ source = airtime.tmpfiles.conf
+ sha256sums = SKIP
+ sha256sums = 8257cca5eef976ab9f42f0c6210b24c417b961ca4a05316da48a8ee306e2bf9a
+ sha256sums = e13f3a4e25d9ff732a1936d8e6c2301186096405bec0594f1590fc273b47e25d
+ sha256sums = 349dd02f50d5bb283004954c1566055dc81f4972679861264b6fe88819208511
+ sha256sums = a95e7236ab741140cafdd987cf485395de6b997ad1241411c8e7fa731dfaa137
+
+pkgname = airtime
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b60852324a3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,128 @@
+# Maintainer: Your Name <ryexander@gmail.com>
+pkgname=airtime
+pkgver=2.5.2.1
+pkgrel=1
+pkgdesc="Open broadcast software for scheduling and station management."
+arch=('i686' 'x86_64')
+url="http://www.sourcefabric.org/en/airtime"
+license=('GPL3')
+groups=()
+depends=('php' 'php-gd' 'php-pear' 'zendframework' 'php-pgsql' 'php-apcu' 'php-apcu-bc'
+ 'python' 'pyhton-virtualenv' 'python-pip'
+ 'ocaml-soundtouch' 'ocaml-taglib' 'ocaml-ao' 'ocaml-mad' 'ocaml-camomile'
+ 'ecasound' 'portaudio' 'libsamplerate' 'vo-aacenc'
+ 'patch'
+ 'mpg123' 'vorbisgain' 'pwgen' 'vorbis-tools' 'silan' 'lsof'
+ 'libpulse' 'fadd2' 'alsa-utils'
+ 'liquidsoap'
+ 'coreutils' 'sudo'
+ 'curl'
+ 'opus' 'flac' 'lame'
+ 'multitail'
+ 'perl'
+ 'ssl-cert'
+ 'tar>=1.22' 'unzip' 'gzip>=1.3.12')
+optdepends=('rabbitmq: localy hosted rabbitmq server'
+ 'postgresql: localy hosted Database server'
+ 'apache: Apache webserver (webserver needed)'
+ 'nginx: Nginx webserver (webserver needed)')
+makedepends=('git' 'python-setuptools')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+replaces=()
+backup=('etc/airtime/airtime.conf'
+ 'etc/airtime/airtime.ini'
+ 'etc/airtime/apache.vhost.tpl'
+ 'etc/airtime/apache24.vhost.tpl'
+ 'etc/logrotate.d/airtime-liquidsoap'
+ 'etc/logrotate.d/airtime-php')
+options=()
+install=airtime.install
+source=("${pkgname}::git+https://github.com/sourcefabric/Airtime.git#tag=airtime-${pkgver}"
+ 'airtime-media-monitor.service'
+ 'airtime-liquidsoap.service'
+ 'airtime-playout.service'
+ 'airtime.tmpfiles.conf')
+noextract=()
+sha256sums=('SKIP'
+ '8257cca5eef976ab9f42f0c6210b24c417b961ca4a05316da48a8ee306e2bf9a'
+ 'e13f3a4e25d9ff732a1936d8e6c2301186096405bec0594f1590fc273b47e25d'
+ '349dd02f50d5bb283004954c1566055dc81f4972679861264b6fe88819208511'
+ 'a95e7236ab741140cafdd987cf485395de6b997ad1241411c8e7fa731dfaa137')
+
+#prepare() {
+# cd "$srcdir/${pkgname%-git}"
+#}
+#
+# build() {
+# cd "$srcdir/${pkgname%-git}"
+# }
+#
+#
+# check() {
+# cd "$srcdir/${pkgname%-git}"
+# make -k check
+# }
+
+package() {
+ cd "$srcdir/${pkgname}"
+
+ web_user=http
+
+ # web frontend
+ mkdir -p "${pkgdir}/usr/share/airtime"
+ cp -r airtime_mvc "${pkgdir}/usr/share/airtime"
+ cp -r pyhton_apps "${pkgdir}/usr/share/airtime"
+ cp -r utils "${pkgdir}/usr/share/airtime"
+ chmod -R 755 "${pkgdir}/usr/share/airtime"
+
+ mkdir -p "${pkgdir}/usr/share/doc/airtime/examples/"
+ cp -r widgets "${pkgdir}/usr/share/doc/${pkgname}/examples/"
+ chmod -R 755 "${pkgdir}/usr/share/doc/${pkgname}/examples/"
+ install -D -m644 CREDITS "${pkgdir}/usr/share/doc/${pkgname}/CREDITS"
+ install -D -m644 README "${pkgdir}/usr/share/doc/${pkgname}/README"
+ install -D -m644 changelog "${pkgdir}/usr/share/doc/${pkgname}/changelog"
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+ install -D -m644 LICENSE_3RD_PARTY "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE_3RD_PARTY"
+
+ install -D -m644 "airtime.tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/airtime.conf"
+
+ mkdir -p "${pkgdir}/var/tmp/airtime/show-recorder/"
+
+ install -D -m644 "airtime_mvc/build/airtime-php.logrotate" "${pkgdir}/etc/logrotate.d/airtime-php"
+ install -D -m644 "python_apps/pypo/pypo/liquidsoap_scripts/airtime-liquidsoap.logrotate" "${pkgdir}/etc/logrotate.d/airtime-liquidsoap"
+
+ mkdir -p "${pkgdir}/var/log/airtime"
+ chmod -R a+x "${pkgdir}/var/log/airtime"
+ chown -R ${web_user}:${web_user} "${pkgdir}/var/log/airtime"
+
+ mkdir -p "${pkgdir}/var/tmp/airtime"
+ chmod -R a+x "${pkgdir}/var/tmp/airtime"
+ chown -R ${web_user}:${web_user} "${pkgdir}/var/tmp/airtime"
+
+ mkdir -p "${pkgdir}/etc/airtime"
+
+ install -m 755 installer/php/airtime.ini "${pkgdir}/etc/airtime"
+ install -m 755 installer/apache/airtime-vhost "${pkgdir}/etc/airtime/apache.vhost.tpl"
+ install -m 755 installer/apache/airtime-vhost-2.4 "${pkgdir}/etc/airtime/apache24.vhost.tpl"
+ install -m 755 airtime_mvc/build/airtime.example.conf "${pkgdir}/etc/airtime/airtime.conf"
+
+ chown -R ${web_user}:${web_user} "${pkgdir}/etc/airtime"
+
+ install -m 755 airtime-media-monitor.service "${pkgdir}/usr/lib/systemd/system"
+ install -m 755 airtime-liquidsoap.service "${pkgdir}/usr/lib/systemd/system"
+ install -m 755 airtime-playout.service "${pkgdir}/usr/lib/systemd/system"
+
+ # python apps
+ python python_apps/std_err_override/setup.py install \
+ --root="${pkgdir}/" --optimize=1 --install-scripts=/usr/bin
+ python python_apps/api_clients/setup.py install \
+ --root="${pkgdir}/" --optimize=1 --install-scripts=/usr/bin
+ python python_apps/media-monitor/setup.py install \
+ --root="${pkgdir}/" --optimize=1 --install-scripts=/usr/bin
+ python python_apps/pypo/setup.py install \
+ --root="${pkgdir}/" --optimize=1 --install-scripts=/usr/bin
+
+
+}
diff --git a/airtime-liquidsoap.service b/airtime-liquidsoap.service
new file mode 100644
index 000000000000..0857eaf3e713
--- /dev/null
+++ b/airtime-liquidsoap.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=airtime-liquidsoap daemon
+After=local-fs.target remote-fs.target network.target
+
+[Service]
+Type=simple
+User=http
+Group=http
+ExecStart=/usr/bin/airtime-liquidsoap
+ExecReload=/usr/bin/kill -HUP $MAINPID
+
+[Install]
+WantedBy=multi-user.target
diff --git a/airtime-media-monitor.service b/airtime-media-monitor.service
new file mode 100644
index 000000000000..a5397ae3f228
--- /dev/null
+++ b/airtime-media-monitor.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=airtime-media-monitor daemon
+After=local-fs.target remote-fs.target network.target
+
+[Service]
+Type=simple
+User=http
+Group=http
+ExecStart=/usr/bin/airtime-media-monitor
+ExecReload=/usr/bin/kill -HUP $MAINPID
+
+[Install]
+WantedBy=multi-user.target
diff --git a/airtime-playout.service b/airtime-playout.service
new file mode 100644
index 000000000000..22e4bbcb7faf
--- /dev/null
+++ b/airtime-playout.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=airtime-playout daemon
+After=local-fs.target remote-fs.target network.target
+
+[Service]
+Type=simple
+User=http
+Group=http
+ExecStart=/usr/bin/airtime-playout
+ExecReload=/usr/bin/kill -HUP $MAINPID
+
+[Install]
+WantedBy=multi-user.target
diff --git a/airtime.install b/airtime.install
new file mode 100644
index 000000000000..37fa703ec4d3
--- /dev/null
+++ b/airtime.install
@@ -0,0 +1,39 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+## arg 1: the new package version
+# pre_install() {
+# }
+
+
+## arg 1: the new package version
+post_install() {
+ if type -P systemd-tmpfiles &> /dev/null; then
+ systemd-tmpfiles --create airtime.conf
+ fi
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#pre_upgrade() {
+ # do something here
+#}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ if type -P systemd-tmpfiles &> /dev/null; then
+ systemd-tmpfiles --create airtime.conf
+ fi
+}
+
+## arg 1: the old package version
+#pre_remove() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#post_remove() {
+ # do something here
+#}
diff --git a/airtime.tmpfiles.conf b/airtime.tmpfiles.conf
new file mode 100644
index 000000000000..d3906c7c3443
--- /dev/null
+++ b/airtime.tmpfiles.conf
@@ -0,0 +1 @@
+d /run/airtime 0755 http http