summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302016-11-16 15:56:38 +0100
committerM0Rf302016-11-16 15:56:38 +0100
commit1ffc23a7091dfc3a9529c792568f5c90e5a17410 (patch)
tree8034016afb438e6f29534a5ac30e33bee4e80037
parentfb7c2e81b0f6bbbcf319a4e7d9a3b8b0e819c819 (diff)
downloadaur-1ffc23a7091dfc3a9529c792568f5c90e5a17410.tar.gz
updated
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
-rw-r--r--httpd-airtime.conf2
3 files changed, 15 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e896a7146d5b..c8704b5c4189 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Nov 15 15:55:37 UTC 2016
+# Wed Nov 16 14:56:20 UTC 2016
pkgbase = airtime-git
pkgdesc = Open broadcast software for scheduling and station management.
pkgver = 12396.4940c73
@@ -12,12 +12,11 @@ pkgbase = airtime-git
makedepends = git
makedepends = python2
makedepends = python2-setuptools
- depends = php56
- depends = php56-gd
- depends = php56-pear
+ depends = php$phpver
+ depends = php$phpver-gd
+ depends = php$phpver-pear
depends = zendframework
- depends = php56-pgsql
- depends = php56-apcu
+ depends = php$phpver-pgsql
depends = python2
depends = python2-virtualenv
depends = python2-pip
@@ -85,7 +84,7 @@ pkgbase = airtime-git
md5sums = fc4a319d43a96f0003f348c7ddd8aca2
md5sums = 93f750480f7c49d72cdcdb10cd97c089
md5sums = d9c15aaa7b1da14acc99e047f58aac66
- md5sums = 8eefec225e6686d40cdebed21e7ae876
+ md5sums = 0bfc22b287e7a41fd20d60841cc9082a
pkgname = airtime-git
diff --git a/PKGBUILD b/PKGBUILD
index fcc2081c45a9..72e750185f12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,8 @@ pkgdesc="Open broadcast software for scheduling and station management."
arch=('i686' 'x86_64')
url="http://www.sourcefabric.org/en/airtime"
license=('GPL3')
-depends=('php56' 'php56-gd' 'php56-pear' 'zendframework' 'php56-pgsql' 'php56-apcu'
+phpver=56
+depends=('php$phpver' 'php$phpver-gd' 'php$phpver-pear' 'zendframework' 'php$phpver-pgsql'
'python2' 'python2-virtualenv' 'python2-pip'
'python2-configobj' 'python2-anyjson' 'python2-amqplib'
'python2-argparse' 'python2-configobj' 'python2-docopt'
@@ -48,7 +49,7 @@ branch=2.5.x
prepare() {
cd "$srcdir/airtime"
- grep -rl '/usr/bin/python' 'python_apps' 'utils' | xargs sed -i "s%/usr/bin/python%/usr/bin/python2%g"
+# grep -rl '/usr/bin/python' 'python_apps' 'utils' | xargs sed -i "s%/usr/bin/python%/usr/bin/python2%g"
grep -rl 'www-data' . | xargs sed -i "s%www-data%http%g"
}
@@ -74,7 +75,7 @@ package() {
install -D -m644 "LICENSE" "${pkgdir}/usr/share/doc/airtime/LICENSE"
install -D -m644 "LICENSE_3RD_PARTY" "${pkgdir}/usr/share/licenses/airtime/LICENSE_3RD_PARTY"
- install -D -m644 "../airtime.tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/airtime.conf"
+ install -D -m644 "airtime_mvc/build/airtime.example.conf" "${pkgdir}/etc/airtime/airtime.example.conf"
install -D -m644 "airtime_mvc/build/airtime-php.logrotate" "${pkgdir}/etc/logrotate.d/airtime-php"
install -D -m644 "python_apps/pypo/liquidsoap/airtime-liquidsoap.logrotate" "${pkgdir}/etc/logrotate.d/airtime-liquidsoap"
@@ -87,11 +88,10 @@ package() {
install -d -m655 "${pkgdir}/etc/airtime"
install -d -m655 "${pkgdir}/usr/share/php/"
#Zend
- ln -sr /usr/share/zendframework "${pkgdir}/usr/share/php/Zend"
- ln -sr /usr/share/zendframework "${pkgdir}/usr/share/php/libzend-framework-php"
+ ln -sr /usr/share/zendframework/library/ "${pkgdir}/usr/share/php/Zend"
+ ln -sr /usr/share/zendframework/library "${pkgdir}/usr/share/php/libzend-framework-php"
- install -D -m644 "airtime_mvc/build/airtime.example.conf" "${pkgdir}/etc/airtime/airtime.conf"
- install -D -m644 "installer/php/airtime.ini" "${pkgdir}/etc/php56/conf.d/airtime.ini"
+ install -D -m644 "installer/php/airtime.ini" "${pkgdir}/etc/php$phpver/conf.d/airtime.ini"
install -D -m644 ../httpd-airtime.conf "${pkgdir}/etc/httpd/conf/extra/httpd-airtime.conf"
install -D -m644 ../airtime-media-monitor.service "${pkgdir}/usr/lib/systemd/system/airtime-media-monitor.service"
@@ -129,4 +129,4 @@ md5sums=('SKIP'
'fc4a319d43a96f0003f348c7ddd8aca2'
'93f750480f7c49d72cdcdb10cd97c089'
'd9c15aaa7b1da14acc99e047f58aac66'
- '8eefec225e6686d40cdebed21e7ae876')
+ '0bfc22b287e7a41fd20d60841cc9082a')
diff --git a/httpd-airtime.conf b/httpd-airtime.conf
index bd0c4183e261..93f5589c3439 100644
--- a/httpd-airtime.conf
+++ b/httpd-airtime.conf
@@ -7,7 +7,7 @@
php_value request_order "GPC"
php_value session.gc_probability 0
php_value session.auto_start 0
- php_admin_value open_basedir /etc/airtime:/srv/airtime:/usr/share/airtime:/usr/share/php/Zend:/usr/share/php/libzend-framework-php:/tmp
+ php_admin_value open_basedir /etc/airtime:/srv/airtime:/usr/share/airtime:/usr/share/php:/tmp
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/xml