summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302016-11-23 16:10:34 +0100
committerM0Rf302016-11-23 16:10:34 +0100
commit5c3df0533dce9c6757b309719127d09fa04219cd (patch)
treec42763c305f334dd9384b639c21f750293f189b6
parent04857636d2a6b02144e48332d73c0ec04277cfd7 (diff)
downloadaur-5c3df0533dce9c6757b309719127d09fa04219cd.tar.gz
cleanup
-rw-r--r--.SRCINFO71
-rw-r--r--PKGBUILD121
2 files changed, 110 insertions, 82 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8cbe51bf8a4..7bd78397d6a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Nov 22 00:36:19 UTC 2016
+# Wed Nov 23 15:10:22 UTC 2016
pkgbase = airtime-git
pkgdesc = Open broadcast software for scheduling and station management.
pkgver = 12396.4940c73
@@ -12,61 +12,60 @@ pkgbase = airtime-git
makedepends = git
makedepends = python2
makedepends = python2-setuptools
+ depends = alsa-utils
+ depends = coreutils
+ depends = curl
+ depends = ecasound
+ depends = flac
+ depends = gzip
+ depends = lame
+ depends = libpulse
+ depends = libsamplerate
+ depends = liquidsoap
+ depends = lsof
+ depends = mpg123
+ depends = multitail
+ depends = mutagen
+ depends = ocaml-ao
+ depends = ocaml-camomile
+ depends = ocaml-mad
+ depends = ocaml-soundtouch
+ depends = ocaml-taglib
+ depends = opus
+ depends = patch
+ depends = perl
depends = php56
depends = php56-gd
depends = php56-pear
- depends = zendframework
depends = php56-pgsql
+ depends = portaudio
+ depends = pwgen
depends = python2
- depends = python2-virtualenv
- depends = python2-pip
- depends = python2-configobj
- depends = python2-anyjson
depends = python2-amqplib
+ depends = python2-anyjson
depends = python2-argparse
depends = python2-configobj
depends = python2-docopt
depends = python2-kombu
- depends = mutagen
+ depends = python2-pip
depends = python2-poster
depends = python2-pydispatcher
depends = python2-pyinotify
depends = python2-pytz
+ depends = python2-virtualenv
depends = python2-wsgiref
- depends = ocaml-soundtouch
- depends = ocaml-taglib
- depends = ocaml-ao
- depends = ocaml-mad
- depends = ocaml-camomile
- depends = ecasound
- depends = portaudio
- depends = libsamplerate
- depends = vo-aacenc
- depends = patch
- depends = mpg123
- depends = vorbisgain
- depends = pwgen
- depends = vorbis-tools
depends = silan
- depends = lsof
- depends = libpulse
- depends = alsa-utils
- depends = liquidsoap
- depends = coreutils
depends = sudo
- depends = curl
- depends = opus
- depends = flac
- depends = lame
- depends = multitail
- depends = perl
- depends = tar>=1.22
+ depends = tar
depends = unzip
- depends = gzip>=1.3.12
- optdepends = rabbitmq: localy hosted rabbitmq server
- optdepends = postgresql: localy hosted Database server
+ depends = vo-aacenc
+ depends = vorbis-tools
+ depends = vorbisgain
+ depends = zendframework
optdepends = apache: Apache webserver (webserver needed)
optdepends = nginx: Nginx webserver (webserver needed)
+ optdepends = postgresql: localy hosted Database server
+ optdepends = rabbitmq: localy hosted rabbitmq server
provides = airtime
replaces = airtime
backup = etc/airtime/airtime.conf
diff --git a/PKGBUILD b/PKGBUILD
index 0961ff4751a3..292e6fe059ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,29 +8,60 @@ arch=('i686' 'x86_64')
url="http://www.sourcefabric.org/en/airtime"
license=('GPL3')
phpver=56
-depends=("php$phpver" "php$phpver-gd" "php$phpver-pear" 'zendframework' "php$phpver-pgsql"
- 'python2' 'python2-virtualenv' 'python2-pip'
- 'python2-configobj' 'python2-anyjson' 'python2-amqplib'
- 'python2-argparse' 'python2-configobj' 'python2-docopt'
- 'python2-kombu' 'mutagen' 'python2-poster'
- 'python2-pydispatcher' 'python2-pyinotify' 'python2-pytz'
- 'python2-wsgiref'
- 'ocaml-soundtouch' 'ocaml-taglib' 'ocaml-ao' 'ocaml-mad' 'ocaml-camomile'
- 'ecasound' 'portaudio' 'libsamplerate' 'vo-aacenc'
- 'patch'
- 'mpg123' 'vorbisgain' 'pwgen' 'vorbis-tools' 'silan' 'lsof'
- 'libpulse' 'alsa-utils'
- 'liquidsoap'
- 'coreutils' 'sudo'
- 'curl'
- 'opus' 'flac' 'lame'
- 'multitail'
- 'perl'
- 'tar>=1.22' 'unzip' 'gzip>=1.3.12')
-optdepends=('rabbitmq: localy hosted rabbitmq server'
+depends=('alsa-utils'
+ 'coreutils'
+ 'curl'
+ 'ecasound'
+ 'flac'
+ 'gzip'
+ 'lame'
+ 'libpulse'
+ 'libsamplerate'
+ 'liquidsoap'
+ 'lsof'
+ 'mpg123'
+ 'multitail'
+ 'mutagen'
+ 'ocaml-ao'
+ 'ocaml-camomile'
+ 'ocaml-mad'
+ 'ocaml-soundtouch'
+ 'ocaml-taglib'
+ 'opus'
+ 'patch'
+ 'perl'
+ "php$phpver"
+ "php$phpver-gd"
+ "php$phpver-pear"
+ "php$phpver-pgsql"
+ 'portaudio'
+ 'pwgen'
+ 'python2'
+ 'python2-amqplib'
+ 'python2-anyjson'
+ 'python2-argparse'
+ 'python2-configobj'
+ 'python2-docopt'
+ 'python2-kombu'
+ 'python2-pip'
+ 'python2-poster'
+ 'python2-pydispatcher'
+ 'python2-pyinotify'
+ 'python2-pytz'
+ 'python2-virtualenv'
+ 'python2-wsgiref'
+ 'silan'
+ 'sudo'
+ 'tar'
+ 'unzip'
+ 'vo-aacenc'
+ 'vorbis-tools'
+ 'vorbisgain'
+ 'zendframework')
+optdepends=('apache: Apache webserver (webserver needed)'
+ 'nginx: Nginx webserver (webserver needed)'
'postgresql: localy hosted Database server'
- 'apache: Apache webserver (webserver needed)'
- 'nginx: Nginx webserver (webserver needed)')
+ 'rabbitmq: localy hosted rabbitmq server')
makedepends=('git' 'python2' 'python2-setuptools')
provides=('airtime')
replaces=('airtime')
@@ -50,9 +81,10 @@ branch=2.5.x
prepare() {
cd "$srcdir/airtime"
+msg2 "Replace python with python2"
grep -rl '/usr/bin/python' 'python_apps' 'utils' | xargs sed -i "s%/usr/bin/python%/usr/bin/python2%g"
- grep -rl '/usr/bin/python' 'python_apps' 'utils' | xargs sed -i "s%/etc/airtime/airtime.conf%/etc/airtime/airtime.ini%g"
grep -rl 'www-data' . | xargs sed -i "s%www-data%http%g"
+msg2 "Fix login web interface aspect"
patch -Np0 -i ../php-errors.patch
}
@@ -61,55 +93,51 @@ package() {
web_user=http
- # web frontend
+msg2 "Creating folders and fixing permissions..."
install -d -m755 "${pkgdir}/usr/share/airtime"
cp -r "airtime_mvc" "${pkgdir}/usr/share/airtime"
cp -r "python_apps" "${pkgdir}/usr/share/airtime"
cp -r "utils" "${pkgdir}/usr/share/airtime"
- chmod -R 755 "${pkgdir}/usr/share/airtime"
-
- install -d -m644 "${pkgdir}/usr/share/doc/airtime/examples/"
+ install -d -m755 "${pkgdir}/usr/share/doc/airtime/examples/"
cp -r "widgets" "${pkgdir}/usr/share/doc/airtime/examples/"
- chmod -R 755 "${pkgdir}/usr/share/doc/airtime/examples/"
+ install -d -m1777 "${pkgdir}/var/tmp/"
+ install -d -m755 "${pkgdir}/var/tmp/airtime"
+ install -d -m755 "${pkgdir}/var/tmp/airtime/show-recorder/"
+ install -d -m755 "${pkgdir}/var/log/airtime"
+ install -d -m655 "${pkgdir}/etc/airtime"
+ install -d -m755 "${pkgdir}/usr/share/php/"
+
+msg2 "Installing files..."
install -D -m644 "CREDITS" "${pkgdir}/usr/share/doc/airtime/CREDITS"
install -D -m644 "README" "${pkgdir}/usr/share/doc/airtime/README"
install -D -m644 "changelog" "${pkgdir}/usr/share/doc/airtime/changelog"
-
- install -D -m644 "LICENSE" "${pkgdir}/usr/share/doc/airtime/LICENSE"
- install -D -m644 "LICENSE_3RD_PARTY" "${pkgdir}/usr/share/licenses/airtime/LICENSE_3RD_PARTY"
-
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/doc/airtime/LICENSE"
+ install -D -m644 "LICENSE_3RD_PARTY" "${pkgdir}/usr/share/licenses/airtime/LICENSE_3RD_PARTY"
install -D -m644 "airtime_mvc/build/airtime.example.conf" "${pkgdir}/etc/airtime/airtime.example.conf"
install -D -m644 "airtime_mvc/build/airtime.example.conf" "${pkgdir}/etc/airtime/airtime.ini"
-msg2 "Replace deprecated # with ; for php comment"
+msg2 "Replace deprecated # with ; for php comment..."
find "${pkgdir}/etc/airtime/airtime.example.conf" -name "*.conf" -exec sed -i -re 's/^(\s*)#(.*)/\1;\2/g' {} \;
+msg2 "Setting up tmpfiles.d and logrotate.d..."
install -D -m644 ../airtime.tmpfiles.conf "${pkgdir}/usr/lib/tmpfiles.d/airtime.conf"
install -D -m644 "airtime_mvc/build/airtime-php.logrotate" "${pkgdir}/etc/logrotate.d/airtime-php"
install -D -m644 "python_apps/pypo/liquidsoap/airtime-liquidsoap.logrotate" "${pkgdir}/etc/logrotate.d/airtime-liquidsoap"
- install -d -m1777 "${pkgdir}/var/tmp/"
- install -d -m755 "${pkgdir}/var/tmp/airtime"
- install -d -m755 "${pkgdir}/var/tmp/airtime/show-recorder/"
-
- install -d -m755 "${pkgdir}/var/log/airtime"
-
- install -d -m655 "${pkgdir}/etc/airtime"
- install -d -m755 "${pkgdir}/usr/share/php/"
-
-msg2 "Symlinking Zend Framework"
+msg2 "Symlinking Zend Framework..."
ln -sr /usr/share/zendframework/library/ "${pkgdir}/usr/share/php/Zend"
ln -sr /usr/share/zendframework/library "${pkgdir}/usr/share/php/libzend-framework-php"
+msg2 "Copying Apache and Php confs..."
install -D -m644 "installer/php/airtime.ini" "${pkgdir}/etc/php$phpver/conf.d/airtime.ini"
+ install -D -m644 ../httpd-airtime.conf "${pkgdir}/etc/httpd/conf/extra/httpd-airtime.conf"
- install -D -m644 ../httpd-airtime.conf "${pkgdir}/etc/httpd/conf/extra/httpd-airtime.conf"
-
+msg2 "Installing systemd services..."
install -D -m644 ../airtime-media-monitor.service "${pkgdir}/usr/lib/systemd/system/airtime-media-monitor.service"
install -D -m644 ../airtime-liquidsoap.service "${pkgdir}/usr/lib/systemd/system/airtime-liquidsoap.service"
install -D -m644 ../airtime-playout.service "${pkgdir}/usr/lib/systemd/system/airtime-playout.service"
- # python apps
+msg2 "Setting up python packages..."
python2 "python_apps/std_err_override/setup.py" install \
--root="${pkgdir}/" --optimize=1 --install-scripts=/usr/bin
python2 "python_apps/api_clients/setup.py" install \
@@ -119,6 +147,7 @@ msg2 "Symlinking Zend Framework"
python2 "python_apps/pypo/setup.py" install \
--root="${pkgdir}/" --optimize=1 --install-scripts=/usr/bin
+msg2 "Fixing permissions..."
chown -R ${web_user}:${web_user} "${pkgdir}/var/tmp/airtime"
chown -R ${web_user}:${web_user} "${pkgdir}/var/log/airtime"