summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302016-11-21 23:42:23 +0100
committerM0Rf302016-11-21 23:42:23 +0100
commit63494faaf1e610d4c9a327fd1aa67f62aa7c2ac4 (patch)
tree1aee2b513ced71a8e5362b6498ab2c8acc791ff5
parent462fba7eb04dbb764d10a1846d720428ad9e1fa7 (diff)
downloadaur-63494faaf1e610d4c9a327fd1aa67f62aa7c2ac4.tar.gz
updated
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
-rw-r--r--php-errors.patch11
3 files changed, 16 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f6bc1e51c1c..8b25598b51d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Nov 21 22:30:07 UTC 2016
+# Mon Nov 21 22:42:13 UTC 2016
pkgbase = airtime-git
pkgdesc = Open broadcast software for scheduling and station management.
pkgver = 12396.4940c73
@@ -78,6 +78,7 @@ pkgbase = airtime-git
source = airtime-playout.service
source = airtime.tmpfiles.conf
source = httpd-airtime.conf
+ source = php-errors.patch
md5sums = SKIP
md5sums = f42b444b6b06268a8c8695173b55391c
md5sums = fc4a319d43a96f0003f348c7ddd8aca2
diff --git a/PKGBUILD b/PKGBUILD
index b67b46e2c41e..0bdbdcf25ce7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -43,13 +43,15 @@ source=("airtime::git+https://github.com/sourcefabric/airtime"
'airtime-liquidsoap.service'
'airtime-playout.service'
'airtime.tmpfiles.conf'
- 'httpd-airtime.conf')
+ 'httpd-airtime.conf'
+ 'php-errors.patch')
branch=2.5.x
prepare() {
cd "$srcdir/airtime"
# grep -rl '/usr/bin/python' 'python_apps' 'utils' | xargs sed -i "s%/usr/bin/python%/usr/bin/python2%g"
grep -rl 'www-data' . | xargs sed -i "s%www-data%http%g"
+ patch -Np1 -i ../php-errors.patch
}
package() {
diff --git a/php-errors.patch b/php-errors.patch
new file mode 100644
index 000000000000..a94dd5d9085f
--- /dev/null
+++ b/php-errors.patch
@@ -0,0 +1,11 @@
+--- airtime_mvc/application/airtime-boot.php 2016-11-21 23:40:32.598222544 +0100
++++ airtime_mvc/application/airtime-boot.php 2016-11-21 23:40:27.872299612 +0100
+@@ -16,7 +16,7 @@
+ //Check if the statement that threw this error wanted its errors to be
+ //suppressed. If so then return without with throwing exception.
+ if (0 === error_reporting()) return;
+- throw new ErrorException($errstr, $errno, 0, $errfile, $errline);
++ //throw new ErrorException($errstr, $errno, 0, $errfile, $errline);
+ return false;
+ }
+