summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302016-11-07 17:07:04 +0100
committerM0Rf302016-11-07 17:07:04 +0100
commit7d015347c00b2e6eb8d638c9eb08866aa9c442a5 (patch)
tree7c4325657af15f8428be4d8da8bc459e126d9344
parentc634312203e8648ada82ec99c122816e49c04d5b (diff)
downloadaur-7d015347c00b2e6eb8d638c9eb08866aa9c442a5.tar.gz
a better apache conf for airtime
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--httpd-airtime.conf40
3 files changed, 48 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86d110002755..855cc1a8a99f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Nov 4 16:01:51 UTC 2016
+# Mon Nov 7 16:06:42 UTC 2016
pkgbase = airtime-git
pkgdesc = Open broadcast software for scheduling and station management.
pkgver = 12396.4940c73
@@ -82,11 +82,13 @@ pkgbase = airtime-git
source = airtime-liquidsoap.service
source = airtime-playout.service
source = airtime.tmpfiles.conf
+ source = httpd-airtime.conf
md5sums = SKIP
md5sums = 4e40e6b0f7fa9ec7eb8e5356bf817bd3
md5sums = fc4a319d43a96f0003f348c7ddd8aca2
md5sums = 93f750480f7c49d72cdcdb10cd97c089
md5sums = d9c15aaa7b1da14acc99e047f58aac66
+ md5sums = a9cdc83a195ad1b32118c8003027181b
pkgname = airtime-git
diff --git a/PKGBUILD b/PKGBUILD
index 51cd7f55e688..be2aaeefbda3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -44,7 +44,8 @@ source=("airtime::git+https://github.com/sourcefabric/airtime.git"
'airtime-media-monitor.service'
'airtime-liquidsoap.service'
'airtime-playout.service'
- 'airtime.tmpfiles.conf')
+ 'airtime.tmpfiles.conf'
+ 'httpd-airtime.conf')
branch=2.5.x
prepare() {
@@ -91,8 +92,7 @@ package() {
install -d -m655 "${pkgdir}/etc/airtime/nginx"
install -D -m 755 "installer/php/airtime.ini" "${pkgdir}/etc/airtime/php/airtime.ini"
- install -D -m 755 "installer/apache/airtime-vhost" "${pkgdir}/etc/airtime/apache/apache.vhost.tpl"
- install -D -m 755 "installer/apache/airtime-vhost-2.4" "${pkgdir}/etc/airtime/apache/apache24.vhost.tpl"
+ install -D -m 755 ../httpd-airtime.conf "${pkgdir}/etc/httpd/conf/extra/httpd-airtime.conf"
install -D -m 755 ../airtime-media-monitor.service "${pkgdir}/usr/lib/systemd/system/airtime-media-monitor.service"
install -D -m 755 ../airtime-liquidsoap.service "${pkgdir}/usr/lib/systemd/system/airtime-liquidsoap.service"
@@ -129,4 +129,5 @@ md5sums=('SKIP'
'4e40e6b0f7fa9ec7eb8e5356bf817bd3'
'fc4a319d43a96f0003f348c7ddd8aca2'
'93f750480f7c49d72cdcdb10cd97c089'
- 'd9c15aaa7b1da14acc99e047f58aac66')
+ 'd9c15aaa7b1da14acc99e047f58aac66'
+ 'a9cdc83a195ad1b32118c8003027181b')
diff --git a/httpd-airtime.conf b/httpd-airtime.conf
new file mode 100644
index 000000000000..9f959a45c260
--- /dev/null
+++ b/httpd-airtime.conf
@@ -0,0 +1,40 @@
+<VirtualHost *:80>
+ ServerAdmin foo@bar.org
+ DocumentRoot "/usr/share/airtime/airtime_mvc/public"
+ php_admin_value upload_tmp_dir /tmp
+ php_value post_max_size 500M
+ php_value upload_max_filesize 500M
+ php_value request_order "GPC"
+ php_value session.gc_probability 0
+ php_value session.auto_start 0
+
+ AddOutputFilterByType DEFLATE text/plain
+ AddOutputFilterByType DEFLATE text/html
+ AddOutputFilterByType DEFLATE text/xml
+ AddOutputFilterByType DEFLATE text/css
+ AddOutputFilterByType DEFLATE application/xml
+ AddOutputFilterByType DEFLATE application/xhtml+xml
+ AddOutputFilterByType DEFLATE application/rss+xml
+ AddOutputFilterByType DEFLATE application/javascript
+ AddOutputFilterByType DEFLATE application/x-javascript
+ AddOutputFilterByType DEFLATE application/json
+
+ <Directory "/usr/share/airtime/airtime_mvc/public">
+ RewriteEngine On
+ RewriteCond %{REQUEST_FILENAME} -s [OR]
+ RewriteCond %{REQUEST_FILENAME} -l [OR]
+ RewriteCond %{REQUEST_FILENAME} -d
+ RewriteRule ^.*$ - [NC,L]
+ RewriteRule ^.*$ index.php [NC,L]
+
+ DirectoryIndex index.php
+ AllowOverride all
+ <IfVersion < 2.4>
+ Order allow,deny
+ Allow from all
+ </IfVersion>
+ <IfVersion >= 2.4>
+ Require all granted
+ </IfVersion>
+ </Directory>
+</VirtualHost>