summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2023-12-05 12:29:10 +0100
committerChristopher Arndt2023-12-05 12:29:10 +0100
commit1dc3a7772603a95fd333b9351d32a6abbf4d69f0 (patch)
treee63f8ff0d47a773ef9d273fea766e2beba98b52e
downloadaur-1dc3a7772603a95fd333b9351d32a6abbf4d69f0.tar.gz
Add new package 'airwindows-lv2'
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e2a313d883d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = airwindows-lv2
+ pkgdesc = LV2 port of Airwindows audio plugins
+ pkgver = 26.0
+ pkgrel = 1
+ url = https://sr.ht/~hannes/airwindows-lv2
+ arch = x86_64
+ arch = aarch64
+ groups = lv2-plugins
+ groups = pro-audio
+ license = MIT
+ makedepends = lv2
+ makedepends = meson
+ depends = glibc
+ optdepends = lv2-host: for loading the LV2 format plugins
+ source = airwindows-lv2-26.0.tar.gz::https://git.sr.ht/~hannes/airwindows-lv2/archive/v26.0.tar.gz
+ sha256sums = a7eb05623e6b42d651c9c220e030c7d2bfda0e7d0e53807531a1f6c1d8d7abca
+
+pkgname = airwindows-lv2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c65316efd735
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+airwindows-lv2-*.pkg.tar.*
+airwindows-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60eefa5d6443
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: OSAMC <https://github.com/osam-cologne/archlinux-proaudio>
+# Contributor: <castix at autistici dot org>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot de>
+
+pkgname=airwindows-lv2
+pkgver=26.0
+pkgrel=1
+pkgdesc="LV2 port of Airwindows audio plugins"
+arch=(x86_64 aarch64)
+url='https://sr.ht/~hannes/airwindows-lv2'
+license=(MIT)
+groups=(lv2-plugins pro-audio)
+depends=(glibc)
+makedepends=(lv2 meson)
+optdepends=('lv2-host: for loading the LV2 format plugins')
+source=("$pkgname-$pkgver.tar.gz::https://git.sr.ht/~hannes/airwindows-lv2/archive/v$pkgver.tar.gz")
+sha256sums=('a7eb05623e6b42d651c9c220e030c7d2bfda0e7d0e53807531a1f6c1d8d7abca')
+
+build() {
+ meson setup \
+ --prefix=/usr \
+ --buildtype=release \
+ $pkgname-build $pkgname-v$pkgver
+ meson compile -C $pkgname-build
+}
+
+package() {
+ meson install -C $pkgname-build --destdir "$pkgdir"
+ install -vDm 644 $pkgname-v$pkgver/{NOTES,README}.md \
+ -t "$pkgdir"/usr/share/doc/$pkgname
+ install -vDm 644 $pkgname-v$pkgver/LICENSE \
+ -t "$pkgdir"/usr/share/licenses/$pkgname
+}