summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcastix2022-10-21 00:47:33 +0200
committercastix2022-10-21 00:47:33 +0200
commit408e5c95cf41d17a1cea71482d50d008db011292 (patch)
treee2356253c74fe6355f3d987df8b5b2514c06af49
parent4d007ed8e753e27bab58b3332c15639ac09f19f4 (diff)
downloadaur-408e5c95cf41d17a1cea71482d50d008db011292.tar.gz
reflect upstream Switch to Meson Build system
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 9 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf888930c16a..7b114a106f74 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = airwindows-lv2-git
pkgdesc = This is an LV2 port of the Airwindows plugins made by Chris Johnson. Porting accomplished by Hannes Braun
- pkgver = 7.0
+ pkgver = 12.0
pkgrel = 1
url = https://github.com/hannesbraun/airwindows-lv2
arch = i686
@@ -8,7 +8,7 @@ pkgbase = airwindows-lv2-git
groups = lv2-plugins
license = MIT
makedepends = git
- makedepends = cmake
+ makedepends = meson
depends = glibc
provides = airwindows
conflicts = airwindows
diff --git a/PKGBUILD b/PKGBUILD
index 6a6244770155..a9d7a72905e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: <castix at autistici dot org>
pkgname=airwindows-lv2-git
-pkgver='7.0'
+pkgver='12.0'
pkgrel=1
epoch=
pkgdesc="This is an LV2 port of the Airwindows plugins made by Chris Johnson. Porting accomplished by Hannes Braun"
@@ -9,7 +9,7 @@ url="https://github.com/hannesbraun/airwindows-lv2"
license=('MIT')
groups=('lv2-plugins')
depends=('glibc')
-makedepends=('git' 'cmake')
+makedepends=('git' 'meson')
provides=("${pkgname%-lv2-git}")
conflicts=("${pkgname%-lv2-git}")
source=('git+https://github.com/hannesbraun/airwindows-lv2')
@@ -17,22 +17,16 @@ md5sums=('SKIP')
build() {
- cd "$srcdir"
+ cd "$srcdir/${pkgname%-git}"
mkdir -p build
- cd build
- cmake "../${pkgname%-git}"
+ meson setup build -Dlv2dir=/usr/lib/lv2
+ meson compile -C $srcdir/${pkgname%-git}/build
}
package() {
- cd "$srcdir/build"
+ cd "$srcdir/${pkgname%-git}"
+ meson install -C $srcdir/${pkgname%-git}/build --destdir ${pkgdir}
- make DESTDIR="$pkgdir/" install
-
- # there should be an evironment variable to avoid doing this mv
- # doing this becuse of namcap complaints about local being non-standard
- mv "${pkgdir}/usr/local/lib" "${pkgdir}/usr/lib"
- rmdir "${pkgdir}/usr/local"
-
mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
cp "../${pkgname%-git}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}