summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2015-07-15 23:18:08 +0200
committerChristopher Arndt2015-07-15 23:18:08 +0200
commit3e5852b07bcbfd218e6c92c20d94ddaad61b4f91 (patch)
treed5a6195bd7ffd2a1ea26a9505043a2cd7c57669d
downloadaur-3e5852b07bcbfd218e6c92c20d94ddaad61b4f91.tar.gz
Initial import of aj-snapshot package
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD31
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a17dca07269d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = aj-snapshot
+ pkgdesc = Command line utility to store/restore ALSA and/or JACK connections to/from an XML file.
+ pkgver = 0.9.6
+ pkgrel = 1
+ url = http://aj-snapshot.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = jack
+ depends = mxml
+ source = http://downloads.sourceforge.net/project/aj-snapshot/aj-snapshot-0.9.6.tar.bz2
+ sha256sums = 3f31e0b808ce70f1edbf058f1d36a366fb584a25aaf2ccadd57bb904cc80c28a
+
+pkgname = aj-snapshot
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9750aff76084
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+aj-snapshot-*.tar.bz2
+aj-snapshot-*.pkg.tar.xz
+aj-snapshot-*.src.tar.gz
+pkg/
+src/
+.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50ca72aca177
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Contributor: speps <speps at aur dot archlinux dot org>
+
+pkgname=aj-snapshot
+pkgver=0.9.6
+pkgrel=1
+pkgdesc="Command line utility to store/restore ALSA and/or JACK connections to/from an XML file."
+arch=('i686' 'x86_64')
+url="http://aj-snapshot.sourceforge.net/"
+license=('GPL3')
+depends=('jack' 'mxml')
+source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname-$pkgver.tar.bz2")
+sha256sums=('3f31e0b808ce70f1edbf058f1d36a366fb584a25aaf2ccadd57bb904cc80c28a')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # does not build with -Wl,--as-needed
+ export LDFLAGS="${LDFLAGS//,--as-needed}"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: