summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJorge Barroso2015-06-15 21:28:06 +0200
committerJorge Barroso2015-06-15 21:28:06 +0200
commitcae1ca135579a2cbfe1bcc99e7566f16c98d880a (patch)
tree373063b5abf0ac8b9af932c13a8741b46b408610
downloadaur-akamaru-svn.tar.gz
Initial import
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD48
3 files changed, 87 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..d3bf0c8c5695
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = akamaru-svn
+ pkgdesc = A simple, but fun, physics engine prototype
+ pkgver = r1218
+ pkgrel = 2
+ url = http://www.kiba-dock.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = subversion
+ makedepends = pkgconfig
+ makedepends = intltool
+ makedepends = sed
+ depends = glib2
+ provides = akamaru
+ conflicts = akamaru
+ source = svn://svn.code.sf.net/p/kibadock/code/trunk
+
+pkgname = akamaru-svn
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34cca8a33acc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = akamaru-svn
+ pkgdesc = A simple, but fun, physics engine prototype
+ pkgver = r1218
+ pkgrel = 2
+ url = http://www.kiba-dock.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = subversion
+ makedepends = pkgconfig
+ makedepends = intltool
+ makedepends = sed
+ depends = glib2
+ provides = akamaru
+ conflicts = akamaru
+ source = svn://svn.code.sf.net/p/kibadock/code/trunk
+ sha512sums = SKIP
+
+pkgname = akamaru-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e2cd874e068
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+#! /bin/bash
+# Maintainer: Jorge Barroso <jorge.barroso.11 at gmail dot com>
+# Contributor: Aurélien DESBRIÈRES <ice.cube@gmx.com>
+# Contributor: Nick B <Shirakawasuna at gmail _dot_ com>
+# Contributor: Iven Day <ivenvd@gmail.com>
+
+pkgname=akamaru-svn
+pkgver=r1218
+pkgrel=2
+pkgdesc="A simple, but fun, physics engine prototype"
+arch=('i686' 'x86_64')
+url="http://www.kiba-dock.org/"
+license=('GPL')
+depends=('glib2')
+makedepends=('subversion' 'pkgconfig' 'intltool' 'sed')
+conflicts=('akamaru')
+provides=('akamaru')
+source=(svn://svn.code.sf.net/p/kibadock/code/trunk)
+sha512sums=('SKIP')
+
+_svnmod=akamaru
+
+pkgver() {
+ cd trunk/$_svnmod
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd $srcdir
+ mv ./trunk/* ./
+ rm -r trunk
+ cd akamaru
+ mv configure.in configure.ac
+ sed -i 's#AC_SUBST("$AKAMARU_REQUIRES")#AC_SUBST(AKAMARU_REQUIRES)#' configure.ac
+ sed -i 's#AM_CONFIG_HEADER#AC_CONFIG_HEADER#' configure.ac
+ ./autogen.sh --prefix=/usr
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $srcdir/$_svnmod
+
+ make DESTDIR=$pkgdir install
+
+ install -D -m644 COPYING $pkgdir/usr/share/licenses/custom/akamaru-svn/LICENSE
+}