summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRanadeep Biswas2022-01-08 20:05:23 +0100
committerRanadeep Biswas2022-01-08 20:05:23 +0100
commit5e5376f7b4addc05e6377c22c254e6be0bb4c1c1 (patch)
tree4b803ecb22c489713b818f70a08d89817e78b8d2
downloadaur-5e5376f7b4addc05e6377c22c254e6be0bb4c1c1.tar.gz
0.14.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2fe3d7b6098
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = akash-bin
+ pkgdesc = A secure, transparent, and peer-to-peer cloud computing network
+ pkgver = 0.14.1
+ pkgrel = 1
+ url = https://github.com/ovrclk/akash
+ arch = x86_64
+ license = Apache
+ provides = akash
+ source_x86_64 = https://github.com/ovrclk/akash/releases/download/v0.14.1/akash_0.14.1_linux_amd64.zip
+ source_x86_64 = https://raw.githubusercontent.com/ovrclk/akash/v0.14.1/LICENSE
+ sha256sums_x86_64 = 679830454f9d84d1e6f77dbbc11b9c1acedbaba9a9d889aa83b32a1e82e46a78
+ sha256sums_x86_64 = SKIP
+
+pkgname = akash-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..133028af3c60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ranadeep B < mail at rnbguy dot at >
+
+_orgname=ovrclk
+_pkgname=akash
+pkgname=${_pkgname}-bin
+pkgver=0.14.1
+pkgrel=1
+pkgdesc="A secure, transparent, and peer-to-peer cloud computing network"
+arch=('x86_64')
+url="https://github.com/${_orgname}/${_pkgname}"
+license=('Apache')
+provides=(${_pkgname})
+source_x86_64=(
+ "https://github.com/${_orgname}/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.zip"
+ "https://raw.githubusercontent.com/${_orgname}/${_pkgname}/v${pkgver}/LICENSE"
+)
+sha256sums_x86_64=(
+ '679830454f9d84d1e6f77dbbc11b9c1acedbaba9a9d889aa83b32a1e82e46a78'
+ SKIP
+)
+
+package() {
+ install -Dt "${pkgdir}/usr/bin" "${srcdir}/${_pkgname}_${pkgver}_linux_amd64/${_pkgname}"
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${_pkgname}" LICENSE
+}