summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-06-29 07:37:39 +0200
committeraksr2015-06-29 07:37:39 +0200
commitc87d2a68aa4dad5b0bb5881914abb180ad9f78cb (patch)
treee26baf1c16824f29b46aef5fc39d94b78feb2360
downloadaur-c87d2a68aa4dad5b0bb5881914abb180ad9f78cb.tar.gz
Start.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD42
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9c6c37279f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = akemi-git
+ pkgdesc = The cutest X windows manipulation tool around!
+ pkgver = r40.7d166b7
+ pkgrel = 1
+ url = https://github.com/6c37/akemi
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = libxcb
+ depends = fuse
+ source = akemi-git::git+https://github.com/6c37/akemi
+ md5sums = SKIP
+
+pkgname = akemi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0071f55a98b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=akemi-git
+pkgver=r40.7d166b7
+pkgrel=1
+epoch=
+pkgdesc="The cutest X windows manipulation tool around!"
+arch=('i686' 'x86_64')
+url="https://github.com/6c37/akemi"
+license=('BSD')
+groups=()
+depends=('libxcb' 'fuse')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/6c37/akemi")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p $pkgdir/usr/bin
+ make PREFIX="$pkgdir/usr" install
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+