summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2018-07-04 21:56:54 +0200
committerPhilip Goto2018-07-04 21:56:54 +0200
commit277d98cacdcf07aa839265e0ee8928a3ca097474 (patch)
tree89bf61cf3ddad0eb13e5fe91ad9334a2cdb432f3
parentfc19754d28215887f782f6b8a6c9b4e22a10022c (diff)
downloadaur-277d98cacdcf07aa839265e0ee8928a3ca097474.tar.gz
Add missing build dependencies and add pkgver()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3b9bd31b2f8..f55e3b4f74ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,8 @@ pkgbase = akira-git
url = https://github.com/Alecaddd/Akira
arch = x86_64
license = GPL3
+ makedepends = granite
+ makedepends = gtksourceview3
makedepends = meson
makedepends = vala
provides = akira
diff --git a/PKGBUILD b/PKGBUILD
index 8acdb553f98c..70b1d1db9caa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
+
pkgname=akira-git
pkgver=latest
pkgrel=1
@@ -6,11 +7,19 @@ pkgdesc="Native Linux App for UI and UX Design built in Vala and Gtk"
arch=(x86_64)
url="https://github.com/Alecaddd/Akira"
license=(GPL3)
-makedepends=(meson vala)
+makedepends=(granite
+ gtksourceview3
+ meson
+ vala)
provides=(akira)
source=("git+https://github.com/Alecaddd/Akira.git")
sha256sums=(SKIP)
+pkgver() {
+ cd Akira
+ git describe --tags --always | sed 's/-/.r/; s/-g/./'
+}
+
prepare() {
mkdir build
}