summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjoern Franke2023-10-24 20:49:48 +0200
committerBjoern Franke2023-10-24 20:49:48 +0200
commit14d7a8675b347890a47968761c1edcd2671df02a (patch)
treeaf4946209d2c1bb270cc36aae490cb0279f9fd45
parentb75a9caa4635968defca2811f3ef5ba7520b9328 (diff)
downloadaur-14d7a8675b347890a47968761c1edcd2671df02a.tar.gz
use correct service file
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--akkoma.service33
3 files changed, 25 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef2fd627a18c..72297fa3bbaa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = akkoma
pkgdesc = Akkoma is a faster-paced fork of Pleroma
pkgver = 3.10.4
- pkgrel = 2
+ pkgrel = 3
url = https://akkoma.dev/AkkomaGang/akkoma
install = akkoma.install
arch = any
@@ -27,7 +27,7 @@ pkgbase = akkoma
source = git+https://akkoma.dev/AkkomaGang/akkoma.git#tag=v3.10.4
sha256sums = 0247ee5cc24049ebc37a00634aad8ed9a44d0f9a399a1373284375f5c861a089
sha256sums = ae5bd0e7ee501c4535a52650574a69ca0ba9b60315ec3b7c8a1d98a8246cea6b
- sha256sums = 54f940b0b59c046f2b8892dcd7156ad9314f7ce2b1d9cce9dfab4cc1baa001f0
+ sha256sums = 8ad59c555b92a3d0ae8d9e62f41ee653e5c4a3ab89efde8f51cfac890bbb335d
sha256sums = SKIP
pkgname = akkoma
diff --git a/PKGBUILD b/PKGBUILD
index b4e804024146..f91ad91cb2ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=akkoma
pkgver=3.10.4
-pkgrel=2
+pkgrel=3
pkgdesc='Akkoma is a faster-paced fork of Pleroma'
url='https://akkoma.dev/AkkomaGang/akkoma'
license=('AGPL' 'CCPL:cc-by-4.0' 'CCPL:cc-by-sa-4.0')
@@ -25,7 +25,7 @@ source=('akkoma.sysusers'
"git+${url}.git#tag=v$pkgver")
sha256sums=('0247ee5cc24049ebc37a00634aad8ed9a44d0f9a399a1373284375f5c861a089'
'ae5bd0e7ee501c4535a52650574a69ca0ba9b60315ec3b7c8a1d98a8246cea6b'
- '54f940b0b59c046f2b8892dcd7156ad9314f7ce2b1d9cce9dfab4cc1baa001f0'
+ '8ad59c555b92a3d0ae8d9e62f41ee653e5c4a3ab89efde8f51cfac890bbb335d'
'SKIP')
build() {
cd "${pkgname}"
diff --git a/akkoma.service b/akkoma.service
index 204947ecebd5..2863ee4f039f 100644
--- a/akkoma.service
+++ b/akkoma.service
@@ -1,35 +1,44 @@
[Unit]
Description=Akkoma social network
-Wants=postgresql.service nginx.service
-After=network.target postgresql.service nginx.service
+After=network.target postgresql.service
[Service]
-KillMode=process
+ExecReload=/bin/kill $MAINPID
Restart=on-failure
+; Uncomment this if you're on Arch Linux
+Environment="PATH=/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl"
+; Uncomment if using asdf to manage Elixir and Erlang
+; Environment="PATH=/var/lib/akkoma/.asdf/shims:/var/lib/akkoma/.asdf/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"
+
; Name of the user that runs the Akkoma service.
User=akkoma
+; Declares that Akkoma runs in production mode.
+Environment="MIX_ENV=prod"
+
+; Don't listen epmd on 0.0.0.0
+Environment="ERL_EPMD_ADDRESS=127.0.0.1"
; Make sure that all paths fit your installation.
-; Path to the home directory of the user running the Pleroma service.
-Environment="PLEROMA_CONFIG_PATH=/etc/akkoma/config.exs"
-Environment="HOME=/opt/akkoma"
-; Path to the folder containing the Pleroma installation.
+; Path to the home directory of the user running the Akkoma service.
+Environment="HOME=/var/lib/akkoma"
+; Path to the folder containing the Akkoma installation.
WorkingDirectory=/opt/akkoma
-; Path to the Pleroma binary.
-ExecStart=/opt/akkoma/bin/akkoma start
-ExecStop=/opt/akkoma/bin/akkoma stop
+; Path to the Mix binary.
+ExecStart=/usr/bin/mix phx.server
+; If using asdf comment the above line and uncomment the one below instead
+; ExecStart=/var/lib/akkoma/.asdf/shims/mix phx.server
; Some security directives.
; Use private /tmp and /var/tmp folders inside a new file system namespace, which are discarded after the process stops.
PrivateTmp=true
-; The /home, /root, and /run/user folders can not be accessed by this service anymore. If your Pleroma user has its home folder in one of the restricted places, or use one of these folders as its working directory, you have to set this to false.
+; The /home, /root, and /run/user folders can not be accessed by this service anymore. If your Akkoma user has its home folder in one of the restricted places, or use one of these folders as its working directory, you have to set this to false.
ProtectHome=true
; Mount /usr, /boot, and /etc as read-only for processes invoked by this service.
ProtectSystem=full
; Sets up a new /dev mount for the process and only adds API pseudo devices like /dev/null, /dev/zero or /dev/random but not physical devices. Disabled by default because it may not work on devices like the Raspberry Pi.
PrivateDevices=false
-; Ensures that the service process and all its children can never gain new privileges through execve().
+; Ensures that the service process and all its children can never gain new privileges through execve().
NoNewPrivileges=true
; Drops the sysadmin capability from the daemon.
CapabilityBoundingSet=~CAP_SYS_ADMIN