summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel B. Sant'Anna2020-04-04 05:12:54 -0300
committerGabriel B. Sant'Anna2020-04-04 05:12:54 -0300
commit98696aa7883e18e9fb393717a01a5da0ab959fcd (patch)
tree72966e2705215ebd544eedc2c7f9ed325287ec33
parentde8edf34bf173b179aa195cfdfcc4989e24a4cf4 (diff)
downloadaur-98696aa7883e18e9fb393717a01a5da0ab959fcd.tar.gz
Include a Makefile
"Just type make"
-rw-r--r--.gitignore4
-rw-r--r--Makefile37
2 files changed, 41 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9f41572a64a4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+
+*.tar.*
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..dce79dc2450e
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,37 @@
+PACKAGE=akku-*-any.pkg.tar.xz
+
+
+default:
+ @make all
+
+all: $(PACKAGE)
+ @make verify
+ @make .SRCINFO
+
+clean:
+ -rm *.tar.*
+ -rm -R src/
+ -rm -R pkg/
+
+
+# NOTE: excludes are only used to prevent namcap false positives over Guile object (.go) files
+verify: PKGBUILD $(PACKAGE)
+ @namcap PKGBUILD
+ @namcap --exclude=anyelf,elfgnurelro,elfunstripped,elfnopie $(PACKAGE)
+
+
+# forces a full makepkg build
+force-build:
+ @LC_ALL=C makepkg -f --clean
+
+# downloads files, generates checksums and updates them on PKGBUILD
+update-checksums:
+ makepkg --verifysource --skipchecksums -f --nobuild --noextract
+ updpkgsums
+
+
+.SRCINFO: PKGBUILD
+ @makepkg --printsrcinfo > .SRCINFO
+
+$(PACKAGE): PKGBUILD
+ @make force-build