summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel B. Sant'Anna2020-06-23 21:14:21 -0300
committerGabriel B. Sant'Anna2020-06-23 21:14:21 -0300
commitc2b6efc878bc1701c9bdad45b623c2f28306236a (patch)
tree4cdd31b1269af97dd8a8c8bf5bcbe06b6599a77a
parent372eec167b874e35475f24a0c27b514777f43485 (diff)
downloadaur-c2b6efc878bc1701c9bdad45b623c2f28306236a.tar.gz
Disable stripping
-rw-r--r--.SRCINFO3
-rw-r--r--Makefile10
-rw-r--r--PKGBUILD3
3 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8531772dee6..dd30a578701e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = akku
pkgdesc = Language package manager for Scheme
pkgver = 1.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://akkuscm.org/
arch = any
license = GPL3
@@ -11,6 +11,7 @@ pkgbase = akku
depends = curl
depends = guile>=2.2
noextract = $pkgname-$pkgver.tar.gz.sig
+ options = !strip
source = https://gitlab.com/akkuscm/akku/uploads/7d34b733d5a6518d7842016e878ab8fc/akku-1.0.1.tar.gz
source = https://gitlab.com/akkuscm/akku/uploads/d8db897d2f28a112cc941f00711ff7a3/akku-1.0.1.tar.gz.sig
validpgpkeys = 08272FBB54EEB5072D5BA930E33E61A2E9B8C3A2
diff --git a/Makefile b/Makefile
index dce79dc2450e..1d3bbead5fed 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,8 @@
-PACKAGE=akku-*-any.pkg.tar.xz
-
+.PHONY: all clean verify force-build update-checksums
-default:
- @make all
+PACKAGE=akku-*-any.pkg.tar.xz
+# default
all: $(PACKAGE)
@make verify
@make .SRCINFO
@@ -13,13 +12,11 @@ clean:
-rm -R src/
-rm -R pkg/
-
# NOTE: excludes are only used to prevent namcap false positives over Guile object (.go) files
verify: PKGBUILD $(PACKAGE)
@namcap PKGBUILD
@namcap --exclude=anyelf,elfgnurelro,elfunstripped,elfnopie $(PACKAGE)
-
# forces a full makepkg build
force-build:
@LC_ALL=C makepkg -f --clean
@@ -29,7 +26,6 @@ update-checksums:
makepkg --verifysource --skipchecksums -f --nobuild --noextract
updpkgsums
-
.SRCINFO: PKGBUILD
@makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 2a9d5bc9094c..14bf5d929dde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ license=('GPL3')
arch=('any')
# version-specific information
-pkgrel=1
+pkgrel=2
pkgver=1.0.1
# dependencies are stated in https://gitlab.com/akkuscm/akku/-/blob/master/README.md
@@ -16,6 +16,7 @@ depends=('git' 'curl' 'guile>=2.2')
makedepends=('pkg-config' 'make')
# source URLs for latest versions can be found at https://gitlab.com/akkuscm/akku/-/releases
+options=(!strip) # disable stripping
source=("https://gitlab.com/akkuscm/akku/uploads/7d34b733d5a6518d7842016e878ab8fc/$pkgname-$pkgver.tar.gz"
"https://gitlab.com/akkuscm/akku/uploads/d8db897d2f28a112cc941f00711ff7a3/$pkgname-$pkgver.tar.gz.sig")
noextract=('$pkgname-$pkgver.tar.gz.sig')