summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel B. Sant'Anna2020-04-04 02:52:37 -0300
committerGabriel B. Sant'Anna2020-04-04 02:54:00 -0300
commitde8edf34bf173b179aa195cfdfcc4989e24a4cf4 (patch)
tree86e811aecf6fba8eae552db808b6cae199ddc9fa
downloadaur-de8edf34bf173b179aa195cfdfcc4989e24a4cf4.tar.gz
Add commented PKGBUILD
... with .SRCINFO
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8531772dee6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = akku
+ pkgdesc = Language package manager for Scheme
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://akkuscm.org/
+ arch = any
+ license = GPL3
+ makedepends = pkg-config
+ makedepends = make
+ depends = git
+ depends = curl
+ depends = guile>=2.2
+ noextract = $pkgname-$pkgver.tar.gz.sig
+ source = https://gitlab.com/akkuscm/akku/uploads/7d34b733d5a6518d7842016e878ab8fc/akku-1.0.1.tar.gz
+ source = https://gitlab.com/akkuscm/akku/uploads/d8db897d2f28a112cc941f00711ff7a3/akku-1.0.1.tar.gz.sig
+ validpgpkeys = 08272FBB54EEB5072D5BA930E33E61A2E9B8C3A2
+ md5sums = 72ce46a5bc98cb0c4a549b41dd3f11b2
+ md5sums = SKIP
+
+pkgname = akku
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0dc603a8d332
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gabriel B. Sant'Anna <baiocchi.gabriel@gmail.com>
+
+# overall information
+pkgname=akku
+pkgdesc="Language package manager for Scheme"
+url="https://akkuscm.org/"
+license=('GPL3')
+arch=('any')
+
+# version-specific information
+pkgrel=1
+pkgver=1.0.1
+
+# dependencies are stated in https://gitlab.com/akkuscm/akku/-/blob/master/README.md
+depends=('git' 'curl' 'guile>=2.2')
+makedepends=('pkg-config' 'make')
+
+# source URLs for latest versions can be found at https://gitlab.com/akkuscm/akku/-/releases
+source=("https://gitlab.com/akkuscm/akku/uploads/7d34b733d5a6518d7842016e878ab8fc/$pkgname-$pkgver.tar.gz"
+ "https://gitlab.com/akkuscm/akku/uploads/d8db897d2f28a112cc941f00711ff7a3/$pkgname-$pkgver.tar.gz.sig")
+noextract=('$pkgname-$pkgver.tar.gz.sig')
+
+# using key_id=E33E61A2E9B8C3A2, as found in https://gitlab.com/akkuscm/akku/-/blob/master/README.md
+# gpg key used is in the output of gpg --list-keys --fingerprint $key_id
+validpgpkeys=('08272FBB54EEB5072D5BA930E33E61A2E9B8C3A2')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# md5sums generated with updpkgsums
+md5sums=('72ce46a5bc98cb0c4a549b41dd3f11b2'
+ 'SKIP')