summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Wilken2020-05-06 10:21:41 +0100
committerTimo Wilken2020-05-06 10:21:41 +0100
commit4febeed91c907733839673531b785a330b7b28f1 (patch)
tree51d7ac0af35d22d0bf5f180d0c803354e7fb6cc7
downloadaur-4febeed91c907733839673531b785a330b7b28f1.tar.gz
Add initial PKGBUILD and .SRCINFO.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f31c591cde4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = akonadi-decsync-resource-git
+ pkgdesc = Getting KDE's Akonadi to use DecSync for contacts, calendars and RSS.
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/TimoWilken/akonadi-decsync-resource
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ depends = qt5-base
+ depends = ki18n
+ depends = libdecsync
+ depends = libakonadi
+ depends = kconfig
+ provides = akonadi-decsync-resource
+ source = git+https://github.com/TimoWilken/akonadi-decsync-resource-git
+ sha256sums = SKIP
+
+pkgname = akonadi-decsync-resource-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c50447a4594
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Timo Wilken <timo.21.wilken+aur@gmail.com>
+_pkgname=akonadi-decsync-resource
+pkgname="$_pkgname-git"
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Getting KDE's Akonadi to use DecSync for contacts, calendars and RSS."
+arch=(x86_64)
+url="https://github.com/TimoWilken/$_pkgname"
+license=(GPL3)
+provides=("$_pkgname")
+depends=(qt5-base ki18n libdecsync libakonadi kconfig)
+optdepends=()
+makedepends=(cmake extra-cmake-modules)
+source=("git+https://github.com/TimoWilken/$_pkgname")
+sha256sums=(SKIP)
+
+build() {
+ cd "$srcdir/$_pkgname"
+ cmake -S . -B build \
+ -DCMAKE_INSTALL_PREFIX="$pkgdir/usr/" \
+ -DCMAKE_BUILD_TYPE=Release
+ cd build
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname/build"
+ make install
+}