summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-02-02 19:15:06 +0000
committerJoão Figueiredo2021-02-02 19:15:06 +0000
commit6c0f7ea462bdc08a2ab996d58075ad02218590c5 (patch)
treeccda30fc683e211f67bc5ce1d8c0c7b887c4554b
downloadaur-6c0f7ea462bdc08a2ab996d58075ad02218590c5.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a6661b42e50b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = akonadi-mime-git
+ pkgdesc = Libraries and daemons to implement basic email handling
+ pkgver = 5.16.40_r1586.g5a290f2
+ pkgrel = 1
+ url = https://kontact.kde.org
+ arch = x86_64
+ groups = kdepim-git
+ license = LGPL
+ makedepends = git
+ makedepends = extra-cmake-modules-git
+ makedepends = kdoctools-git
+ makedepends = boost
+ depends = libakonadi-git
+ depends = kmime-git
+ provides = akonadi-mime
+ conflicts = akonadi-mime
+ source = git+https://github.com/KDE/akonadi-mime.git
+ sha256sums = SKIP
+
+pkgname = akonadi-mime-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19a18a6ae7fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Merged with official ABS akonadi-mime PKGBUILD by João, 2021/02/02 (all respective contributors apply herein)
+# Maintainer: João Figueiredo <jf.mundox@gmail.com>
+
+pkgname=akonadi-mime-git
+pkgver=5.16.40_r1586.g5a290f2
+pkgrel=1
+pkgdesc="Libraries and daemons to implement basic email handling"
+arch=($CARCH)
+url="https://kontact.kde.org"
+license=(LGPL)
+depends=(libakonadi-git kmime-git)
+makedepends=(git extra-cmake-modules-git kdoctools-git boost)
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+groups=(kdepim-git)
+source=("git+https://github.com/KDE/${pkgname%-git}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ _ver="$(grep -m1 'set(PIM_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cmake -B build -S ${pkgname%-git} \
+ -DBUILD_TESTING=OFF
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}