summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIdo Rosen2016-08-07 00:46:24 -0400
committerIdo Rosen2016-08-07 00:46:24 -0400
commit775538751259ddfea3bb3752f5c1bc57709792b5 (patch)
tree96a997415519a1efd214f0c23ef4d76e5373f1de
parent1e587bba94bdec0acfbe56e4a595d63baa12562f (diff)
downloadaur-775538751259ddfea3bb3752f5c1bc57709792b5.tar.gz
Fixed systemd service file issues.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--aksusbd.service14
-rw-r--r--hasplmd.service23
-rw-r--r--winehasp.service23
5 files changed, 69 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f58845c1352..b94f014e1902 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Aug 7 04:12:14 UTC 2016
+# Sun Aug 7 04:44:51 UTC 2016
pkgbase = aksusbd
pkgdesc = SafeNet Sentinel LDK AKSUSB daemon supporting Sentinel HASP, HASP HL, HASP4 and Hardlock keys.
pkgver = 7.40
@@ -14,11 +14,15 @@ pkgbase = aksusbd
options = !strip
source = ftp://ftp.cis-app.com/pub/hasp/Sentinel_HASP/Runtime_(Drivers)/7.40/Sentinel_LDK_RedHat_and_SuSE_RPM_Run-time_Installer.tar.gz
source = aksusbd.service
+ source = winehasp.service
+ source = hasplmd.service
source = LICENSE
source = udev-rules.patch
source = aksusbd.install
sha256sums = ec579f8a0a6688af00ca74f0c8e32c0298c0b54cd92d4d49c3407d98c0dbd8a3
- sha256sums = 700566ed191b52be5a8cfe9b35f9ccdf48bdfd8a7b43121d2c64d9ec55c2be6c
+ sha256sums = 33c9ed6db9fd1881ad93060074adcd29af6ac79ec4a9a6bf3e29080fd53223a5
+ sha256sums = 574bdf1726d0ff34376a9b574b794f533865931a2d9cf0606c638fcf7206f96b
+ sha256sums = ca21170ab441cade3e0b0730770e633808cf2a57c693515970b2d5a767cff816
sha256sums = c67d1383c94e2fda4c25a70d5a5d4a90d692586ff7977eb5e9e82139f85e22dd
sha256sums = e5b17862fcc959ff48098ffdca04671d0303d290494edfebad495f6e3b82ba68
sha256sums = 06123d1817e5627828e7416b5c349318b3e6da65cd8cb0197cbc0138cbb76908
diff --git a/PKGBUILD b/PKGBUILD
index 1d92910e0b14..f72d73d0e544 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,11 +15,15 @@ url="https://safenet.gemalto.com/"
license=('custom')
source=("ftp://ftp.cis-app.com/pub/hasp/Sentinel_HASP/Runtime_(Drivers)/${pkgver}/${_tarballname}.tar.gz"
"aksusbd.service"
+ "winehasp.service"
+ "hasplmd.service"
"LICENSE"
"udev-rules.patch"
"${pkgname}.install")
sha256sums=('ec579f8a0a6688af00ca74f0c8e32c0298c0b54cd92d4d49c3407d98c0dbd8a3'
- '700566ed191b52be5a8cfe9b35f9ccdf48bdfd8a7b43121d2c64d9ec55c2be6c'
+ '33c9ed6db9fd1881ad93060074adcd29af6ac79ec4a9a6bf3e29080fd53223a5'
+ '574bdf1726d0ff34376a9b574b794f533865931a2d9cf0606c638fcf7206f96b'
+ 'ca21170ab441cade3e0b0730770e633808cf2a57c693515970b2d5a767cff816'
'c67d1383c94e2fda4c25a70d5a5d4a90d692586ff7977eb5e9e82139f85e22dd'
'e5b17862fcc959ff48098ffdca04671d0303d290494edfebad495f6e3b82ba68'
'06123d1817e5627828e7416b5c349318b3e6da65cd8cb0197cbc0138cbb76908')
@@ -56,8 +60,9 @@ package() {
${pkgdir}/usr/share/${pkgname}/${pkgname}.init
# systemd service (based on etc/init.d/aksusbd):
- install -Dm644 ${srcdir}/${pkgname}.service \
- ${pkgdir}/usr/lib/systemd/system/${pkgname}.service
+ install -dm755 ${pkgdir}/usr/lib/systemd/system/
+ install -m644 ${srcdir}/{aksusbd,winehasp,hasplmd}.service \
+ ${pkgdir}/usr/lib/systemd/system/
# LICENSE and readme.html:
install -Dm644 ${srcdir}/${_tarballname}/readme.html \
diff --git a/aksusbd.service b/aksusbd.service
index 4670b6022b53..d9ba3784d403 100644
--- a/aksusbd.service
+++ b/aksusbd.service
@@ -1,16 +1,20 @@
[Unit]
-Description=AKSUSB Daemon
-ConditionPathExists=/etc/init.d/aksusbd
-After=syslog.target
+Description=AKSUSB daemon
+Wants=winehasp.service hasplmd.service
[Service]
Type=forking
StandardOutput=tty
TimeoutStopSec=10s
+PrivateTmp=true
+PrivateNetwork=true
+ProtectSystem=full
+ProtectHome=true
+
ExecStart=/usr/bin/aksusbd
-ExecStart=/usr/bin/winehasp
-ExecStart=/usr/bin/hasplmd -s
[Install]
WantedBy=multi-user.target
+Also=winehasp.service
+Also=hasplmd.service
diff --git a/hasplmd.service b/hasplmd.service
new file mode 100644
index 000000000000..009d88e2c4f2
--- /dev/null
+++ b/hasplmd.service
@@ -0,0 +1,23 @@
+[Unit]
+Description=AKSUSB winehasp daemon
+After=aksusbd.service winehasp.service
+Requires=aksusbd.service winehasp.service
+BindsTo=aksusbd.service winehasp.service
+PartOf=aksusbd.service winehasp.service
+
+[Service]
+Type=forking
+StandardOutput=tty
+TimeoutStopSec=10s
+
+PrivateTmp=true
+PrivateNetwork=true
+ProtectSystem=full
+ProtectHome=true
+
+ExecStart=/usr/bin/hasplmd -s
+
+[Install]
+WantedBy=multi-user.target
+Also=aksusbd.service
+Also=winehasp.service
diff --git a/winehasp.service b/winehasp.service
new file mode 100644
index 000000000000..31b1c27c45cc
--- /dev/null
+++ b/winehasp.service
@@ -0,0 +1,23 @@
+[Unit]
+Description=AKSUSB winehasp daemon
+After=aksusbd.service
+Requires=aksusbd.service
+BindsTo=aksusbd.service
+PartOf=aksusbd.service
+
+[Service]
+Type=forking
+StandardOutput=tty
+TimeoutStopSec=10s
+
+PrivateTmp=true
+PrivateNetwork=true
+ProtectSystem=full
+ProtectHome=true
+
+ExecStart=/usr/bin/winehasp
+
+[Install]
+WantedBy=multi-user.target
+Also=aksusbd.service
+Also=hasplmd.service