summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2020-09-22 19:45:04 -0300
committerGonzalo Exequiel Pedone2020-09-22 19:45:04 -0300
commit5d0f7e0cb2885b303ff2df0d88fcefd52d970370 (patch)
treea7d8032e2d2c30364f2e86884ad5c88e3458ac86
parent64d79fc3986a111a2abdafcaba284d48a5c8d7b1 (diff)
downloadaur-5d0f7e0cb2885b303ff2df0d88fcefd52d970370.tar.gz
Apply suggestions from https://bbs.archlinux.org/viewtopic.php?pid=1927541
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--akvcam-dkms-git.install18
3 files changed, 8 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 227b8e556d41..f835af9bdc11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
pkgbase = akvcam-dkms-git
pkgdesc = Virtual camera for Linux
pkgver = 1.1.0.r0.gce8c98e
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/webcamoid/akvcam
- install = akvcam-dkms-git.install
- arch = x86_64
- arch = i686
- license = GPLv2
+ arch = any
+ license = GPL2
makedepends = git
depends = dkms
provides = akvcam-dkms
conflicts = akvcam-dkms
source = git://github.com/webcamoid/akvcam.git
- source = akvcam-dkms-git.install
md5sums = SKIP
- md5sums = 3e315711dc9e57c9ba963abea81468b1
pkgname = akvcam-dkms-git
diff --git a/PKGBUILD b/PKGBUILD
index d64c710a2bd3..03642dfc340a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,17 @@
_pkgbase=akvcam
pkgname=${_pkgbase}-dkms-git
pkgver=1.1.0.r0.gce8c98e
-pkgrel=2
+pkgrel=3
pkgdesc="Virtual camera for Linux"
url="https://github.com/webcamoid/akvcam"
-arch=('x86_64' 'i686')
-license=('GPLv2')
+arch=('any')
+license=('GPL2')
depends=('dkms')
makedepends=('git')
conflicts=("${_pkgbase}-dkms")
provides=("${_pkgbase}-dkms")
-install="${pkgname}.install"
-source=("git://github.com/webcamoid/akvcam.git"
- "${pkgname}.install")
-md5sums=('SKIP'
- '3e315711dc9e57c9ba963abea81468b1')
+source=("git://github.com/webcamoid/akvcam.git")
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/${_pkgbase}"
@@ -27,11 +24,6 @@ pkgver() {
)
}
-build() {
- cd "${srcdir}/${_pkgbase}/src"
- make
-}
-
package() {
cd "${srcdir}/${_pkgbase}"
mkdir -p "${pkgdir}/usr/src/${_pkgbase}-${pkgver}"
@@ -43,6 +35,4 @@ package() {
cp -vf share/examples/output.c "${pkgdir}/etc/${_pkgbase}/examples"
cd "${srcdir}/${_pkgbase}/src"
cp -ar * "${pkgdir}/usr/src/${_pkgbase}-${pkgver}"
- cd "${pkgdir}/usr/src/${_pkgbase}-${pkgver}"
- make clean
}
diff --git a/akvcam-dkms-git.install b/akvcam-dkms-git.install
deleted file mode 100644
index 42bb6a02f04c..000000000000
--- a/akvcam-dkms-git.install
+++ /dev/null
@@ -1,18 +0,0 @@
-# old version (without -$pkgrel): ${1%%-*}
-# new version (without -$pkgrel): ${2%%-*}
-
-post_install() {
- dkms install akvcam/${1%%-*}
-}
-
-pre_upgrade() {
- pre_remove ${2%%-*}
-}
-
-post_upgrade() {
- post_install ${1%%-*}
-}
-
-pre_remove() {
- dkms remove akvcam/${1%%-*} --all
-}