summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2018-11-09 19:14:39 -0300
committerGonzalo Exequiel Pedone2018-11-09 19:14:39 -0300
commitb163ab0c677e750afb73d46ab36345803ab6ad82 (patch)
treefd0828d57901e3e472ddd566123802bad456ef01
downloadaur-b163ab0c677e750afb73d46ab36345803ab6ad82.tar.gz
First commit.
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD49
-rw-r--r--akvcam-dkms-git.install18
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..420dd28d6784
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# vie nov 9 22:12:55 UTC 2018
+pkgbase = akvcam-dkms-git
+ pkgdesc = Virtual camera for Linux
+ pkgver = r145.03d8432
+ pkgrel = 1
+ url = https://github.com/webcamoid/akvcam
+ install = akvcam-dkms-git.install
+ arch = x86_64
+ arch = i686
+ license = GPLv2
+ makedepends = git
+ makedepends = linux-headers
+ depends = dkms
+ provides = akvcam-dkms
+ conflicts = akvcam-dkms
+ source = git://github.com/webcamoid/akvcam.git
+ source = akvcam-dkms-git.install
+ md5sums = SKIP
+ md5sums = 3e315711dc9e57c9ba963abea81468b1
+
+pkgname = akvcam-dkms-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6f44b44da857
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+akvcam-*.tar.xz
+akvcam
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f68acb953f55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+
+_pkgbase=akvcam
+pkgname=${_pkgbase}-dkms-git
+pkgver=r145.03d8432
+pkgrel=1
+pkgdesc="Virtual camera for Linux"
+url="https://github.com/webcamoid/akvcam"
+arch=('x86_64' 'i686')
+license=('GPLv2')
+depends=('dkms')
+makedepends=('git' 'linux-headers')
+conflicts=("${_pkgbase}-dkms")
+provides=("${_pkgbase}-dkms")
+install="${pkgname}.install"
+source=("git://github.com/webcamoid/akvcam.git"
+ "${pkgname}.install")
+md5sums=('SKIP'
+ '3e315711dc9e57c9ba963abea81468b1')
+
+pkgver() {
+ cd "$srcdir/${_pkgbase}"
+ (
+ set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${srcdir}/${_pkgbase}/src"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgbase}"
+ mkdir -p "${pkgdir}/usr/src/${_pkgbase}-${pkgver}"
+ cp -vf COPYING "${pkgdir}/usr/src/${_pkgbase}-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/licenses/akvcam"
+ cp -vf COPYING "${pkgdir}/usr/share/licenses/akvcam"
+ mkdir -p "${pkgdir}/etc/akvcam"
+ cp -vf share/config_example.ini "${pkgdir}/etc/akvcam"
+ cd "${srcdir}/${_pkgbase}/src"
+ strip --strip-debug akvcam.ko
+ make DESTDIR="${pkgdir}/usr" install
+ cp -ar * "${pkgdir}/usr/src/${_pkgbase}-${pkgver}"
+ cd "${pkgdir}/usr/src/${_pkgbase}-${pkgver}"
+ make clean
+}
diff --git a/akvcam-dkms-git.install b/akvcam-dkms-git.install
new file mode 100644
index 000000000000..42bb6a02f04c
--- /dev/null
+++ b/akvcam-dkms-git.install
@@ -0,0 +1,18 @@
+# old version (without -$pkgrel): ${1%%-*}
+# new version (without -$pkgrel): ${2%%-*}
+
+post_install() {
+ dkms install akvcam/${1%%-*}
+}
+
+pre_upgrade() {
+ pre_remove ${2%%-*}
+}
+
+post_upgrade() {
+ post_install ${1%%-*}
+}
+
+pre_remove() {
+ dkms remove akvcam/${1%%-*} --all
+}