summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2016-01-25 22:14:54 -0500
committerJames An2016-01-25 22:14:54 -0500
commit0867a7ae50d373030cf577fa0d611acbc3d3a499 (patch)
tree833d2238804c05244e923ece0c2db2a26444175d
parentd0e72bdc02e11efa3bfbcae7b891dc7cf5f55650 (diff)
downloadaur-0867a7ae50d373030cf577fa0d611acbc3d3a499.tar.gz
Updated to latest upstream version, aligned PKGBUILD to current packaging guidelines, and re-rolled patch against latest upstream source code.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD47
-rw-r--r--unicode-fixes.patch (renamed from toprettyxml-and-unicode-fixes.patch)27
3 files changed, 46 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 095db49cee58..b7047ebffa27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,32 @@
+# Generated by mksrcinfo v8
+# Tue Jan 26 03:14:00 UTC 2016
pkgbase = alacarte-xfce
pkgdesc = Menu editor for Xfce
- pkgver = 3.10.0
- pkgrel = 2
+ pkgver = 3.11.91
+ pkgrel = 1
url = http://www.gnome.org
install = alacarte.install
arch = any
groups = xfce4-goodies
license = LGPL
makedepends = intltool
+ makedepends = libxslt
+ makedepends = docbook-xsl
depends = gnome-menus
+ depends = hicolor-icon-theme
depends = python2-gobject
+ depends = gtk3
depends = exo
- depends = hicolor-icon-theme
- depends = pygtk
- provides = alacarte=3.10.0
+ provides = alacarte=3.11.91
conflicts = alacarte
conflicts = alacarte-git
conflicts = alacarte-xfce-devel
options = !libtool
- source = http://ftp.gnome.org/pub/gnome/sources/alacarte/3.10/alacarte-3.10.0.tar.xz
- source = toprettyxml-and-unicode-fixes.patch
+ source = http://ftp.gnome.org/pub/gnome/sources/alacarte/3.11/alacarte-3.11.91.tar.xz
+ source = unicode-fixes.patch
source = alacarte.desktop
- md5sums = 817b0ebd9bf234d184088c6290f05acd
- md5sums = 8b427043af9d258da0daaa50fad9337d
+ md5sums = 03209a293a904cd3c47336ba0f3e8fc2
+ md5sums = c9b2d6bca7e6cfa92f5c8bf09f179926
md5sums = b927a3927560037c87dab73ef2d3d38b
pkgname = alacarte-xfce
diff --git a/PKGBUILD b/PKGBUILD
index da2283b726d1..09bd908f58df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,53 @@
-# Maintainer: Bartek Piotrowski <barthalion@gmail.com>
+# Maintainer: James An <james@jamesan.ca>
+# Contributor: Bartek Piotrowski <barthalion@gmail.com>
# Contributor: 3ED <krzysztof1987 at googlemail>
# Contributor: Jan de Groot <jgc@archlinux.org>
# Contributor: pressh <pressh@gmail.com>
pkgname=alacarte-xfce
-_realname=${pkgname/-xfce/}
-majorpkgver=3.10
-pkgver=$majorpkgver.0
-pkgrel=2
+_pkgname=${pkgname%-xfce}
+pkgver=3.11.91
+pkgrel=1
pkgdesc="Menu editor for Xfce"
-provides=("alacarte=${pkgver}")
+provides=("$_pkgname=$pkgver")
arch=(any)
license=('LGPL')
url="http://www.gnome.org"
-depends=('gnome-menus' 'python2-gobject' 'exo' 'hicolor-icon-theme' 'pygtk')
-makedepends=('intltool')
+depends=('gnome-menus' 'hicolor-icon-theme' 'python2-gobject' 'gtk3' 'exo')
+makedepends=('intltool' 'libxslt' 'docbook-xsl')
conflicts=('alacarte' 'alacarte-git' 'alacarte-xfce-devel')
install=alacarte.install
options=('!libtool')
groups=('xfce4-goodies')
-source=(http://ftp.gnome.org/pub/gnome/sources/alacarte/$majorpkgver/alacarte-${pkgver}.tar.xz toprettyxml-and-unicode-fixes.patch alacarte.desktop)
-md5sums=('817b0ebd9bf234d184088c6290f05acd'
- '8b427043af9d258da0daaa50fad9337d'
+source=("http://ftp.gnome.org/pub/gnome/sources/$_pkgname/${pkgver:0:4}/$_pkgname-$pkgver.tar.xz"
+ unicode-fixes.patch
+ $_pkgname.desktop)
+md5sums=('03209a293a904cd3c47336ba0f3e8fc2'
+ 'c9b2d6bca7e6cfa92f5c8bf09f179926'
'b927a3927560037c87dab73ef2d3d38b')
-build() {
- cd "${srcdir}/${_realname}-${pkgver}"
- patch -p1 -i $srcdir/toprettyxml-and-unicode-fixes.patch
+prepare() {
+ cd "$_pkgname-$pkgver"
+
+ patch -p1 -i ../unicode-fixes.patch
sed -e 's/gnome-desktop-item-edit/exo-desktop-item-edit/g' -i Alacarte/MainWindow.py
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+}
+
+build() {
+ cd "$_pkgname-$pkgver"
+
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var PYTHON=/usr/bin/python2
make
}
check() {
- cd "${srcdir}/${_realname}-${pkgver}"
+ cd "$_pkgname-$pkgver"
+
make check
}
package() {
- cd "${srcdir}/${_realname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
- install -D "${srcdir}/alacarte.desktop" "${pkgdir}/usr/share/applications/alacarte.desktop"
+ cd "$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ python2 -m compileall "$pkgdir"/usr/lib/python2.7/site-packages/Alacarte/
}
diff --git a/toprettyxml-and-unicode-fixes.patch b/unicode-fixes.patch
index f18406444730..5ba23d386e8a 100644
--- a/toprettyxml-and-unicode-fixes.patch
+++ b/unicode-fixes.patch
@@ -1,28 +1,11 @@
diff -aur alacarte-3.7.90/Alacarte/MenuEditor.py alacarte-3.7.90.new/Alacarte/MenuEditor.py
---- alacarte-3.7.90/Alacarte/MenuEditor.py 2013-02-16 03:23:57.000000000 +0200
-+++ alacarte-3.7.90.new/Alacarte/MenuEditor.py 2013-04-24 22:48:57.876017889 +0300
-@@ -21,6 +21,7 @@
- import xml.dom.minidom
- import xml.parsers.expat
- from gi.repository import GMenu, GLib
-+from xml.dom.ext import PrettyPrint
- from Alacarte import util
-
- def get_default_menu():
-@@ -54,7 +55,7 @@
-
- def save(self):
- with codecs.open(self.path, 'w', 'utf8') as f:
-- f.write(self.dom.toprettyxml())
-+ PrettyPrint(self.dom, stream=f)
-
- def restoreToSystem(self):
- self.restoreTree(self.tree.get_root_directory())
+--- alacarte-3.7.90/Alacarte/MenuEditor.py 2013-02-16 03:23:57.000000000 +0200
++++ alacarte-3.7.90.new/Alacarte/MenuEditor.py 2013-04-24 22:48:57.876017889 +0300
@@ -262,6 +263,7 @@
out_path = os.path.join(util.getUserItemPath(), file_id)
contents, length = keyfile.to_data()
-+ contents = unicode(contents, 'utf8')
++ contents = unicode(contents, 'utf8')
with codecs.open(out_path, 'w', 'utf8') as f:
f.write(contents)
@@ -30,7 +13,7 @@ diff -aur alacarte-3.7.90/Alacarte/MenuEditor.py alacarte-3.7.90.new/Alacarte/Me
file_id = util.getUniqueFileId(keyfile.get_string(GLib.KEY_FILE_DESKTOP_GROUP, 'Name'), '.desktop')
contents, length = keyfile.to_data()
-+ contents = unicode(contents, 'utf8')
++ contents = unicode(contents, 'utf8')
path = os.path.join(util.getUserItemPath(), file_id)
with codecs.open(path, 'w', 'utf8') as f:
@@ -38,7 +21,7 @@ diff -aur alacarte-3.7.90/Alacarte/MenuEditor.py alacarte-3.7.90.new/Alacarte/Me
util.fillKeyFile(keyfile, kwargs)
contents, length = keyfile.to_data()
-+ contents = unicode(contents, 'utf8')
++ contents = unicode(contents, 'utf8')
path = os.path.join(util.getUserDirectoryPath(), file_id)
with codecs.open(path, 'w', 'utf8') as f: