summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2018-03-16 18:34:54 -0400
committerJames An2018-03-16 18:35:29 -0400
commitd0c346dc5e921a8662ab77541329b926fdca599c (patch)
tree6dfa2c41877126845afd53d51de5c74748a8ef22
parent0867a7ae50d373030cf577fa0d611acbc3d3a499 (diff)
downloadaur-d0c346dc5e921a8662ab77541329b926fdca599c.tar.gz
Updated to the latest upstream commit.
Fixed dependencies to match upstream requirements. Re-rolled unicode patch and removed obsolete PrettyPrint patch. Restored upstream desktop entry file. Removed superfluous mention of exo. Restored packaging command to byte-compile all code files.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD51
-rw-r--r--alacarte.desktop8
-rw-r--r--unicode.patch (renamed from unicode-fixes.patch)19
4 files changed, 44 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7047ebffa27..aa2b91bc0c21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Jan 26 03:14:00 UTC 2016
pkgbase = alacarte-xfce
pkgdesc = Menu editor for Xfce
- pkgver = 3.11.91
+ pkgver = 3.11.91.r18.g40c8c60
pkgrel = 1
url = http://www.gnome.org
install = alacarte.install
@@ -12,22 +10,20 @@ pkgbase = alacarte-xfce
makedepends = intltool
makedepends = libxslt
makedepends = docbook-xsl
+ makedepends = git
+ makedepends = gnome-common
depends = gnome-menus
depends = hicolor-icon-theme
depends = python2-gobject
depends = gtk3
- depends = exo
- provides = alacarte=3.11.91
+ provides = alacarte=3.11.91.r18.g40c8c60
conflicts = alacarte
conflicts = alacarte-git
conflicts = alacarte-xfce-devel
- options = !libtool
- source = http://ftp.gnome.org/pub/gnome/sources/alacarte/3.11/alacarte-3.11.91.tar.xz
- source = unicode-fixes.patch
- source = alacarte.desktop
- md5sums = 03209a293a904cd3c47336ba0f3e8fc2
- md5sums = c9b2d6bca7e6cfa92f5c8bf09f179926
- md5sums = b927a3927560037c87dab73ef2d3d38b
+ source = alacarte::git+https://git.gnome.org/browse/alacarte
+ source = unicode.patch
+ md5sums = SKIP
+ md5sums = 716728870e130fce53c412be5bb93d72
pkgname = alacarte-xfce
diff --git a/PKGBUILD b/PKGBUILD
index 09bd908f58df..1c95255b042e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,48 +6,49 @@
pkgname=alacarte-xfce
_pkgname=${pkgname%-xfce}
-pkgver=3.11.91
+pkgver=3.11.91.r18.g40c8c60
pkgrel=1
pkgdesc="Menu editor for Xfce"
-provides=("$_pkgname=$pkgver")
-arch=(any)
+arch=('any')
license=('LGPL')
url="http://www.gnome.org"
-depends=('gnome-menus' 'hicolor-icon-theme' 'python2-gobject' 'gtk3' 'exo')
-makedepends=('intltool' 'libxslt' 'docbook-xsl')
-conflicts=('alacarte' 'alacarte-git' 'alacarte-xfce-devel')
-install=alacarte.install
-options=('!libtool')
groups=('xfce4-goodies')
-source=("http://ftp.gnome.org/pub/gnome/sources/$_pkgname/${pkgver:0:4}/$_pkgname-$pkgver.tar.xz"
- unicode-fixes.patch
- $_pkgname.desktop)
-md5sums=('03209a293a904cd3c47336ba0f3e8fc2'
- 'c9b2d6bca7e6cfa92f5c8bf09f179926'
- 'b927a3927560037c87dab73ef2d3d38b')
+depends=('gnome-menus' 'hicolor-icon-theme' 'python2-gobject' 'gtk3')
+makedepends=('intltool' 'libxslt' 'docbook-xsl' 'git' 'gnome-common')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname" "$_pkgname-git" "$_pkgname-xfce-devel")
+install="$_pkgname.install"
+source=("$_pkgname"::"git+https://git.gnome.org/browse/$_pkgname"
+ 'unicode.patch')
+md5sums=('SKIP'
+ '716728870e130fce53c412be5bb93d72')
+
+pkgver() {
+ cd "$_pkgname"
+ (
+ set -o pipefail
+ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
prepare() {
- cd "$_pkgname-$pkgver"
+ cd $_pkgname
- patch -p1 -i ../unicode-fixes.patch
- sed -e 's/gnome-desktop-item-edit/exo-desktop-item-edit/g' -i Alacarte/MainWindow.py
+ patch -p1 < ../unicode.patch
}
build() {
- cd "$_pkgname-$pkgver"
+ cd $_pkgname
+ NOCONFIGURE=1 ./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var PYTHON=/usr/bin/python2
make
}
-check() {
- cd "$_pkgname-$pkgver"
-
- make check
-}
-
package() {
- cd "$_pkgname-$pkgver"
+ cd $_pkgname
+
make DESTDIR="$pkgdir" install
python2 -m compileall "$pkgdir"/usr/lib/python2.7/site-packages/Alacarte/
}
diff --git a/alacarte.desktop b/alacarte.desktop
deleted file mode 100644
index 626433ee323d..000000000000
--- a/alacarte.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Comment=Alacarte Menu Editor
-Terminal=false
-Name=Alacarte
-Exec=/usr/bin/alacarte
-Type=Application
-Categories=Settings;
-Icon=alacarte
diff --git a/unicode-fixes.patch b/unicode.patch
index 5ba23d386e8a..2fe860f38649 100644
--- a/unicode-fixes.patch
+++ b/unicode.patch
@@ -1,27 +1,28 @@
-diff -aur alacarte-3.7.90/Alacarte/MenuEditor.py alacarte-3.7.90.new/Alacarte/MenuEditor.py
---- alacarte-3.7.90/Alacarte/MenuEditor.py 2013-02-16 03:23:57.000000000 +0200
-+++ alacarte-3.7.90.new/Alacarte/MenuEditor.py 2013-04-24 22:48:57.876017889 +0300
-@@ -262,6 +263,7 @@
+diff --git a/Alacarte/MenuEditor.py b/Alacarte/MenuEditor.py
+index b07690c..72ba22d 100644
+--- a/Alacarte/MenuEditor.py
++++ b/Alacarte/MenuEditor.py
+@@ -260,6 +260,7 @@ class MenuEditor(object):
out_path = os.path.join(util.getUserItemPath(), file_id)
contents, length = keyfile.to_data()
+ contents = unicode(contents, 'utf8')
- with codecs.open(out_path, 'w', 'utf8') as f:
+ with open(out_path, 'w') as f:
f.write(contents)
-@@ -402,6 +404,7 @@
+@@ -400,6 +401,7 @@ class MenuEditor(object):
file_id = util.getUniqueFileId(keyfile.get_string(GLib.KEY_FILE_DESKTOP_GROUP, 'Name'), '.desktop')
contents, length = keyfile.to_data()
+ contents = unicode(contents, 'utf8')
path = os.path.join(util.getUserItemPath(), file_id)
- with codecs.open(path, 'w', 'utf8') as f:
-@@ -424,6 +427,7 @@
+ with open(path, 'w') as f:
+@@ -422,6 +424,7 @@ class MenuEditor(object):
util.fillKeyFile(keyfile, kwargs)
contents, length = keyfile.to_data()
+ contents = unicode(contents, 'utf8')
path = os.path.join(util.getUserDirectoryPath(), file_id)
- with codecs.open(path, 'w', 'utf8') as f:
+ with open(path, 'w') as f: