summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-01-24 07:54:35 -0500
committerJames An2015-01-24 07:54:35 -0500
commitfe96410535fac629cd223ba5aa1f279a6c155a66 (patch)
treeabfdfa764c4c10bbd216bae2c17ab5d32a976760
downloadaur-fe96410535fac629cd223ba5aa1f279a6c155a66.tar.gz
Added alacarte-xfce from the AUR.
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD44
-rw-r--r--alacarte.desktop8
-rw-r--r--alacarte.install11
-rw-r--r--toprettyxml-and-unicode-fixes.patch44
5 files changed, 136 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..095db49cee58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = alacarte-xfce
+ pkgdesc = Menu editor for Xfce
+ pkgver = 3.10.0
+ pkgrel = 2
+ url = http://www.gnome.org
+ install = alacarte.install
+ arch = any
+ groups = xfce4-goodies
+ license = LGPL
+ makedepends = intltool
+ depends = gnome-menus
+ depends = python2-gobject
+ depends = exo
+ depends = hicolor-icon-theme
+ depends = pygtk
+ provides = alacarte=3.10.0
+ conflicts = alacarte
+ conflicts = alacarte-git
+ conflicts = alacarte-xfce-devel
+ options = !libtool
+ source = http://ftp.gnome.org/pub/gnome/sources/alacarte/3.10/alacarte-3.10.0.tar.xz
+ source = toprettyxml-and-unicode-fixes.patch
+ source = alacarte.desktop
+ md5sums = 817b0ebd9bf234d184088c6290f05acd
+ md5sums = 8b427043af9d258da0daaa50fad9337d
+ md5sums = b927a3927560037c87dab73ef2d3d38b
+
+pkgname = alacarte-xfce
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da2283b726d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Bartek Piotrowski <barthalion@gmail.com>
+# Contributor: 3ED <krzysztof1987 at googlemail>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: pressh <pressh@gmail.com>
+
+pkgname=alacarte-xfce
+_realname=${pkgname/-xfce/}
+majorpkgver=3.10
+pkgver=$majorpkgver.0
+pkgrel=2
+pkgdesc="Menu editor for Xfce"
+provides=("alacarte=${pkgver}")
+arch=(any)
+license=('LGPL')
+url="http://www.gnome.org"
+depends=('gnome-menus' 'python2-gobject' 'exo' 'hicolor-icon-theme' 'pygtk')
+makedepends=('intltool')
+conflicts=('alacarte' 'alacarte-git' 'alacarte-xfce-devel')
+install=alacarte.install
+options=('!libtool')
+groups=('xfce4-goodies')
+source=(http://ftp.gnome.org/pub/gnome/sources/alacarte/$majorpkgver/alacarte-${pkgver}.tar.xz toprettyxml-and-unicode-fixes.patch alacarte.desktop)
+md5sums=('817b0ebd9bf234d184088c6290f05acd'
+ '8b427043af9d258da0daaa50fad9337d'
+ 'b927a3927560037c87dab73ef2d3d38b')
+
+build() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ patch -p1 -i $srcdir/toprettyxml-and-unicode-fixes.patch
+ sed -e 's/gnome-desktop-item-edit/exo-desktop-item-edit/g' -i Alacarte/MainWindow.py
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ make
+}
+
+check() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ make check
+}
+
+package() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -D "${srcdir}/alacarte.desktop" "${pkgdir}/usr/share/applications/alacarte.desktop"
+}
diff --git a/alacarte.desktop b/alacarte.desktop
new file mode 100644
index 000000000000..626433ee323d
--- /dev/null
+++ b/alacarte.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Comment=Alacarte Menu Editor
+Terminal=false
+Name=Alacarte
+Exec=/usr/bin/alacarte
+Type=Application
+Categories=Settings;
+Icon=alacarte
diff --git a/alacarte.install b/alacarte.install
new file mode 100644
index 000000000000..cdf5fd48105e
--- /dev/null
+++ b/alacarte.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/toprettyxml-and-unicode-fixes.patch b/toprettyxml-and-unicode-fixes.patch
new file mode 100644
index 000000000000..f18406444730
--- /dev/null
+++ b/toprettyxml-and-unicode-fixes.patch
@@ -0,0 +1,44 @@
+diff -aur alacarte-3.7.90/Alacarte/MenuEditor.py alacarte-3.7.90.new/Alacarte/MenuEditor.py
+--- alacarte-3.7.90/Alacarte/MenuEditor.py 2013-02-16 03:23:57.000000000 +0200
++++ alacarte-3.7.90.new/Alacarte/MenuEditor.py 2013-04-24 22:48:57.876017889 +0300
+@@ -21,6 +21,7 @@
+ import xml.dom.minidom
+ import xml.parsers.expat
+ from gi.repository import GMenu, GLib
++from xml.dom.ext import PrettyPrint
+ from Alacarte import util
+
+ def get_default_menu():
+@@ -54,7 +55,7 @@
+
+ def save(self):
+ with codecs.open(self.path, 'w', 'utf8') as f:
+- f.write(self.dom.toprettyxml())
++ PrettyPrint(self.dom, stream=f)
+
+ def restoreToSystem(self):
+ self.restoreTree(self.tree.get_root_directory())
+@@ -262,6 +263,7 @@
+ out_path = os.path.join(util.getUserItemPath(), file_id)
+
+ contents, length = keyfile.to_data()
++ contents = unicode(contents, 'utf8')
+
+ with codecs.open(out_path, 'w', 'utf8') as f:
+ f.write(contents)
+@@ -402,6 +404,7 @@
+ file_id = util.getUniqueFileId(keyfile.get_string(GLib.KEY_FILE_DESKTOP_GROUP, 'Name'), '.desktop')
+
+ contents, length = keyfile.to_data()
++ contents = unicode(contents, 'utf8')
+
+ path = os.path.join(util.getUserItemPath(), file_id)
+ with codecs.open(path, 'w', 'utf8') as f:
+@@ -424,6 +427,7 @@
+ util.fillKeyFile(keyfile, kwargs)
+
+ contents, length = keyfile.to_data()
++ contents = unicode(contents, 'utf8')
+
+ path = os.path.join(util.getUserDirectoryPath(), file_id)
+ with codecs.open(path, 'w', 'utf8') as f: