summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-12-23 14:26:39 +0100
committerFabioLolix2023-12-23 14:26:39 +0100
commitaadae22ba4f09d32575c517d00331780cf8f0cb9 (patch)
treef477ae29d277c77f0617551d8c4a5cb1b51232a8
parent575466bd16b26b93fad5f66caf3683e922f9f072 (diff)
downloadaur-aadae22ba4f09d32575c517d00331780cf8f0cb9.tar.gz
v0.4.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ede4347f5b25..1470c84b14be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = alacenc
pkgdesc = Encode audio into the Apple Lossless Audio Codec (ALAC) format
- pkgver = 0.3.0
- pkgrel = 2
+ pkgver = 0.4.0
+ pkgrel = 1
url = https://github.com/flacon/alacenc
arch = x86_64
license = MIT
makedepends = git
makedepends = cmake
+ depends = glibc
depends = gcc-libs
- source = git+https://github.com/flacon/alacenc.git#tag=v0.3.0
- source = alacenc-gcc13-fix.patch::https://github.com/flacon/alacenc/pull/3/commits/84b6e5c7aee44a052bddffca9e7d486eb97c50f7.patch
+ source = git+https://github.com/flacon/alacenc.git#tag=v0.4.0
sha256sums = SKIP
- sha256sums = a959af32736882778d4017b378a1267163a0d0c86729196c99bdaa67cacfc215
pkgname = alacenc
diff --git a/PKGBUILD b/PKGBUILD
index 2efa4c5f7f4a..7e1d7025c9f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,19 @@
# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=alacenc
-pkgver=0.3.0
-pkgrel=2
+pkgver=0.4.0
+pkgrel=1
pkgdesc="Encode audio into the Apple Lossless Audio Codec (ALAC) format"
arch=(x86_64)
url="https://github.com/flacon/alacenc"
license=(MIT)
-depends=(gcc-libs)
+depends=(glibc gcc-libs)
makedepends=(git cmake)
-source=("git+https://github.com/flacon/alacenc.git#tag=v${pkgver}"
- "alacenc-gcc13-fix.patch::https://github.com/flacon/alacenc/pull/3/commits/84b6e5c7aee44a052bddffca9e7d486eb97c50f7.patch")
-sha256sums=('SKIP'
- 'a959af32736882778d4017b378a1267163a0d0c86729196c99bdaa67cacfc215')
-
-prepare() {
- cd alacenc
- patch -Np1 -i ../alacenc-gcc13-fix.patch
-}
+source=("git+https://github.com/flacon/alacenc.git#tag=v${pkgver}")
+sha256sums=('SKIP')
build() {
- cmake -S alacenc -B build \
+ cmake -S alacenc -B build -Wno-dev \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr