summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquininer kel2016-11-01 21:53:14 +0800
committerquininer kel2016-11-01 21:53:14 +0800
commit193f971e69df25eb53b55025223686860783dcb2 (patch)
tree7f9bec6f2970de7a357aa7d2b19c19d411f01f60
downloadaur-193f971e69df25eb53b55025223686860783dcb2.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5a368b9c3ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Nov 1 13:52:49 UTC 2016
+pkgbase = alacritty-git
+ pkgdesc = WORK IN PROGRESS - a terminal
+ pkgver = 0.1.0.180
+ pkgrel = 1
+ url = https://github.com/jwilm/alacritty
+ arch = x86_64
+ arch = i686
+ license = Apache-2.0
+ makedepends = cargo
+ provides = alacritty
+ conflicts = alacritty
+ source = alacritty-git::git+https://github.com/jwilm/alacritty.git
+ sha256sums = SKIP
+
+pkgname = alacritty-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4df1c357998
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=alacritty-git
+pkgver=0.1.0.180
+pkgrel=1
+pkgdesc="WORK IN PROGRESS - a terminal"
+arch=('x86_64' 'i686')
+url="https://github.com/jwilm/alacritty"
+license=('Apache-2.0')
+depends=()
+makedepends=('cargo')
+optdepends=()
+provides=('alacritty')
+conflicts=('alacritty')
+source=($pkgname::git+https://github.com/jwilm/alacritty.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD)
+}
+
+build() {
+ cd $pkgname
+ cargo build --release
+}
+
+package() {
+ cd $pkgname
+ install -D -m755 "$srcdir/$pkgname/target/release/alacritty" "$pkgdir/usr/bin/alacritty"
+}