summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoorat2021-09-22 12:09:06 +0600
committerzoorat2021-09-22 12:09:06 +0600
commitb0e780e29d38fef6bdebbe4769a2ed165a74938d (patch)
treef78b3cc74b869172a7945b4ad45f1b7680ac65b9
parent079e3470fe3682689288110a6bfc5f2613e4ddfa (diff)
downloadaur-b0e780e29d38fef6bdebbe4769a2ed165a74938d.tar.gz
updating to v4.1.2
Signed-off-by: zoorat <78788887+z00rat@users.noreply.github.com>
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD12
-rw-r--r--fixing_v4.1.2.patch11
4 files changed, 28 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bd3984d6148..d6c89158644c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = alacritty-themes
pkgdesc = A cross-platform GPU-accelerated Terminal emulator.
- pkgver = 4.1.1
- pkgrel = 2
+ pkgver = 4.1.2
+ pkgrel = 1
url = https://github.com/rajasegar/alacritty-themes
install = alacritty-themes.install
arch = any
@@ -11,8 +11,10 @@ pkgbase = alacritty-themes
depends = nodejs
conflicts = alacritty-themes
replaces = alacritty-themes
- noextract = alacritty-themes-4.1.1.tgz
- source = https://registry.npmjs.org/alacritty-themes/-/alacritty-themes-4.1.1.tgz
- b2sums = 2dd1247ab59f5af74436b8643dedf5b679b063a869d6c70e1925f76aa856c907d77452f179ff5c810e6c8b46bc911da0833a8e63c8849d98a25681cc1f64bcc7
+ noextract = alacritty-themes-4.1.2.tgz
+ source = https://registry.npmjs.org/alacritty-themes/-/alacritty-themes-4.1.2.tgz
+ source = fixing_v4.1.2.patch
+ b2sums = aac71402d02519b7921c8172f0218ee161bd1b3fb6343e497eed22407abf34623b0781bbbdadd687eae2e3861bfaab4c9ff6f09790145966e8349ddd643723d5
+ b2sums = SKIP
pkgname = alacritty-themes
diff --git a/.gitignore b/.gitignore
index b12b11914478..71c67a0cf004 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,5 @@
!PKGBUILD
!.SCRINFO
!alacritty-themes.install
+
+!fixing_v4.1.2.patch
diff --git a/PKGBUILD b/PKGBUILD
index 71150be2e80d..19a638a35c77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Ben Silverman <bensilverman10 at gmail dot com>
pkgname=alacritty-themes
-pkgver=4.1.1
-pkgrel=2
+pkgver=4.1.2
+pkgrel=1
pkgdesc="A cross-platform GPU-accelerated Terminal emulator."
arch=(any)
@@ -16,9 +16,11 @@ conflicts=("$pkgname")
replaces=("$pkgname")
install="$pkgname.install"
-source=("https://registry.npmjs.org/${pkgname}/-/${pkgname}-${pkgver}.tgz")
+source=("https://registry.npmjs.org/${pkgname}/-/${pkgname}-${pkgver}.tgz"
+ "fixing_v4.1.2.patch")
noextract=("${pkgname}-${pkgver}.tgz")
-b2sums=('2dd1247ab59f5af74436b8643dedf5b679b063a869d6c70e1925f76aa856c907d77452f179ff5c810e6c8b46bc911da0833a8e63c8849d98a25681cc1f64bcc7')
+b2sums=('aac71402d02519b7921c8172f0218ee161bd1b3fb6343e497eed22407abf34623b0781bbbdadd687eae2e3861bfaab4c9ff6f09790145966e8349ddd643723d5'
+ 'SKIP')
# Document: https://wiki.archlinux.org/title/Node.js_package_guidelines
package() {
@@ -39,4 +41,6 @@ package() {
mv "$tmppackage" "$pkgjson"
chmod 644 "$pkgjson"
done
+
+ patch $pkgdir/usr/lib/node_modules/alacritty-themes/src/helpers/index.js -i fixing_v4.1.2.patch
}
diff --git a/fixing_v4.1.2.patch b/fixing_v4.1.2.patch
new file mode 100644
index 000000000000..f772d9eed585
--- /dev/null
+++ b/fixing_v4.1.2.patch
@@ -0,0 +1,11 @@
+--- index.original.js 2021-09-22 11:53:04.435471903 +0600
++++ pkg/alacritty-themes/usr/lib/node_modules/alacritty-themes/src/helpers/index.js 2021-09-22 11:53:33.317118492 +0600
+@@ -7,7 +7,7 @@
+ );
+
+ function rootDirectory() {
+- return process.env.PWD;
++ return "/usr/lib/node_modules/alacritty-themes";
+ }
+
+ function themeFilePath(themeName) {