summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMogeko2021-08-18 04:57:55 +0200
committerMogeko2021-08-18 04:57:55 +0200
commitbc3a9f2057c20972748729b5c87d3d1a5b484a33 (patch)
tree860e4a71887547899f02e45ea8f2d11b0a5dc37d
downloadaur-bc3a9f2057c20972748729b5c87d3d1a5b484a33.tar.gz
feat: add alass
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD25
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dab2cb3336a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = alass
+ pkgdesc = Automatic Language-Agnostic Subtitle Synchronization
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/kaegi/alass
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ depends = ffmpeg
+ provides = alass
+ source = https://github.com/kaegi/alass/archive/refs/tags/v2.0.0.tar.gz
+ sha256sums = ce88f92c7a427b623edcabb1b64e80be70cca2777f3da4b96702820a6cdf1e26
+
+pkgname = alass
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0f4c8aaf19bc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d18a5101b724
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mogeko <zhengjunyi@live.com>
+
+pkgname=alass
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Automatic Language-Agnostic Subtitle Synchronization"
+arch=('x86_64')
+url='https://github.com/kaegi/alass'
+license=('GPL3')
+depends=('ffmpeg')
+makedepends=('cargo')
+provides=("$pkgname")
+source=("$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('ce88f92c7a427b623edcabb1b64e80be70cca2777f3da4b96702820a6cdf1e26')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 target/release/alass-cli "${pkgdir}/usr/bin/alass"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}