summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvgeniy Alekseev2021-03-09 00:29:11 +0300
committerEvgeniy Alekseev2021-03-09 00:29:11 +0300
commit69bc39f02881028791cc775eab10d3af329f3f73 (patch)
treec485302f348157ee0cce3e876a401f4fee379d26
parentee8fb309dd0318934d12ad612cfaf9172d5492ce (diff)
downloadaur-69bc39f02881028791cc775eab10d3af329f3f73.tar.gz
restore albert from [community] package
also fix some devtools warnings
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD117
2 files changed, 46 insertions, 92 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d47efc8ac44..fa8d222f8190 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,15 @@
-# Generated by mksrcinfo v8
-# Mon Dec 31 20:26:45 UTC 2018
pkgbase = albert
- pkgdesc = A sophisticated standalone keyboard launcher.
- pkgver = 0.16.1
+ pkgdesc = A sophisticated standalone keyboard launcher
+ pkgver = 0.17.2
pkgrel = 1
url = https://github.com/albertlauncher
- arch = i686
arch = x86_64
- arch = armv7h
license = GPL
makedepends = cmake
- makedepends = gcc
makedepends = git
makedepends = muparser
makedepends = python
makedepends = qt5-declarative
- makedepends = qt5-svg
makedepends = virtualbox
makedepends = virtualbox-sdk
depends = qt5-charts
@@ -23,18 +17,17 @@ pkgbase = albert
depends = qt5-quickcontrols
depends = qt5-svg
depends = qt5-x11extras
- depends = libx11
optdepends = muparser: Calculator plugin
optdepends = python: Python extension
optdepends = virtualbox: VirtualBox plugin
- source = mirrors/albert::git+https://github.com/albertlauncher/albert.git#tag=v0.16.1
+ source = mirrors/albert::git+https://github.com/albertlauncher/albert.git#tag=v0.17.2
source = mirrors/plugins::git+https://github.com/albertlauncher/plugins.git
source = mirrors/python::git+https://github.com/albertlauncher/python.git
source = mirrors/pybind11::git+https://github.com/pybind/pybind11.git
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
pkgname = albert
diff --git a/PKGBUILD b/PKGBUILD
index 9c3876759d45..85cb273ee094 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,30 @@
-# Maintainer: Manuel Schneider <manuelschneid3r at googles mail>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Manuel Schneider <manuelschneid3r at googles mail>
+
pkgname=albert
-pkgver=0.16.1
+pkgver=0.17.2
pkgrel=1
-pkgdesc="A sophisticated standalone keyboard launcher."
-arch=('i686' 'x86_64' 'armv7h')
+pkgdesc="A sophisticated standalone keyboard launcher"
+arch=('x86_64')
url="https://github.com/albertlauncher"
license=('GPL')
-depends=(
- 'qt5-charts'
- 'qt5-graphicaleffects'
- 'qt5-quickcontrols'
- 'qt5-svg'
- 'qt5-x11extras'
- 'libx11'
-)
-makedepends=(
- 'cmake'
- 'gcc'
- 'git'
- 'muparser'
- 'python'
- 'qt5-declarative'
- 'qt5-svg'
- 'virtualbox'
- 'virtualbox-sdk'
-)
-optdepends=(
- 'muparser: Calculator plugin'
- 'python: Python extension'
- 'virtualbox: VirtualBox plugin'
-)
-#source=("mirrors/albert::git+https://github.com/albertlauncher/albert.git#branch=dev"
+depends=('qt5-charts' 'qt5-graphicaleffects' 'qt5-quickcontrols' 'qt5-svg' 'qt5-x11extras')
+makedepends=('cmake' 'git' 'muparser' 'python' 'qt5-declarative' 'virtualbox' 'virtualbox-sdk')
+optdepends=('muparser: Calculator plugin'
+ 'python: Python extension'
+ 'virtualbox: VirtualBox plugin')
source=("mirrors/albert::git+https://github.com/albertlauncher/albert.git#tag=v${pkgver}"
"mirrors/plugins::git+https://github.com/albertlauncher/plugins.git"
"mirrors/python::git+https://github.com/albertlauncher/python.git"
"mirrors/pybind11::git+https://github.com/pybind/pybind11.git")
-md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
prepare() {
+ mkdir -p build
cd "$srcdir/albert"
git submodule init
@@ -47,68 +33,43 @@ prepare() {
cd "$srcdir/albert/plugins"
git submodule init
- git config submodule.python/pybind11.url $srcdir/pybind11
- git config submodule.python/share/modules.url $srcdir/python
+ git config submodule.python/pybind11.url "$srcdir/pybind11"
+ git config submodule.python/share/modules.url "$srcdir/python"
git submodule update python/pybind11 python/share/modules
-
}
build() {
- echo -e "
-
- ╭──────────────────────────────────────────────╮
- │ │
- │ \e[31mThis is a plugin based application\e[0m │
- │ \e[31mCheck the optional dependencies\e[0m │
- │ │
- │ If you plan to report bugs please modify │
- │ the PKGBUILD to build the debug version. │
- │ │
- ╰──────────────────────────────────────────────╯
-"
-
- [[ -d "build" ]] || mkdir -p "build"
- cd "build"
+ cd build
- # https://ptpb.pw/_dFp
- cmake \
- "../${pkgname}" \
+ cmake ../$pkgname \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE="RelWithDebInfo " \
- -Wno-dev
+ -Wno-dev \
+ -DBUILD_WIDGETBOXMODEL=ON \
+ -DBUILD_QMLBOXMODEL=ON \
+ -DBUILD_APPLICATIONS=ON \
+ -DBUILD_CALCULATOR=ON \
+ -DBUILD_CHROMEBOOKMARKS=ON \
+ -DBUILD_DEBUG=OFF \
+ -DBUILD_FILES=ON \
+ -DBUILD_FIREFOXBOOKMARKS=ON \
+ -DBUILD_HASHGENERATOR=ON \
+ -DBUILD_MPRIS=ON \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_SSH=ON \
+ -DBUILD_SYSTEM=ON \
+ -DBUILD_TEMPLATE=OFF \
+ -DBUILD_TERMINAL=ON \
+ -DBUILD_VIRTUALBOX=ON
- # Maybe you want to add some of those
- # but remember to adjust the dependencies
-
- #-DCMAKE_BUILD_TYPE="Debug"
- #-DBUILD_WIDGETBOXMODEL=ON
- #-DBUILD_QMLBOXMODEL=ON
- #-DBUILD_APPLICATIONS=ON
- #-DBUILD_CALCULATOR=ON
- #-DBUILD_CHROMEBOOKMARKS=ON
- #-DBUILD_EXTERNALEXTENSIONS=ON
- #-DBUILD_DEBUG=OFF
- #-DBUILD_FILES=ON
- #-DBUILD_FIREFOXBOOKMARKS=ON
- #-DBUILD_HASHGENERATOR=ON
- #-DBUILD_KVSTORE=ON
- #-DBUILD_MPRIS=ON
- #-DBUILD_PYTHON=ON
- #-DBUILD_SSH=ON
- #-DBUILD_SYSTEM=ON
- #-DBUILD_TEMPLATE=OFF
- #-DBUILD_TERMINAL=ON
- #-DBUILD_VIRTUALBOX=ON
-
- #VERBOSE=1 make
make
}
package() {
- cd "${srcdir}/build"
+ cd build
+
make DESTDIR="$pkgdir/" install
}