summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Schneider2017-10-25 12:06:46 +0200
committerManuel Schneider2017-10-25 12:06:46 +0200
commit8690b464b4cecbb57962d892eeee613310761f56 (patch)
treeec1eb5ad4a5fc6ed7240c5d14930b2ad2b33b3da
parent02a0be2757fafc4b9e87c519147f341b026e3ef0 (diff)
downloadaur-8690b464b4cecbb57962d892eeee613310761f56.tar.gz
v0.14.4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39710472f487..4eb79f7d3fe1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Oct 21 17:59:37 UTC 2017
+# Wed Oct 25 10:05:54 UTC 2017
pkgbase = albert
pkgdesc = A sophisticated standalone keyboard launcher.
- pkgver = 0.14.3
+ pkgver = 0.14.4
pkgrel = 1
url = https://github.com/albertlauncher
arch = i686
@@ -28,7 +28,7 @@ pkgbase = albert
optdepends = virtualbox: VirtualBox plugin
provides = albert
conflicts = albert-git
- source = mirrors/albert::git+https://github.com/albertlauncher/albert.git#tag=v0.14.3
+ source = mirrors/albert::git+https://github.com/albertlauncher/albert.git#tag=v0.14.4
source = mirrors/plugins::git+https://github.com/albertlauncher/plugins.git
source = mirrors/python::git+https://github.com/albertlauncher/python.git
source = mirrors/pybind11::git+https://github.com/pybind/pybind11.git
diff --git a/PKGBUILD b/PKGBUILD
index 3cd8135fbcd6..92597bb2c6eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Manuel Schneider <manuelschneid3r at googles mail>
pkgname=albert
-pkgver=0.14.3
+pkgver=0.14.4
pkgrel=1
pkgdesc="A sophisticated standalone keyboard launcher."
arch=('i686' 'x86_64' 'armv7h')
@@ -31,6 +31,7 @@ optdepends=(
)
provides=('albert')
conflicts=('albert-git')
+#source=("mirrors/albert::git+https://github.com/albertlauncher/albert.git#branch=dev"
source=("mirrors/albert::git+https://github.com/albertlauncher/albert.git#tag=v${pkgver}"
"mirrors/plugins::git+https://github.com/albertlauncher/plugins.git"
"mirrors/python::git+https://github.com/albertlauncher/python.git"
@@ -71,10 +72,12 @@ build() {
[[ -d "build" ]] || mkdir -p "build"
cd "build"
+ # https://ptpb.pw/_dFp
cmake \
"../${pkgname}" \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE="MinSizeRel" \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE="RelWithDebInfo " \
-Wno-dev
# Maybe you want to add some of those
@@ -100,7 +103,7 @@ build() {
#-DBUILD_TERMINAL=ON
#-DBUILD_VIRTUALBOX=ON
- make -j $((`nproc`+1))
+ VERBOSE=1 make -j $((`nproc`+1))
}