summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Schneider2017-05-13 15:11:44 +0200
committerManuel Schneider2017-05-13 15:11:44 +0200
commit91afb9dd789a08189dce555f5450deb9f29dbb76 (patch)
treebb42f16c9703bd8676a290876d9b624104da4219
parenta69d112430afa64ca34770870306c46e67fdafb7 (diff)
downloadaur-91afb9dd789a08189dce555f5450deb9f29dbb76.tar.gz
v0.11.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4be7e3b09ea2..76d4afed2c13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Apr 16 11:22:55 UTC 2017
+# Sat May 13 13:11:44 UTC 2017
pkgbase = albert
pkgdesc = A DE agnostic omnilauncher.
- pkgver = 0.11.1
+ pkgver = 0.11.2
pkgrel = 1
url = https://github.com/ManuelSchneid3r/albert
arch = i686
@@ -18,8 +18,8 @@ pkgbase = albert
depends = qt5-svg
provides = albert
conflicts = albert-git
- source = https://github.com/ManuelSchneid3r/albert/archive/v0.11.1.tar.gz
- md5sums = 730ce21015116708a9314ee2fd50f78d
+ source = https://github.com/ManuelSchneid3r/albert/archive/v0.11.2.tar.gz
+ md5sums = 7de4f5a062a8fc1bb91f5cf8a2f2f72a
pkgname = albert
diff --git a/PKGBUILD b/PKGBUILD
index d33f94d15d03..7485fb24fc35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Manuel Schneider <manuelschneid3r at googles mail>
pkgname=albert
-pkgver=0.11.1
+pkgver=0.11.2
pkgrel=1
pkgdesc="A DE agnostic omnilauncher."
arch=('i686' 'x86_64')
@@ -12,16 +12,28 @@ provides=('albert')
conflicts=('albert-git')
source=(https://github.com/ManuelSchneid3r/albert/archive/v${pkgver}.tar.gz)
noextract=()
-md5sums=('730ce21015116708a9314ee2fd50f78d')
+md5sums=('7de4f5a062a8fc1bb91f5cf8a2f2f72a')
+
+# If you want a debug build, change CMAKE_BUILD_TYPE to 'Debug'
+#_build_type="Debug"
+_build_type="Release"
build() {
- echo -e "\e[41;20;1mIf you plan to report bugs please modify the PKGBUILD to build the debug version.\e[0m"
+ cat << EOD
+
+ ╭──────────────────────────────────────────────╮
+ │ │
+ │ If you plan to report bugs please modify │
+ │ the PKGBUILD to build the debug version. │
+ │ │
+ ╰──────────────────────────────────────────────╯
+
+EOD
[[ -d "${pkgname}-${pkgver}/build" ]] || mkdir -p "${pkgname}-${pkgver}/build"
cd "${pkgname}-${pkgver}/build"
- # If you want a debug build, change CMAKE_BUILD_TYPE to 'Debug'
- cmake ".." -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ cmake ".." -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=${_build_type}
make
}