summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Schneider2017-09-30 15:13:38 +0200
committerManuel Schneider2017-09-30 15:13:38 +0200
commita5f5fbe976e255a500fbc527d44ba665e194008f (patch)
tree4d72f4b5dad6d34aad83bf4b6ece9ab254924816
parent463aafab79f9ff0473a8ecf88985e38062536be6 (diff)
downloadaur-a5f5fbe976e255a500fbc527d44ba665e194008f.tar.gz
v0.13.1-2
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD31
2 files changed, 23 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db9e0acc4e30..8300baf0257a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
# Generated by mksrcinfo v8
-# Sat Sep 30 09:52:19 UTC 2017
+# Sat Sep 30 13:13:24 UTC 2017
pkgbase = albert
- pkgdesc = A DE agnostic omnilauncher.
+ pkgdesc = A sophisticated standalone keyboard launcher.
pkgver = 0.13.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/albertlauncher/albert
arch = i686
arch = x86_64
+ arch = armv7h
license = GPL
makedepends = git
makedepends = cmake
@@ -24,7 +25,9 @@ pkgbase = albert
optdepends = qt5-graphicaleffects: QML frontend
provides = albert
conflicts = albert-git
- source = git://github.com/albertlauncher/albert.git#tag=v0.13.1
+ source = git://github.com/albertlauncher/albert.git
+ source = git://github.com/albertlauncher/plugins.git
+ md5sums = SKIP
md5sums = SKIP
pkgname = albert
diff --git a/PKGBUILD b/PKGBUILD
index a10605c24fc6..ac042152e686 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Manuel Schneider <manuelschneid3r at googles mail>
pkgname=albert
pkgver=0.13.1
-pkgrel=1
-pkgdesc="A DE agnostic omnilauncher."
-arch=('i686' 'x86_64')
+pkgrel=2
+pkgdesc="A sophisticated standalone keyboard launcher."
+arch=('i686' 'x86_64' 'armv7h')
url="https://github.com/albertlauncher/albert"
license=('GPL')
depends=(
@@ -28,32 +28,33 @@ optdepends=(
)
provides=('albert')
conflicts=('albert-git')
-source=("git://github.com/albertlauncher/albert.git#tag=v${pkgver}")
-noextract=()
-md5sums=('SKIP')
+source=('git://github.com/albertlauncher/albert.git'
+ 'git://github.com/albertlauncher/plugins.git')
+md5sums=('SKIP' 'SKIP')
prepare() {
- cd ${pkgname}
-
- # Workaround permission problems, this should be fixed in v0.13.1
- sed -i 's/git@github.com:/https:\/\/github.com\//' .gitmodules
-
- git submodule update --init --recursive
+ cd "${srcdir}/albert"
+ git checkout "v${pkgver}" > /dev/null 2>&1
+ git submodule init
+ git config submodule.plugins.url $srcdir/plugins
+ git submodule update plugins
}
build() {
- cat << EOD
+ echo -e "
╭──────────────────────────────────────────────╮
│ │
+ │ \e[31mThis is a plugin based application\e[0m │
+ │ \e[31mCheck the optional dependencies\e[0m │
+ │ │
│ If you plan to report bugs please modify │
│ the PKGBUILD to build the debug version. │
│ │
╰──────────────────────────────────────────────╯
-
-EOD
+"
[[ -d "build" ]] || mkdir -p "build"
cd "build"