summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2022-11-28 16:06:27 -0500
committerTony Lambiris2022-11-28 16:06:27 -0500
commit0c58d54cbef48533c54ff84ad12010a79a162eb1 (patch)
tree7e76028f716e53b595d31c6fea868132aab74fd8
parent022a2f7c8142601cf3f02f17f1375f24821242b8 (diff)
downloadaur-0c58d54cbef48533c54ff84ad12010a79a162eb1.tar.gz
Version bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
2 files changed, 22 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 408d53745970..3e604d12e144 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = albert-git
pkgdesc = A sophisticated standalone keyboard launcher.
- pkgver = 0.17.6.r1.ge7edd9eb
+ pkgver = 0.17.6.r0.g77ab76d2
pkgrel = 1
url = https://github.com/albertlauncher/albert
arch = any
@@ -28,6 +28,10 @@ pkgbase = albert-git
source = albertlauncher/plugins::git+https://github.com/albertlauncher/plugins.git
source = albertlauncher/python::git+https://github.com/albertlauncher/python.git
source = albertlauncher/pybind11::git+https://github.com/pybind/pybind11.git
+ source = albertlauncher/xkcd-plugin::git+https://github.com/bergercookie/xkcd-albert-plugin.git
+ source = albertlauncher/jetbrains-plugin::git+https://github.com/mqus/jetbrains-albert-plugin.git
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d077539db596..8746e8518da7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@libpcap.net>
pkgname=albert-git
-pkgver=0.17.6.r1.ge7edd9eb
+pkgver=0.17.6.r0.g77ab76d2
pkgrel=1
pkgdesc="A sophisticated standalone keyboard launcher."
arch=('any')
@@ -17,10 +17,14 @@ optdepends=('muparser: Calculator plugin'
source=("albertlauncher/albert::git+https://github.com/albertlauncher/albert.git"
"albertlauncher/plugins::git+https://github.com/albertlauncher/plugins.git"
"albertlauncher/python::git+https://github.com/albertlauncher/python.git"
- "albertlauncher/pybind11::git+https://github.com/pybind/pybind11.git")
+ "albertlauncher/pybind11::git+https://github.com/pybind/pybind11.git"
+ "albertlauncher/xkcd-plugin::git+https://github.com/bergercookie/xkcd-albert-plugin.git"
+ "albertlauncher/jetbrains-plugin::git+https://github.com/mqus/jetbrains-albert-plugin.git")
sha256sums=('SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -30,24 +34,28 @@ pkgver() {
}
prepare() {
- cd "${srcdir}/albert"
-
mkdir -p build
- cd "${srcdir}"/albert
+ cd "${srcdir}/albert"
git submodule init
git config submodule.plugins.url "${srcdir}/plugins"
- git submodule update plugins
+ git -c protocol.file.allow=always submodule update plugins
cd "${srcdir}/albert/plugins"
git submodule init
git config submodule.python/pybind11.url "${srcdir}/pybind11"
git config submodule.python/share/modules.url "${srcdir}/python"
- git submodule update python/pybind11 python/share/modules
+ git -c protocol.file.allow=always submodule update python/pybind11 python/share/modules
+
+ cd "${srcdir}/albert/plugins/python/share/modules"
+ git submodule init
+ git config submodule.jetbrains_projects.url "${srcdir}/jetbrains-plugin"
+ git config submodule.xkcd.url "${srcdir}/xkcd-plugin"
+ git -c protocol.file.allow=always submodule update --remote --merge jetbrains_projects xkcd
}
build() {
- cd "${srcdir}/albert/build"
+ cd "${srcdir}/build"
cmake "${srcdir}/albert" \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -76,7 +84,7 @@ build() {
}
package() {
- cd "${srcdir}/albert/build"
+ cd "${srcdir}/build"
make DESTDIR="${pkgdir}" install
}