summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2023-01-20 20:47:49 -0500
committerTony Lambiris2023-01-20 20:47:49 -0500
commitfc302e4271b9ff6b377e9296db4bddfaeeda0ca3 (patch)
tree9845cb6778bec332a409ba97b78720e986a3b660
parent0c58d54cbef48533c54ff84ad12010a79a162eb1 (diff)
downloadaur-fc302e4271b9ff6b377e9296db4bddfaeeda0ca3.tar.gz
Version bump
-rw-r--r--.SRCINFO50
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD135
3 files changed, 87 insertions, 100 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e604d12e144..a77c58a7909e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,40 +1,28 @@
pkgbase = albert-git
- pkgdesc = A sophisticated standalone keyboard launcher.
- pkgver = 0.17.6.r0.g77ab76d2
+ pkgdesc = A sophisticated standalone keyboard launcher
+ pkgver = 0.19.2.r4.g33b4acae
pkgrel = 1
- url = https://github.com/albertlauncher/albert
- arch = any
+ url = https://github.com/albertlauncher
+ arch = x86_64
license = GPL
makedepends = cmake
makedepends = git
makedepends = muparser
+ makedepends = pybind11
makedepends = python
- makedepends = qt5-declarative
- makedepends = qt5-svg
- makedepends = virtualbox
- makedepends = virtualbox-sdk
- depends = qt5-charts
- depends = qt5-graphicaleffects
- depends = qt5-quickcontrols
- depends = qt5-svg
- depends = qt5-x11extras
- depends = libx11
- optdepends = muparser: Calculator plugin
- optdepends = python: Python extension
- optdepends = virtualbox: VirtualBox plugin
- provides = albert
- conflicts = albert
- source = albertlauncher/albert::git+https://github.com/albertlauncher/albert.git
- source = albertlauncher/plugins::git+https://github.com/albertlauncher/plugins.git
- source = albertlauncher/python::git+https://github.com/albertlauncher/python.git
- source = albertlauncher/pybind11::git+https://github.com/pybind/pybind11.git
- source = albertlauncher/xkcd-plugin::git+https://github.com/bergercookie/xkcd-albert-plugin.git
- source = albertlauncher/jetbrains-plugin::git+https://github.com/mqus/jetbrains-albert-plugin.git
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ depends = hicolor-icon-theme
+ depends = qt6-scxml
+ depends = qt6-svg
+ optdepends = muparser: calculator plugin
+ optdepends = python: python extension
+ optdepends = python-urllib3: python web plugins
+ source = mirrors/albert::git+https://github.com/albertlauncher/albert.git
+ source = mirrors/plugins::git+https://github.com/albertlauncher/plugins.git
+ source = mirrors/python::git+https://github.com/albertlauncher/python.git
+ source = mirrors/qhotkey::git+https://github.com/Skycoder42/QHotkey.git
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
pkgname = albert-git
diff --git a/.gitignore b/.gitignore
index cb91e8de9d80..e9b1135377a0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
src
pkg
tags
-albertlauncher
+mirrors
*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 8746e8518da7..30cf3da6ca28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,90 +1,89 @@
# Maintainer: Tony Lambiris <tony@libpcap.net>
pkgname=albert-git
-pkgver=0.17.6.r0.g77ab76d2
+_pkgname=${pkgname%-git}
+pkgver=0.19.2.r4.g33b4acae
pkgrel=1
-pkgdesc="A sophisticated standalone keyboard launcher."
-arch=('any')
-url="https://github.com/albertlauncher/albert"
+pkgdesc="A sophisticated standalone keyboard launcher"
+arch=('x86_64')
+url="https://github.com/albertlauncher"
license=('GPL')
-provides=('albert')
-conflicts=('albert')
-depends=('qt5-charts' 'qt5-graphicaleffects' 'qt5-quickcontrols' 'qt5-svg' 'qt5-x11extras' 'libx11')
-makedepends=('cmake' 'git' 'muparser' 'python' 'qt5-declarative' 'qt5-svg' 'virtualbox' 'virtualbox-sdk')
-optdepends=('muparser: Calculator plugin'
- 'python: Python extension'
- 'virtualbox: VirtualBox plugin')
-source=("albertlauncher/albert::git+https://github.com/albertlauncher/albert.git"
- "albertlauncher/plugins::git+https://github.com/albertlauncher/plugins.git"
- "albertlauncher/python::git+https://github.com/albertlauncher/python.git"
- "albertlauncher/pybind11::git+https://github.com/pybind/pybind11.git"
- "albertlauncher/xkcd-plugin::git+https://github.com/bergercookie/xkcd-albert-plugin.git"
- "albertlauncher/jetbrains-plugin::git+https://github.com/mqus/jetbrains-albert-plugin.git")
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
+depends=('hicolor-icon-theme' 'qt6-scxml' 'qt6-svg')
+makedepends=('cmake' 'git' 'muparser' 'pybind11' 'python')
+optdepends=('muparser: calculator plugin'
+ 'python: python extension'
+ 'python-urllib3: python web plugins')
+source=("mirrors/albert::git+https://github.com/albertlauncher/albert.git"
+ "mirrors/plugins::git+https://github.com/albertlauncher/plugins.git"
+ "mirrors/python::git+https://github.com/albertlauncher/python.git"
+ "mirrors/qhotkey::git+https://github.com/Skycoder42/QHotkey.git")
+sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP')
pkgver() {
- cd "${srcdir}/albert"
+ cd "$srcdir/albert"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
}
prepare() {
- mkdir -p build
-
- cd "${srcdir}/albert"
- git submodule init
- git config submodule.plugins.url "${srcdir}/plugins"
- git -c protocol.file.allow=always submodule update plugins
-
- cd "${srcdir}/albert/plugins"
- git submodule init
- git config submodule.python/pybind11.url "${srcdir}/pybind11"
- git config submodule.python/share/modules.url "${srcdir}/python"
- git -c protocol.file.allow=always submodule update python/pybind11 python/share/modules
-
- cd "${srcdir}/albert/plugins/python/share/modules"
- git submodule init
- git config submodule.jetbrains_projects.url "${srcdir}/jetbrains-plugin"
- git config submodule.xkcd.url "${srcdir}/xkcd-plugin"
- git -c protocol.file.allow=always submodule update --remote --merge jetbrains_projects xkcd
+ mkdir -p build
+
+ cd "$srcdir/albert"
+ git submodule init
+
+ git config submodule.plugins.url "$srcdir/plugins"
+ git -c protocol.file.allow=always submodule update plugins
+
+ git config submodule.lib/QHotkey.url "$srcdir/qhotkey"
+ git -c protocol.file.allow=always submodule update lib/QHotkey
+
+ cd "$srcdir/albert/plugins"
+ git submodule init
+ git config submodule.python/plugins.url "$srcdir/python"
+ git -c protocol.file.allow=always submodule update python/plugins
}
+
build() {
- cd "${srcdir}/build"
-
- cmake "${srcdir}/albert" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -Wno-dev \
- -DBUILD_WIDGETBOXMODEL=ON \
- -DBUILD_QMLBOXMODEL=ON \
- -DBUILD_APPLICATIONS=ON \
- -DBUILD_CALCULATOR=ON \
- -DBUILD_CHROMEBOOKMARKS=ON \
- -DBUILD_EXTERNALEXTENSIONS=ON \
- -DBUILD_DEBUG=OFF \
- -DBUILD_FILES=ON \
- -DBUILD_FIREFOXBOOKMARKS=ON \
- -DBUILD_HASHGENERATOR=ON \
- -DBUILD_KVSTORE=ON \
- -DBUILD_MPRIS=ON \
- -DBUILD_PYTHON=ON \
- -DBUILD_SSH=ON \
- -DBUILD_SYSTEM=ON \
- -DBUILD_TEMPLATE=OFF \
- -DBUILD_TERMINAL=ON \
- -DBUILD_VIRTUALBOX=ON
-
- make
+ cd build
+
+ cmake ../$_pkgname \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_FIND_PACKAGE_RESOLVE_SYMLINKS=ON \
+ -DQHOTKEY_INSTALL=OFF \
+ -DBUILD_WIDGETSBOXMODEL=ON \
+ -DBUILD_APPLICATIONS_XDG=ON \
+ -DBUILD_CALCULATOR=ON \
+ -DBUILD_CHROMIUM=ON \
+ -DBUILD_DEBUG=OFF \
+ -DBUILD_FILES=ON \
+ -DBUILD_HASH=ON \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_SNIPPETS=ON \
+ -DBUILD_SSH=ON \
+ -DBUILD_SYSTEM=ON \
+ -DBUILD_TEMPLATE=OFF \
+ -DBUILD_TERMINAL=ON \
+ -DBUILD_URLHANDLER=ON \
+ -DBUILD_WEBSEARCH=ON
+
+ make
}
+
package() {
- cd "${srcdir}/build"
+ cd build
+
+ make DESTDIR="$pkgdir/" install
- make DESTDIR="${pkgdir}" install
+ # remove some trash
+ rm -r "$pkgdir/usr/share/albert/python/plugins/.archive"
+ rm -r "$pkgdir/usr/share/albert/python/plugins/.git"*
}
+
+# vim:set ts=2 sw=2 et: